Regional setting used (1 Viewer)

fredco

Portal Pro
November 13, 2010
88
15
Netherlands Netherlands
Country flag
When importing movies, Moving Pictures uses the regional format from Windows to determine which language to use when scraping the GENRE of a movie. My setting is to scrape everything in English. All meta data is in English EXEPT for the Genre tag. That is in Dutch when I have my format setting at "Dutch". When I change this to English (United States) all is good again. Is this a bug?
 

ltfearme

Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,698
    7,083
    Sydney
    Australia Australia
    Country flag
    Sorry for the late reply, I actually replied a long time ago and found out that my message was still in a draft form so didn't look like it submitted.

    Sounds like a bug, it might be a something specific to that scraper. Can you try test with the default themoviedb.org scraper, that is a good English only one and very reliable.

    Can't tell you more without a closer look at the code.
     

    fredco

    Portal Pro
    November 13, 2010
    88
    15
    Netherlands Netherlands
    Country flag
    Thanks. I immediately tried with themoviedb.org. It makes things worse: now not only the genre but also the SUMMARY are in Dutch. I normally use IMDb+ for all my movies and when I revert back to this scraper, the problem is back to just the GENRE. Like I said: regional setting is DUTCH. When I put that back to English, all is ok.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,698
    7,083
    Sydney
    Australia Australia
    Country flag
    You might need to override your language to English in the Data Sources section, have you done that by any chance?
    upload_2018-12-3_7-10-29.png


    If set to manual it will use the regional settings for language where possible. I use manual, but I have English regional settings so I can't confirm whether that setting will definitely work for you....in theory it should but before switching disable all sources except for themoviedb.org as thats a source I can maintain and fix if its not being respected.
     

    Attachments

    fredco

    Portal Pro
    November 13, 2010
    88
    15
    Netherlands Netherlands
    Country flag
    I also ALWAYS use manual, because I want IMDb+ being used as primary scraper. I have my regional settings ALWAYS to Dutch also. But this issue started a few months ago, before it didn't happen. But I still will give it a try and report back.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,698
    7,083
    Sydney
    Australia Australia
    Country flag
    I think if you disable all sources but IMDb+ then and then set to 'English' in the configuration it might work for you. Im pretty sure it should respect disabled/enabled sources when set to auto with language override.
     

    fredco

    Portal Pro
    November 13, 2010
    88
    15
    Netherlands Netherlands
    Country flag
    When I disable all sources except IMDb+, set data sources to auto and language to English it scrapes using themoviedb.org (although it was disabled). Language is now good: both Genre and Summary and all other metadata is in English. But now it does not use IMDb+ automatically, I have to do this manually. Still strange that it happened recently. Could it have something to do with the new version of Moving Pictures that came out in september?
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,698
    7,083
    Sydney
    Australia Australia
    Country flag
    Not sure, I don't recall any work done that could affect that. Could of been a scraper change though which affects what you see.
     

    tooker

    Portal Member
    September 27, 2012
    13
    8
    38
    Saint-Petersburg
    Russian Federation Russian Federation
    Country flag
    I have same thing as fredco. I use IMDB+ as a scraper so Data Sources option is set to manual. All meta data is in English exept cover arts. They are in Russian. I receive English cover arts only when I change system format in control panel to English.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,345
    1,824
    Country flag
    @fredco, IMDb+ allows overrule of the language in the IMDb+ plugin settings (requires the MediaPortal Extension plugin to be installed, and then you can do it via GUI).

    The problem is that a lot of the Dutch language support features on IMDb+ rely on moviemeter.nl and they don't allow anonymous API access, and I cannot include my API keys in the open source. For that solution I used to host a proxy page on my domain, but both my damn hosting companies decided to throw in the towel and seize to operate (still mad about it). They both did it at a time I was busy with work, and notified me at the last minute, so thankfully was able to make last-ditch effort backup with hours to spare, but not the proper migration to a new host. Then work got busy again, and I kept forgetting as well. Hell I bought two new VPSes last Black Friday and they still are not configured to begin the migration process.

    IMDb.com with Dutch should somewhat work, but it will be acting weird, until I rehost the PHP script somewhere.

    No idea how @ltfearme does it, but now that I'm reminded again I've made a note to check this weekend.

    Feel free to provide detailed logs the way tooker did on his Russian issue on the IMDb+ forum though, because once I found the time it was a 5-minute fix (could not have done that without the way tooker provided the exact log files I need), and waiting on him to provide logs again to solve the cover issue. Should be able to quickly identify the IMDb.com Dutch issue and make that work, until MovieMeter.nl proxy is up and running again.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R Correct setting for recordings on shared folder General 0
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    M [fixed] [MP2-831] 12h time format shown in TV Guide with Swedish language settings Submit: Bug Reports 27
    joEhSuper Backup Setting - ErrorBackupFolder TV-Server 9
    Rob Hexenmeister [solved] Customising Fanart Handler settings Fanart Handler 3
    joecrow AMD Radeon Settings app. won't start after hibernation. General Support 0
    L [solved] Modifying programmed recording after setting it General 0
    B [solved] How to manually set MAC of TV Server for WOL Installation, configuration support 2
    X MadVR Settings Video & DVD 2
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    D Correct wake-on-lan settings General 3
    G MP Crashed during setting up recording. Newcomers Forum 1
    cbr954rr Overtake/overwrite settings for all clients Feature Requests 0
    cbr954rr Same settings on all Clients? General 6
    framug 1.22.0 BasicHome Editor settings for DefaultWide HD skin not kept when update 1.22 3
    N [Question] [MP2-493] Default culture not saved in settings MediaPortal 2 0
    cbr954rr Movie sets in films General 20
    D PC rebuild & MP2 upgrade - how to preserve database and settings? General 1
    cbr954rr Possibillity to export and import all client settings? General 0
    morpheus_xx [Finished] [MP2-802] TV-Settings availability in all TV screens MediaPortal 2 12
    N [will not fix] Changed settings do not take effect until MP2-Client is stopped and restarted. Submit: Bug Reports 4
    ajs [solved] Latest Media Handler - Skin settings - Custom latests items number Fanart Handler 27
    Rob Hexenmeister [solved] Latests Media Handler - Skinning an updating window or control Fanart Handler 26
    A Operating System Important Win10 Settings for MP Operating System 1
    T Mp 1.20 won't play .265 hdr capable file......settings problem? logs inc. Watch / Listen Media 0
    Similar threads

























    Top Bottom