Remember last viewed channel (1 Viewer)

Razorblade

Portal Pro
May 22, 2010
99
3
Home Country
Germany Germany
Hello Forum,

Some days ago my MP SQL database crashed an I had to rebuilt it.

Until then my TV client did remember the last viewed TV channel even after a reboot. So even after rebooting my TV client and then turning on TV, the client automatically tuned to the last viewed channel, e.g. channel 5.

But after rebuilding the database my TV client always tunes to the first channel of the "All channels" group regardless of the last viewed channel.

Am I missing a checkbox?
Where's that option to remember that last viewed channel?

I am using MP 1.2.3 in a TV server / TV client environment

Thanks
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Hello Razorblade

    Some days ago my MP SQL database crashed an I had to rebuilt it.
    Did you rebuild from scratch as "rebuild" implies, or did you repair (mysqlcheck --auto-repair)?

    Am I missing a checkbox?
    Where's that option to remember that last viewed channel?
    It should be automatic. The channel is stored to your MediaPortal.xml file.

    mm
     

    Razorblade

    Portal Pro
    May 22, 2010
    99
    3
    Home Country
    Germany Germany
    Hello mm,

    thanks for your answer.

    I am using a MSSQL database. Due to an unrecoverable error in the database I had to export the server settings to an xml file, drop the database and then create a new one. After that I did an import of the xml settings.
    So far so good :)

    Since then one my two TV clients is showing that behaviour.
    I can't tell if the database error is the reason for that or if this is just coincidence.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Since then one my two TV clients is showing that behaviour.
    I can't tell if the database error is the reason for that or if this is just coincidence.
    I would say coincidence. As previously mentioned, the last-viewed-channel is stored in MediaPortal.xml. In other words, it is totally a client-side concern and has no connection to the database.

    You can open the MediaPortal.xml file in any text editor:
    1. Open MP configuration.
    2. Click "User config files" in the top left corner, then "open log directory".
    3. Go one level up. Now you should see MediaPortal.xml.

    If you open it, look for the "mytv" section:
    Code:
      <section name="mytv"> 
        ...
        <entry name="group">All Channels</entry> 
        <entry name="channel">Channel 4</entry>
        ...
      </section>

    The two entries mentioned above store the last viewed channel and group.

    mm
     

    Razorblade

    Portal Pro
    May 22, 2010
    99
    3
    Home Country
    Germany Germany
    Thanks for that hint with the MediaPortal.xml file.

    I just opened that file in notepad, saved and closed it. That did the trick.
     

    Users who are viewing this thread

    Similar threads

    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Replies
    0
    Views
    509
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up a running mediaportal setup. Without the logs however, I don't have a clue on what exactly is wrong...
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up...
    Hi there, I'm a happy long time user and am currently using MP 1.25. Up until now I had no issues with my setup. Yesterday...
    Replies
    1
    Views
    555
    In lieu of a likely modification to TV Setup module, I have devised my own workaround, using SQL. Here is a quick resume. Should be safe but make sure you have a backup before you try this! Simple scenario to demonstrate. 2 cards both on A/B diseqc switches. In each case A connects to LNB pointed at Satelite 1, and B to Sat 2...
    In lieu of a likely modification to TV Setup module, I have devised my own workaround, using SQL. Here is a quick resume. Should be...
    Started on: 2020-08-25 last update: 2020-08-25 Summary: Add the ability to sort or restrict channels by group in mapping dialog...
    Replies
    4
    Views
    757
    duplicate post see below for for solution https://forum.team-mediaportal.com/threads/mp-suddenly-crashes-when-starting-live-tv-on-most-channels-and-on-recordings-from-the-same-channels.139849/#post-1270831
    duplicate post see below for for solution...
    I have been using MP 1 for years with no troubles. but in the last couple of days it sudden just crashes when starting live tv...
    Replies
    1
    Views
    3K
    This problem still exists with MP 1.29.
    This problem still exists with MP 1.29.
    When installing MP1, the TV DB configuration dialog specifies SQL Server 2005 (see attached file "Setup database connection -...
    Replies
    5
    Views
    1K
    Top Bottom