remote client: no connection after server standby

Discussion in 'Television (MyTV frontend and TV-Server)' started by joystick, February 14, 2009.

  1. joystick
    • Premium Supporter

    joystick MP Donator

    Joined:
    January 26, 2006
    Messages:
    892
    Likes Received:
    38
    Ratings:
    +40 / 1
    Home Country:
    Germany Germany
    TV-Server Version: TVE3 MP1
    MediaPortal Version: MP1
    MediaPortal Skin: Streamed MP
    Windows Version: XP SP3
    CPU Type: Intel C2D 6550
    HDD: 2 x Samsung 500GB, 1xSamsung 1TB
    Memory: DDR2 3GB
    Motherboard: AUSUS P5K-E WiFi AP
    Video Card: His Radeon HD2600 XT
    Video Card Driver: 8.11
    Sound Card: Realtech onboard
    Sound Card AC3: Optical out
    Sound Card Driver:
    1. TV Card: FireDTV
    1. TV Card Type: DVB-C
    1. TV Card Driver: latest stable
    2. TV Card: Firedtv
    2. TV Card Type: DVB-C
    2. TV Card Driver: latest stable
    3. TV Card: KNC-One
    3. TV Card Type: DVB-C
    3. TV Card Driver: latest stable
    4. TV Card: KNC-One
    4. TV Card Type: DVB-C
    4. TV Card Driver: latest stable
    MPEG2 Video Codec: PDVD 8
    MPEG2 Audio Codec: PDVD 8
    h.264 Video Codec: PDVD 8
    Satelite/CableTV Provider: Kabel Deutschland
    HTPC Case: Zalman HD160 incl. Irtrans
    Cooling: Fan
    Power Supply: Nesteq 500 Watts silent
    Remote: Logitech Harmony 525
    TV: Samsung Plasma 50''
    TV - HTPC Connection: DVI->HDMI

    Hi all,

    my MP1 Server/Client machine is running super including standby and resume without external help (MPstandby handler etc).

    My problem is that my remote MP clients cannot connect to the Server box when the server resumed from standby.
    After a TV service restart everything is working fine again.

    The problem is caused by the MSSQLserver browser which does not seem to run correctly after standby.

    how could I solve this issue (without MPstandbyhandler)?



    cheers

    joystick
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. joystick
    • Premium Supporter

    joystick MP Donator

    Joined:
    January 26, 2006
    Messages:
    892
    Likes Received:
    38
    Ratings:
    +40 / 1
    Home Country:
    Germany Germany
    fixed the issue by deactivating "reinitialize service after standby".

    I only hope this will not cause other issues.... so far everything seems to work fine, though!!

    cheers
    joystick
     
  4. nachttier

    nachttier Portal Pro

    Joined:
    March 31, 2006
    Messages:
    86
    Likes Received:
    1
    Occupation:
    Computer Engineer
    Location:
    Viernheim
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hello,

    I can confirm this behavior on my system. Singleseat everything works very well, but when I want to access the server through another machine after the server had been in standby, something just seems to get stuck at some point.
    How did you figure out that the SQL server is the cause for this behavior? I could not find any evidence in the logs. Furthermore I am using MySQL and experience the same. I will add logs when I get home.
    Deactivating the reinitialization of the service does indeed help, but I think that this is not the way it was meant to work. Additionally, I need the reinitialization function, since otherwise TV will not work if the server was put into standby while TV was active (=not idle).

    But I am still not sure if I should post a bugreport.

    Regards,
    nachttier
     
  5. joystick
    • Premium Supporter

    joystick MP Donator

    Joined:
    January 26, 2006
    Messages:
    892
    Likes Received:
    38
    Ratings:
    +40 / 1
    Home Country:
    Germany Germany
    my conclusion that the sql server is the bad guy is only based on the fact that the Tv server is running on the local machine, and that the remote client is not....
    after a restart of the tvservice (which also restarts the serverbrowser---- i think) everything is working fine, thus it had to be the sql server in my opinion.

    cheers

    joystick
     
  6. nachttier

    nachttier Portal Pro

    Joined:
    March 31, 2006
    Messages:
    86
    Likes Received:
    1
    Occupation:
    Computer Engineer
    Location:
    Viernheim
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi,

    I just finished collecting the logs from server and client. All I did is wake up the server (WOL) and then starting Mediaportal on the client and trying to start TV.
    The client got stuck as always, so I had to kill Mediaportal.
    This is reflected in the Mediaportal.log and the last lines:
    Code (Text):
    1.  
    2. 2009-03-03 20:12:06.219462 [Info.][MPMain]: get all groups from database
    3. 2009-03-03 20:12:06.416462 [Info.][MPMain]: loaded 2 tv groups
    4. 2009-03-03 20:12:06.418462 [Info.][MPMain]: tv home init:ProSieben
    5. 2009-03-03 20:12:06.422462 [Info.][MPMain]: TVHome.ViewChannelAndCheck(): View channel=ProSieben
    6. 2009-03-03 20:12:07.762462 [Info.][MPMain]: succeeded:Succeeded TvControl.VirtualCard
    7. 2009-03-03 20:12:07.797462 [Info.][MPMain]: tvhome:startplay
    8. 2009-03-03 20:12:07.803462 [Info.][MPMain]: tvhome:file:D:\Aufnahmen\timeshift\live1-0.ts.tsbuffer
    9. 2009-03-03 20:12:07.816462 [Warn.][MPMain]: tvhome:startplay.  Phase 1 - 49 ms - Done method initialization
    10. 2009-03-03 20:12:07.819462 [Info.][MPMain]: tvhome:startplay:rtsp://HTPC/stream1.0 - using rtsp mode:True
    11. 2009-03-03 20:12:07.858462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: inspecting media : rtsp://HTPC/stream1.0
    12. 2009-03-03 20:12:07.859462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: FrameRate : 0
    13. 2009-03-03 20:12:07.859462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: VideoCodec :
    14. 2009-03-03 20:12:07.860462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: Scan type :
    15. 2009-03-03 20:12:07.860462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: IsInterlaced: False
    16. 2009-03-03 20:12:07.861462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: Width : 0
    17. 2009-03-03 20:12:07.861462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: Height : 0
    18. 2009-03-03 20:12:07.862462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: Audiochannels : 0
    19. 2009-03-03 20:12:07.862462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: Audiorate : 0
    20. 2009-03-03 20:12:07.863462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: AspectRatio :
    21. 2009-03-03 20:12:07.863462 [Info.][MPMain]: MediaInfoWrapper.MediaInfoWrapper: AudioCodec :
    22. 2009-03-03 20:12:07.871462 [Info.][MPMain]: RefreshRateChanger.AdaptRefreshRate: 'auto refreshrate changer' disabled
    23. 2009-03-03 20:12:07.871462 [Info.][MPMain]: g_Player.Play(rtsp://HTPC/stream1.0 TV)
    24. 2009-03-03 20:12:07.872462 [Info.][MPMain]: RefreshRateChanger.AdaptRefreshRate: 'auto refreshrate changer' disabled
    25. 2009-03-03 20:12:07.907462 [Info.][MPMain]: TSReaderPlayer play:rtsp://HTPC/stream1.0 radio:False
    26. 2009-03-03 20:12:07.907462 [Info.][MPMain]: TSReaderPlayer: live tv
    27. 2009-03-03 20:12:07.909462 [Info.][MPMain]: TSReaderPlayer: Enabling DX9 exclusive mode
    28. 2009-03-03 20:12:07.909462 [Info.][MPMain]: TSReaderPlayer:play rtsp://HTPC/stream1.0
    29. 2009-03-03 20:12:07.950462 [Info.][MPMain]: TSReaderPlayer:cleanup DShow graph False
    30. 2009-03-03 20:12:07.951462 [Info.][MPMain]: TSReaderPlayer:grapbuilder=null
    31. 2009-03-03 20:12:07.972462 [Info.][MPMain]: TSReaderPlayer: Cleanup done
    32. 2009-03-03 20:12:08.000462 [Info.][MPMain]: TSReaderPlayer: GetInterfaces()
    33. 2009-03-03 20:12:08.001462 [Info.][MPMain]: TSReaderPlayer:cleanup DShow graph False
    34. 2009-03-03 20:12:08.001462 [Info.][MPMain]: TSReaderPlayer:grapbuilder=null
    35. 2009-03-03 20:12:08.022462 [Info.][MPMain]: TSReaderPlayer: Cleanup done
    36. 2009-03-03 20:12:08.034462 [Info.][MPMain]: TSReaderPlayer: add _vmr9
    37. 2009-03-03 20:12:08.042462 [Info.][MPMain]: VMR9: added EVR Renderer to graph
    38. 2009-03-03 20:12:08.133462 [Info.][MPMain]: TSReaderPlayer: add codecs
    39. 2009-03-03 20:12:08.477462 [Info.][MPMain]: added filter:CyberLink Video/SP Decoder (PDVD7) to graph
    40. 2009-03-03 20:12:08.844462 [Info.][MPMain]: added filter:CyberLink H.264/AVC Decoder (PDVD7) to graph
    41. 2009-03-03 20:12:08.850462 [Info.][MPMain]: added filter:AC3Filter to graph
    42. 2009-03-03 20:12:08.855462 [Info.][MPMain]: added filter:MONOGRAM AAC Decoder to graph
    43. 2009-03-03 20:12:08.862462 [Info.][MPMain]: DirectShowUtils: First try to insert new audio renderer Default DirectSound Device
    44. 2009-03-03 20:12:08.862462 [Info.][MPMain]: DirectShowUtils: Found audio renderer
    45. 2009-03-03 20:12:08.874462 [Info.][MPMain]: TSReaderPlayer:add TsReader to graph
    46. 2009-03-03 20:12:08.875462 [Info.][MPMain]: TSReaderPlayer: open file: rtsp://HTPC/stream1.0
    47.  
    to me this does not look like a problem with the SQL server.
    On the server it can be observed that the stream is started but the client somehow does not pick it up. Therefore the server thinks the client is idle and kicks it:
    Code (Text):
    1.  
    2. 2009-03-03 20:12:30.232554 [23]: card: WaitForTimeShiftFile - video and audio are seen after 0,4091535 seconds
    3. 2009-03-03 20:12:30.237437 [23]: user:Saphod card:1 sub:0 add stream:D:\Aufnahmen\timeshift\live1-0.ts.tsbuffer
    4. 2009-03-03 20:12:30.237437 [23]: RTSP: start streamer
    5. 2009-03-03 20:12:30.238413 [RTSP Streaming thread]: RTSP: Streamer started
    6. 2009-03-03 20:12:30.239390 [23]: RTSP: add stream stream1.0 file:D:\Aufnahmen\timeshift\live1-0.ts.tsbuffer
    7. 2009-03-03 20:12:30.241343 [23]: Controller: StartTimeShifting started on card:1 to D:\Aufnahmen\timeshift\live1-0.ts.tsbuffer
    8. 2009-03-03 20:12:30.248178 [Channel state thread]: Controller: DoSetChannelStates for 15 channels
    9. 2009-03-03 20:13:57.269952 [HeartBeatMonitor]: Controller: Heartbeat Monitor - kicking idle user Saphod
    10. 2009-03-03 20:13:57.279717 [HeartBeatMonitor]: Controller: StopTimeShifting 1
    11. 2009-03-03 20:13:57.287529 [HeartBeatMonitor]: card TechnoTrend BDA/DVB-S Tuner: StopTimeShifting user:Saphod sub:0
    12.  
    Would be nice if some dev could take a quick glimpse at this. I wonder why this has not been reported before. I think I saw this behavior since 1.0, so chances are that its only an error on my end, but I don't know what it could be.
    And as a reminder: it all works well if I restart the TV service or if I disable the reinitialization of the TV service in the powerscheduler plugin.

    Regards,
    nachttier
     
  7. nachttier

    nachttier Portal Pro

    Joined:
    March 31, 2006
    Messages:
    86
    Likes Received:
    1
    Occupation:
    Computer Engineer
    Location:
    Viernheim
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Show System Specs
    *bump*

    No one having an idea why this is happening?
    Can someone confirm that it is working for him/her?

    Regards,
    nachttier
     
  8. joystick
    • Premium Supporter

    joystick MP Donator

    Joined:
    January 26, 2006
    Messages:
    892
    Likes Received:
    38
    Ratings:
    +40 / 1
    Home Country:
    Germany Germany
    *bump*
    this is still happening with 1.01.... :(

    cheers

    joystick
     
  9. happyf1sh

    happyf1sh Portal Member

    Joined:
    August 26, 2007
    Messages:
    43
    Likes Received:
    11
    Ratings:
    +15 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hello joystick,

    Do you still have this problem because I appear to have the same issue?

    Did you find a solution?

    happyf1sh
     
  10. joystick
    • Premium Supporter

    joystick MP Donator

    Joined:
    January 26, 2006
    Messages:
    892
    Likes Received:
    38
    Ratings:
    +40 / 1
    Home Country:
    Germany Germany
    the only solution for me was using mp standby handler -> restarting tv service after standby.
    However it could be that the problem does not come up when using MySql instead of MSSQL (but thats only a guess)

    cheers

    joystick
     
  11. nachttier

    nachttier Portal Pro

    Joined:
    March 31, 2006
    Messages:
    86
    Likes Received:
    1
    Occupation:
    Computer Engineer
    Location:
    Viernheim
    Ratings:
    +1 / 0
    Home Country:
    Germany Germany
    Show System Specs
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!