[Resolved] No fanart for "Who is America?"

Discussion in 'My TVSeries' started by fischy667, August 17, 2018.

  1. fischy667
    • Super User

    fischy667 Super User

    Joined:
    May 5, 2010
    Messages:
    930
    Likes Received:
    181
    Gender:
    Male
    Occupation:
    physicist - Software Tester
    Location:
    Rostock
    Ratings:
    +353 / 1
    Home Country:
    Germany Germany
    Show System Specs
    I do not see fanart for the series "Who is America?" although the plugin did download some and they are marked as local in the fanart view.

    I also recognized that new fanarts do not have the usual name structure (<series id>-<number>.jpg), they have a random number starting with 5. Maybe this is the problem??



    I attached some screenshots, my database and the log. Hopefully it helps you to find and solve the problem.
     

    Attached Files:

    • Like Like x 2
    • Thank You! Thank You! x 1
    • Informative Informative x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. volumia

    volumia Portal Pro

    Joined:
    November 23, 2011
    Messages:
    96
    Likes Received:
    18
    Gender:
    Male
    Location:
    whereever my feet take me...
    Ratings:
    +34 / 0
    Home Country:
    Netherlands Netherlands
    Same thing here. The fanart was downloaded and present in the database, but just not showing.
    With me it is for example for the seies "Take Two".
     
  4. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,451
    Likes Received:
    4,231
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,371 / 0
    Home Country:
    Australia Australia
    Thanks, I will look into it.

    Those strange filenames are not isolated to fanart, I have seen some for banners and posters as well. It is possibly the cause of the issue, but will need to review the code to find out.
     
    Last edited: August 29, 2018
    • Thank You! Thank You! x 1
  5. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,451
    Likes Received:
    4,231
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,371 / 0
    Home Country:
    Australia Australia
    Looking at the code that searches for available fanart on disk, it uses the series ID as a filter so these filenames are definitely spooking it.

    I will need to ensure the files have expected filename before saving to disk or change logic when loading.
     
    • Like Like x 1
  6. volumia

    volumia Portal Pro

    Joined:
    November 23, 2011
    Messages:
    96
    Likes Received:
    18
    Gender:
    Male
    Location:
    whereever my feet take me...
    Ratings:
    +34 / 0
    Home Country:
    Netherlands Netherlands
    Thanks so far for the effort.
    If you need testing, just say the word!
     
  7. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,579
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,082 / 2
    Home Country:
    Sweden Sweden
    Show System Specs
    I'm also having FanArt issues. All of the new shows' fanart won't show up in any views inside this plugin. Only for shows with returning seasons are working, but I also have not been able to turn some of the fanarts off (I do this when a major character leaves a show for example).

    Emph
     
  8. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,451
    Likes Received:
    4,231
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,371 / 0
    Home Country:
    Australia Australia
    I have identified the issue and have resolved it locally. Im just testing it now and when happy will make a public release.

    I suspect any new fanart uploaded to the site has this new filename format.
     
    • Like Like x 2
    • Thank You! Thank You! x 1
  9. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,451
    Likes Received:
    4,231
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,371 / 0
    Home Country:
    Australia Australia
    Test DLL attached.
     

    Attached Files:

    • MP-TVSeries.zip
      File size:
      528.8 KB
      Uploaded:
      September 1, 2018
      Views:
      19
    • Like Like x 4
  10. fischy667
    • Super User

    fischy667 Super User

    Joined:
    May 5, 2010
    Messages:
    930
    Likes Received:
    181
    Gender:
    Male
    Occupation:
    physicist - Software Tester
    Location:
    Rostock
    Ratings:
    +353 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Looks good for me.

    I deleted all fanart starting with 5 from the folder and the database.
     
    Last edited: September 1, 2018
    • Like Like x 2
    • Thank You! Thank You! x 1
  11. volumia

    volumia Portal Pro

    Joined:
    November 23, 2011
    Messages:
    96
    Likes Received:
    18
    Gender:
    Male
    Location:
    whereever my feet take me...
    Ratings:
    +34 / 0
    Home Country:
    Netherlands Netherlands
    Sorry to say, not solved here. No fanart showing (e.g. Take Two and Tom Clancy's Jack Ryan).
    The filenames have changed to series ID-numbers.
    From the GUI it tells me the fanart is present locally.

    My approach; replaced the DLL, deleted the series from the database, deleted the local files, start import, check results.
    Funny thing is, that the fanart does show in the recently added list overlay.

    Any other input I can provide, please let me know.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!