Rework DeployTool (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,583
    10,403
    France
    Home Country
    France France
    Description of Change
    This change is to be able to re-install and doing fresh install from same installed version

    The MP build provided is based on MP 1.4

    The source code can be found in the branch MP1-4067-Rework_DeployTool_to_be_able_to_reinstall_and_doing_fresh_install on github.

    Steps to install and test
    Installation
    Download the installer and execute it. If you already have MP 1.4 installed, you should be able now to do clean install or reinstall current 1.4.0.

    Verify installation.

    Testing
    Everything should work ;-)
    Please do not forget to give some feedback (also if there is no bug). Thank you!

    Sebastiii

    Changelog

    Version 1.4.0
    Build Based on MP 1.4

    2013.07.16 : Update installer based on latest commit fix


    Ps : Thanks Michael i take your template to create this thread :)
     
    Last edited:

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,948
    5,617
    France - IDF
    Home Country
    France France
    @Testers : For test please ;)
    Seb : log files are available from deploytool ?, i know only Mp package.
     

    The_Stig

    Retired Team Member
  • Premium Supporter
  • April 5, 2005
    2,176
    428
    Probably too dumb here, but I don't find the string. And besides this I don't have a git account ;-)

    Anyone can change the german string to "Bestehende Installation Version 1.4.0 erneut installieren"? (If I understand correct that this option is only visible when 1.4.0 is already installed; with an older version you don't get this possibility, right?)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,583
    10,403
    France
    Home Country
    France France
    • Thread starter
    • Moderator
    • #9
    All string language need to be updated, i only update English one.
    If local language is not found, it will use the 'English' one.

    I don't remember how to update it without using vs2010, transifex maybe or languagetool exists maybe ?
     

    Users who are viewing this thread

    Top Bottom