Satellite Stream Stops working on HD (1 Viewer)

g00se

Portal Member
April 28, 2014
19
1
48
United Kingdom United Kingdom
Posting this for people Googling about the problem, setting my card properties to stop when the card enters idle instead of pause fixed this for me permanently.
mediportalcardprops.png
 

DrunkenSquirrel

Portal Member
February 23, 2014
9
1
United Kingdom United Kingdom
Hi Again, problem re-occured last night, was working fine for many months, I'm starting to think maybe cold weather affects it?

I have now set my settings as you described g00se, I'll report back after trying a record tonight and see if that works :)
Thanks.
 

holidayboy

New Member
January 30, 2015
1
0
44
Great Britain (UK) Great Britain (UK)
I see this as well when my TBS6985 card has not been used for a while.

I'm not sure if my TBS DVB-T2 card does it as well.

I'll have to collect some proper logs.

I've tried all sorts of things and thankfully I finally stumbled across this thread.
 

DrunkenSquirrel

Portal Member
February 23, 2014
9
1
United Kingdom United Kingdom
So it looks like your solution worked g00se! (I don't want to jinx it, but the record went ok the other day I tried it).
Hopefully this gets resolved for good :)

Cheers everyone and nice to see this thread become a place for people looking for help with the same issue on google.
 

Hotkey

MP Donator
  • Premium Supporter
  • July 18, 2007
    254
    6
    42
    Dortmund
    Germany Germany
    Hi everyone. I just stumbled over this thread becaus i'm having the same problem. I've got a multi-seat setup and the server is solely used for mediaportal server. The computer is running 24/7 atm and i allready disabled possible disturbing software like anti virus, windows defender, etc.

    The OS is stored on a Samsung SSD which is also used for thimeshifting whereas the recording folder is set to a 1TB HDD. I'm also using a TBS card (6985 Quad Tuner) and mostly i got the problem only for the first record of the day.

    I also tried the hints here, but the setting was allready set to "Stop card" in idle

    The following logs are from the TsWriter (befor you ask, the recording is not for me :)):
    Code:
    [2015-02-11 20:10:03,452] [7469e50] [fa0] - debug: AddChannel()
    [2015-02-11 20:10:03,452] [7469e50] [fa0] - analyzer: reset
    [2015-02-11 20:10:03,452] [7469e50] [fa0] - PatParser::Reset
    [2015-02-11 20:10:03,452] [7469e50] [fa0] - NIT:Reset
    [2015-02-11 20:10:03,452] [7469e50] [fa0] - PatParser::Reset done
    [2015-02-11 20:10:03,452] [7469e50] [fa0] - cagrabber: reset
    [2015-02-11 20:10:03,452] [7469e50] [fa0] - debug: done AddChannel()
    [2015-02-11 20:10:03,555] [7469e50] [fa0] - epg: reset
    [2015-02-11 20:10:03,555] [7469e50] [fa0] - epg:ResetEPG()
    [2015-02-11 20:10:03,555] [7469e50] [fa0] - mhw reset
    [2015-02-11 20:10:03,556] [7469e50] [fa0] - CMpTsFilter::Pause()
    [2015-02-11 20:10:03,556] [7469e50] [fa0] - Pause filter...
    [2015-02-11 20:10:03,556] [7469e50] [fa0] - HRESULT = 0x0
    [2015-02-11 20:10:03,865] [7469e50] [fa0] - CMpTsFilter::Run()
    [2015-02-11 20:10:03,865] [7469e50] [fa0] - Run filter...
    [2015-02-11 20:10:03,865] [7469e50] [fa0] - HRESULT = 0x0
    [2015-02-11 20:10:03,888] [7469e50] [fa0] - pmtgrabber: set callback:e20038
    [2015-02-11 20:10:03,888] [7469e50] [fa0] - pmtgrabber: grab pmt:60 sid:ef10
    [2015-02-11 20:10:03,888] [7469e50] [fa0] - cagrabber: set callback:e2ffa8
    [2015-02-11 20:10:03,888] [7469e50] [fa0] - cagrabber: reset
    [2015-02-11 20:10:04,003] [7469e50] [d5c] - cagrabber: got ca version:15 -1
    [2015-02-11 20:10:04,003] [7469e50] [d5c] - cagrabber: do callback
    [2015-02-11 20:10:04,122] [7469e50] [d5c] - pmtgrabber: got pmt 60 sid:ef10
    [2015-02-11 20:10:04,123] [7469e50] [d5c] - pmtgrabber: PMT pids changed from:
    [2015-02-11 20:10:04,123] [7469e50] [d5c] -  pcr      pid:    0
    [2015-02-11 20:10:04,123] [7469e50] [d5c] -  pmt      pid:    0
    [2015-02-11 20:10:04,123] [7469e50] [d5c] - pmtgrabber: PMT pids changed to:
    [2015-02-11 20:10:04,123] [7469e50] [d5c] -  pcr      pid:   ff
    [2015-02-11 20:10:04,123] [7469e50] [d5c] -  pmt      pid:   60
    [2015-02-11 20:10:04,123] [7469e50] [d5c] -  video    pid:   ff type: H264
    [2015-02-11 20:10:04,123] [7469e50] [d5c] -  audio    pid:  103 language: UNK type: AC3
    [2015-02-11 20:10:04,123] [7469e50] [d5c] -  Subtitle pid:   30 language: deu type: DVB subtitle 2
    [2015-02-11 20:10:04,123] [7469e50] [d5c] - pmtgrabber: got new pmt version:0 ffffffff, service_id:ef10
    [2015-02-11 20:10:04,123] [7469e50] [d5c] - pmtgrabber: do callback pid 60
    [2015-02-11 20:10:04,148] [7469e50] [fa0] - analyzer: set video pid:ff
    [2015-02-11 20:10:04,148] [7469e50] [fa0] - analyzer: reset
    [2015-02-11 20:10:04,148] [7469e50] [fa0] - analyzer: set audio pid:103
    [2015-02-11 20:10:04,148] [7469e50] [fa0] - analyzer: reset
    [2015-02-11 20:10:04,221] [7469e50] [fa0] - Recorder: RECORD    set filename:G:\HTPC\Recordings\Der Bachelor - RTL HD - 2015-02-11.ts
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    Received from TvService: pmt pid:0x60 serviceId: 0xef10 pmtlength:611
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    Old pids cleared
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    got pmt - tableid: 0x2 section_length: 608 sid: 0xef10
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    PMT parsed  - Pid 0x60 ServiceId 0xef10 stream count: 7
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    pcr pid:0xff
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    SetPcrPid clear old PIDs
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    add video stream pid: 0xff fake pid: 0x30 stream type: 0x1b logical type: 0x1b descriptor length: 6
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    add audio stream pid: 0x103 fake pid: 0x40 stream type: 0x6 logical type: 0x81 descriptor length: 12
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    add teletext stream pid: 0x20 fake pid: 0x63 stream type: 0x6 logical type: 0x56 descriptor length: 10
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    stream rejected - pid: 0x105 stream type: 0x5 logical type: 0x5 descriptor length: 5
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    add subtitle stream pid: 0x30 fake pid: 0x50 stream type: 0x6 logical type: 0x6 descriptor length: 10
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    stream rejected - pid: 0x106 stream type: 0xb logical type: 0xb descriptor length: 14
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    stream rejected - pid: 0x107 stream type: 0xc logical type: 0xc descriptor length: 3
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    SetVideoAudioObserver observer ok
    [2015-02-11 20:10:04,222] [7469e50] [fa0] - Recorder: RECORD    Start 'G:\HTPC\Recordings\Der Bachelor - RTL HD - 2015-02-11.ts'
    [2015-02-11 20:10:04,253] [7469e50] [d5c] - Recorder: RECORD    start of video detected
    [2015-02-11 20:10:04,272] [7469e50] [d5c] - Recorder: RECORD    clear TS packet queue
    [2015-02-11 20:10:04,272] [7469e50] [d5c] - CDiskRecorder::WriteToRecording() - Reset write buffer throttle
    [2015-02-11 20:10:04,272] [7469e50] [d5c] - Recorder: RECORD    Info : Next broadcaster program clock reference rollover : 1 days 02:23:22 0
    [2015-02-11 20:10:04,291] [7469e50] [d5c] - Recorder: RECORD    start of audio detected
    [2015-02-11 20:10:08,054] [7469e50] [d5c] - Recorder:Pid ff Continuity error... e ( prev 9 ) - bad signal?
    [2015-02-11 20:10:08,262] [7469e50] [d5c] - Recorder:Pid ff Continuity error... 4 ( prev b ) - bad signal?
    [2015-02-11 20:10:08,268] [7469e50] [d5c] - Recorder:Pid 103 Continuity error... b ( prev 9 ) - bad signal?
    [2015-02-11 20:10:08,268] [7469e50] [d5c] - Recorder:Pid ff Continuity error... b ( prev e ) - bad signal?
    [2015-02-11 20:10:08,274] [7469e50] [d5c] - Recorder:Pid ff Continuity error... 2 ( prev d ) - bad signal?
    [2015-02-11 20:10:08,280] [7469e50] [d5c] - Recorder:Pid ff Continuity error... e ( prev 9 ) - bad signal?
    [2015-02-11 20:10:08,286] [7469e50] [d5c] - Recorder:Pid 20 Continuity error... 4 ( prev 1 ) - bad signal?
    [2015-02-11 20:10:08,286] [7469e50] [d5c] - Recorder:Pid 103 Continuity error... 0 ( prev c ) - bad signal?
    [2015-02-11 20:10:44,790] [7469e50] [d5c] - Recorder:Pid ff Continuity error... 3 ( prev 3 ) - bad signal?
    The recording simply stops (the file in the recording folder doesn't increase in its size anymore) where's the client still shows the "recording" sign.
    Every time this happens, when i delete the recording and start it again, the error never appears again until the next day (e.g. after a long idle phase).
    I also never had any problems with signal quality on any other TV/Receiver which is using the same dish. The TVService.log also says the signal is good:

    Code:
    [2015-02-11 20:10:04,186] [Log    ] [scheduler thread] [INFO ] - subch:0 stop tif
    [2015-02-11 20:10:04,192] [Log    ] [scheduler thread] [INFO ] - **************************************************
    [2015-02-11 20:10:04,192] [Log    ] [scheduler thread] [INFO ] - ***** SIGNAL LEVEL: 92, SIGNAL QUALITY: 83 *****
    [2015-02-11 20:10:04,192] [Log    ] [scheduler thread] [INFO ] - **************************************************
    [2015-02-11 20:10:04,193] [Log    ] [scheduler thread] [INFO ] - user:scheduler1 add
    [2015-02-11 20:10:04,218] [Log    ] [scheduler thread] [INFO ] - Scheduler : record to G:\HTPC\Recordings\Der Bachelor - RTL HD - 2015-02-11.ts
    [2015-02-11 20:10:04,218] [Log    ] [scheduler thread] [INFO ] - Controller: epg stop
    [2015-02-11 20:10:04,219] [Log    ] [scheduler thread] [INFO ] - card: StartRecording 4 G:\HTPC\Recordings\Der Bachelor - RTL HD - 2015-02-11.ts
    [2015-02-11 20:10:04,220] [Log    ] [scheduler thread] [INFO ] - StartRecording to G:\HTPC\Recordings\Der Bachelor - RTL HD - 2015-02-11.ts
    [2015-02-11 20:10:04,221] [Log    ] [scheduler thread] [INFO ] - subch:0 StartRecord(G:\HTPC\Recordings\Der Bachelor - RTL HD - 2015-02-11.ts)
    [2015-02-11 20:10:04,221] [Log    ] [scheduler thread] [INFO ] - subch:0-0 tswriter StartRecording...
    [2015-02-11 20:10:04,221] [Log    ] [scheduler thread] [INFO ] - SetRecorderPids
    [2015-02-11 20:10:04,222] [Log    ] [scheduler thread] [INFO ] - Set video / audio observer
    [2015-02-11 20:10:04,222] [Log    ] [scheduler thread] [INFO ] - DVB subch:0 Started recording
    [2015-02-11 20:10:04,223] [Log    ] [scheduler thread] [INFO ] - card: WaitForFile - waiting _eventAudio & _eventVideo
    [2015-02-11 20:10:04,253] [Log    ] [53       ] [INFO ] - PID seen - type = Video
    [2015-02-11 20:10:04,291] [Log    ] [53       ] [INFO ] - PID seen - type = Audio
    [2015-02-11 20:10:04,292] [Log    ] [scheduler thread] [INFO ] - card: WaitForFile - video and audio are seen after 0,069004 seconds
    [2015-02-11 20:10:04,292] [Log    ] [scheduler thread] [INFO ] - TimeshiftingEPG: channel RTL HD is not configured for grabbing epg
    [2015-02-11 20:10:04,294] [Log    ] [scheduler thread] [INFO ] - card: SignalTuneEvent card: 4 / subch: 0
    [2015-02-11 20:10:04,299] [Log    ] [55       ] [INFO ] - ChannelStates.GetAllTimeshiftingAndRecordingChannels took 1 msec
    [2015-02-11 20:10:04,315] [Log    ] [scheduler thread] [INFO ] - Scheduler: recList: count: 1 add scheduleid: 1 card: TBS 6985 DVBS/S2 Tuner B
    [2015-02-11 20:10:04,366] [Log    ] [55       ] [INFO ] - ChannelStates.DoSetChannelStates took 72 msec
    After reading through this thread i think there's three most likely reasons:

    a) The TBS Card has some idling Issues or Driver issues
    b) The problem is idle-related. Could the Energy setting "Idle HDD after 20 minutes" be the reason? The HDD for the recording is solely used for the recording and therefore could be in idling mode and didn't start fast enough? But in this case the recording shouldn't start at all?
    c) The HDD is the problem. But would then the problem not appear more often??

    Im looking forward for your help and thanks for reading so far :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    B [solved] Where is the satellite data now? General 10
    S rotierende disk in streamed mp Skin Modifikationen 30
    C Streaming/transcoding MP2 vs MP1? General 1
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    P Streaming MediaPortal 1 Talk 5
    P Streaming to two clients from the same card Newcomers Forum 1
    L Non-PC device streaming... Newcomers Forum 1
    raffe How to add 500+ streams? OnlineVideos 1
    R Heavy pixelation on HD OTA Streams Installation, configuration support 1
    C streaming out UDP instead of RTSP Newcomers Forum 0
    C Recording back to back shows from IPTV streams General Support 8
    T Missing sound in online streaming service (SVTPlay) General Support 3
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    doskabouter Black screen while watching some iptv streams General Support 2
    II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    jmarc Recording IPTV streams General Support 1
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    C Is there a Tuner Stream Failure Alarm Plugin? MediaPortal 1 Plugins 1
    P [solved] MediaPortal 2 Won't stream HDHR Dual General 1
    M.Hulot Streamed MP behält gewählte Ansicht nicht bei Allgemeines Supportforum 4
    J Different video and audio streams. OnlineVideos 8
    Similar threads

























    Top Bottom