Self Contained Web Server / Interface (1 Viewer)

Big_Kev

Portal Pro
June 8, 2007
338
186
Sorry Must have missed something...

Will fix ASAP

Kev
 

Big_Kev

Portal Pro
June 8, 2007
338
186
Version 0.0.0.4

level20peon;177685: said:
Code:
szAppName : MPWebInt.exe     szAppVer : 0.0.0.2     szModName : unknown     
szModVer : 0.0.0.0     offset : 00000011
After closing this error message the WebServer starts normally. The radio programs however are still displayed.


-level20peon
I have uploaded another version.

VERSION 0.0.0.4

As normal, if you have changed your HTML templates, graphics etc, make sure you back them up first.

mainmenu.htm has changed in this version - added button for Keyword Search. searchmain.htm is a new file.

I found something I missed with the radio channels and I have fixed that - It worked on my data as expected.

If displayed, all radio stations are listed to the right of the TV channels - otherwise not displayed.

I have added a basic keyword search that searches the title and description of programs in the current EPG database (not recorded programs or scheduled programs) for the phrase you enter.

I plan to add to this with Genre, Classification, Channel dropdowns etc so that you can for example show all of the G rated Comedies or all Crime Dramas etc.

Feedback on the search, and what you would like to see in it would be very useful

Code:
szAppName : MPWebInt.exe     szAppVer : 0.0.0.2     szModName : unknown     
szModVer : 0.0.0.0     offset : 00000011

I am still trying to get to the bottom of this one - it would seem that the database connection is not closing properly but I am not sure why.

Re-starting the service after the error has cleared will get the web server running again. It only happens after a query has been executed. If you start the service, then stop it without doing anything on the Web Server it is fine. The service connects to the database on startup... anyway, I will find it.

Regards
Kev
 

Big_Kev

Portal Pro
June 8, 2007
338
186
Version 0.0.0.5

... another new version!

Sorry, but I was on a roll!

Added Genre, Classification and Channel dropdowns to the search page.

At present you will need to use the back arrow on your browser to go from the search results back to the search page.

The HTML for searchmain.htm changes from version 0.0.0.4 and guidemain.htm changes from version 0.0.0.3 so take care if you have made changes to any html pages. Back them up before installing and add in the changed lines.

Please throw some feedback my way on the search page...

Regards
Kev

New Version 0.0.0.6

Sorry, another one..

Now added a drop down on the program guide page to show all dates with EPG data available and jump to that date.

Changes to HTML for guidemain.htm so back up first if you have changed any pages

Regards
Kev
 

Sh4nn0w

MP Donator
  • Premium Supporter
  • September 14, 2006
    321
    23
    United Kingdom United Kingdom
    Can't keep up with it, 3rd install today, (0.0.0.6) :)

    One comment I have so far about the search is that even though the radio programs are now hidden under the EPG, as per config, the radio columns do show up in the search results.

    Also just noticed if I just select a Channel in the search (any channel other than ALL) I just get a blank page. This is with all other options empty/at default from opening the page.
     

    level20peon

    MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    I just tested 0.0.0.6

    - radio programs aren't shown anymore if i uncheck the correlative option
    - the crash when checking / unchecking this option and restarting the server still occurs
    - everything else works like a charm :)

    I would like to place another feature request:
    Is it possible to add a 24 hour time format ? I think some people (including me :p) prefer this format to "am / pm".


    -level20peon
     

    Big_Kev

    Portal Pro
    June 8, 2007
    338
    186
    I would like to place another feature request:
    Is it possible to add a 24 hour time format ? I think some people (including me :p) prefer this format to "am / pm".


    -level20peon
    Just uploaded version 0.0.0.7

    On the appearance tab there is a new input for Time Format. Just Right click it to see the options available.

    24 hour time would be hh:nn

    Regards
    Kev
     

    midiboy

    Portal Pro
    March 14, 2005
    78
    0
    Hi Big_Kev,

    great project, thanks. A few things I noticed with 0.0.0.7 (first version I tried):

    1. The program guide only shows the programs from the current system time and later but not earlier. Right now it is 10pm here and the first program displayed is from 10pm.

    2. Clicking on next in the program guide opens a blank page with a HTTP 500 "Internal Servererror" Same happens when going to another date in the program guide. Tried with Firefox, IE6 and IE7. Only the same day is displayed properly.

    3. The channels displayed are the ones MP Server found and named during the channel scan. Those are wrong mostly (at least in my case). Would it be possible to display the "display names" instead ?

    Thanks for your work !
    midiboy
     

    Big_Kev

    Portal Pro
    June 8, 2007
    338
    186
    Question/New Version 0.0.0.8 (Sorry 3 posts merged)

    Hi Big_Kev,

    great project, thanks. A few things I noticed with 0.0.0.7 (first version I tried):

    1. The program guide only shows the programs from the current system time and later but not earlier. Right now it is 10pm here and the first program displayed is from 10pm.

    2. Clicking on next in the program guide opens a blank page with a HTTP 500 "Internal Servererror" Same happens when going to another date in the program guide. Tried with Firefox, IE6 and IE7. Only the same day is displayed properly.

    3. The channels displayed are the ones MP Server found and named during the channel scan. Those are wrong mostly (at least in my case). Would it be possible to display the "display names" instead ?

    Thanks for your work !
    midiboy
    Could you give me some more info?

    Which version of TV Engine are you using?

    Are you using MSSQL or MySQL database?

    I can not reproduce those issues... the "500" error would indicate a crash in an SQL query and the blank page would indicate a rouge query that has not terminated but has not crashed.

    There is possibly some sort of database mis-match here???

    Regards
    Kev


    New Version 0.0.0.8
    Can't keep up with it, 3rd install today, (0.0.0.6) :)

    One comment I have so far about the search is that even though the radio programs are now hidden under the EPG, as per config, the radio columns do show up in the search results.

    Also just noticed if I just select a Channel in the search (any channel other than ALL) I just get a blank page. This is with all other options empty/at default from opening the page.

    Fixes for searches with the Channel option set.

    Dont show radio or shift radio to the right in search results.

    Series Recordings should now show in the main guide (like every day at this time etc...)

    More options for changing date/time formats - see configuration pages.

    As usual, if you have changed any of the HTML pages, back them up before running this install, as they will be overwritten.

    Regards
    Kev

    Big_Kev - Have you tried this out with RC2?
    Not Yet...

    The Web Interface is independent of the MP client, so if the TV Engine database structure has not changed, then it will work just fine.

    Regards
    Kev
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom