[fixed] Server change, data source does not follow. (1 Viewer)

pellegj

Portal Pro
May 7, 2009
106
32
Sweden Sweden
MediaPortal Version: 1.1 RC1
MediaPortal Skin: Blue3wide
Windows Version: Win 7 Pro
CPU Type: Intel Core i7 920
HDD: Kingston SSD V+ 64GB
Memory: 6 GB DDR3
Motherboard: Asus P6T Deluxe V2
Video Card: ASUS Radeon HD 5770
Video Card Driver: 8.681.0.0
Sound Card: Onboard Reltek HD Audio
Sound Card AC3: no AC3
Sound Card Driver: 6.10.2.6585
1. TV Card: TT C-1501
1. TV Card Type: DVB-C
1. TV Card Driver: 5.0.1.8
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: PowerDVD8
MPEG2 Audio Codec: PowerDVD8
h.264 Video Codec: PowerDVD8
Satelite/CableTV Provider: Tele 2
HTPC Case:
Cooling: Many Fans
Power Supply:
Remote: MS MCE
TV:
TV - HTPC Connection: DVI

After changing TV server in MP Config, the data source does not change with it.
I changed from TV server "tvsrv" to server "dvbc", but the data source does not change on client, it still looks after "tvsrv".
Found the option in Gentle.config, but the user should not have to change it manually i guess.
Code:
2010-02-23 18:54:59.319946 [ERROR][MPMain(1)]: Exception   :The database backend (provider SQLServer) could not be reached.
Check the connection string: Password=***;Persist Security Info=True;User ID=sa;Initial Catalog=MpTvDb;Data Source=tvsrv\SQLEXPRESS;Connection Timeout=300;
 

arion_p

Retired Team Member
  • Premium Supporter
  • February 7, 2007
    3,373
    1,626
    Athens
    Greece Greece
    Country flag
    I have seen something similar, but need to investigate further. I also think it is related to many users' issue on first use after clean install TVPlugin triees to connect to MS SQLServer instead of MySQL (by default MySQL is installed).
     

    pellegj

    Portal Pro
    May 7, 2009
    106
    32
    Sweden Sweden
    To clear things up a bit from me.
    I run TV Server on Win 7 x86 with MS SQLExpress 2008 on both servers, not MySQL since i had problems with performance with MySQL in the past. But nevermind, the problem still is on the client (Win 7 Pro x64).
    I configured my client to use TVSRV server from Configuration.exe, and ran it like that for a couple of days. I then setup my other server with my DVBC card, and fired up Configuration.exe on the client again and changed the servername to DVBC under "TV->TV Client" in config. That did indeed change the config in MediaPortal.xml, however the database connection in Gentle.config was not updated to reflect the change. So the client tries to connect to TVSRV\SQLEpress instead of DVBC\SQLExpress on startup, but since TVSRV server is offline it wait for 300 seconds and then times out. It then continues to load, and end up with showing me the desktop, like all of MediaPortal client is transparent, i can see everything on my desktop, but cant click anything since MediaPortal still is on top, but not showing anything, i have to kill the MediaPortal process to get access to my desktop again.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    R [solved] Change Server name General 1
    high Server changes/updates Online Facilities 36
    E [solved] TV-Server Configuration Missing TV-Server 9
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    E TV-SERVER control TV-Server 3
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 7
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    catalpa ...immer mal wird der Server abgekoppelt :( Allgemeines Support- und Diskussionsforum 0
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 11
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    toricred [solved] Configuring TV Server to use NAS General 5
    T Server / client channel logo location Installation, configuration support 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    J TV Server setup question Newcomers Forum 0
    I [solved] Connection to TV Server MySQL General Support 8
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    F After resume, TV Server connection screen is shown General Support 4
    R TV server crash with WintTV quadHD General 0
    Similar threads

























    Top Bottom