[solved] - Setup Issue - Hanging on Starting Services

Discussion in 'General' started by MartyWakat, February 21, 2019.

  1. MartyWakat

    MartyWakat Portal Member

    Joined:
    January 16, 2016
    Messages:
    17
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Aloha All,

    I’ve been using MediaPortal 2 for a couple years but I’ve been running the Summer 15 version I think. I decided to update to the newest version and I’m having a problem. I first just tried installing without trying to remove the old version or anything. It hung near the end of the install at “Starting Services’. I then tried removing from Add/Remove and then manually deleted folders in ProgramFilesx86 and tried install again...same problem. I have checked for all updates in windows update (Windows10) and gotten all available. I am running install as Admin and choosing default install for a standalone machine. I have tried custom install and choose a different folder than previous installs with same issue. I have used CCleaner to cleanup registry and any orphaned dll files and general cleanup. I have tried to manually download and install .NET as many forum posts I found with this error mentioned possible .NET issues but window install says I have current version and stops install.

    I’m willing to take any suggestions to try and get the install to complete. I’ve looked through the log that is available after the failed install and it doesn’t really tell me much.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,771
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Hello,

    It is not possible to upgrade a Summer 15 version and your settings need to be redone. All your data will be lost and need to be recreated by the automatic importer.
    1. Please delete (or at least rename) the Team MediaPortal data folder C:\ProgramData\Team MediaPortal
    2. Uninstall all Dokan versions, except 1.0.5 - reboot
    3. Run the installer again - the latest version is 2.2
    If issues persist, turn to the .NET part.
    We saw similar problems yesterday (German thread Posting #41). The solution was to use a .NET cleanup tool and remove all 4.x.x versions from the machine. It was then possible to install .NET 4.7.1, after which MP2 was installing without issues and the service started. The user didn't post which tool he used, but I trust you will find something yourself. Otherwise post a comment and I'll ask in the other thread.

    As a former WMC-user you may particularly like the WMC skin.
     
  4. MartyWakat

    MartyWakat Portal Member

    Joined:
    January 16, 2016
    Messages:
    17
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Thank you so much,

    Your first suggestion worked. I had forgotten about the ProgramData\TeamMediaPortal folder since it was a hidden folder. I deleted that folder and also uninstalled the Dokan library sources and rebooted. Installed smoothly after.

    Mahalo
     
  5. MartyWakat

    MartyWakat Portal Member

    Joined:
    January 16, 2016
    Messages:
    17
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    I have added a few of my media servers and am loving the interface of the new version.

    Thanks again
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!