Skip forward and back gets out of sync with playback time | Page 2

Discussion in 'General Support' started by adagio, June 4, 2014.

  1. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,538
    Likes Received:
    2,830
    Location:
    Cambridge
    Ratings:
    +4,132 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Reverse play (and fast-forward above - I think - 8x speed) is done by sequential skip-stepping, so will suffer from the same seeking problems as manual skipping.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. adagio

    adagio Portal Pro

    Joined:
    April 5, 2009
    Messages:
    68
    Likes Received:
    0
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    I'll try the file with 1.3 today. I'm hesitant to update to 1.4, 1.5 etc because another issue I reported on different thread is that 1.7 does not find all my HD channels correctly, so I need to scan with my old 1.3 and then manually type in the channels settings back into 1.7.

    Wouldn't the developers have a change log that would lead them to when the skip functions were changed?
     
  4. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,538
    Likes Received:
    2,830
    Location:
    Cambridge
    Ratings:
    +4,132 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Yes - it's here (for the TsReader.ax module that does most of the work) - https://github.com/MediaPortal/Medi...ectShowFilters/TsReader/source/TsFileSeek.cpp

    The last change that made it into the Master version was included in MP 1.4.0 (the changes after that will be included MP 1.8.0)
     
  5. adagio

    adagio Portal Pro

    Joined:
    April 5, 2009
    Messages:
    68
    Likes Received:
    0
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    I skipped back and forth around the same area for the same recorded file with both MP 1.3 and MP 1.7. I'm uploading the logs from both of those. The first part of the logs were me trying to get to the right spot. The main part of the log would be where I played the video back and forth around the 56- 58 minute mark. As expected, MP 1.3 skipped back and forth correctly. MP 1.7 would often skip to a part of the video maybe a minute back. I turned DEBUG on the logs too, hoping that would give more info.
     

    Attached Files:

  6. adagio

    adagio Portal Pro

    Joined:
    April 5, 2009
    Messages:
    68
    Likes Received:
    0
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Interesting. I was looking at the two logs. MP 1.7 has log data of 'No PCR found...' but MP 1.3 doesn't have any of those logs.

    The line in the code - if (m_pcrfound.IsValid) must be returning differently between the two versions.
     
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    I note there have been changes in the TsWriter code related to PCR. Not changes that I think could cause this... but it would be helpful if you could provide at least MediaPortal.log, TsReader.log and TsWriter.log wherever possible.

    [edit: To be clear, the TV Server TsWriter log would only be available for live TV/timeshifting and when the recordings were actually recorded. Playing a recording won't create any TsWriter log entries.]

    [edit2: It would be interesting to see the TsWriter log for MP 1.7+ simply starting live TV on the channel that these recordings come from. Could you please do a bit of channel jumping and skipping backwards and forwards with live TV and the channel that is problematic, then post the TVService.log and TsWriter.log, and tell us what the name of the channel is.]
     
    Last edited: June 8, 2014
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
  9. adagio

    adagio Portal Pro

    Joined:
    April 5, 2009
    Messages:
    68
    Likes Received:
    0
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    The attached logs are from both server and player. I started live TV on the bad channel (WTMJ-HD) and skipped a few times, then switched channels to WISN-HD, skipped a few times, changed to another good channel, skipped a few times, and then back to WTMJ-DT again and skipped around there.

    Thank you for your interest in this. Also thanks for the other post. I'll look into that patch!

    --- oops. Forgot to turn on debug mode for logs. I can redo it if you want.
     

    Attached Files:

    Last edited: June 8, 2014
  10. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,538
    Likes Received:
    2,830
    Location:
    Cambridge
    Ratings:
    +4,132 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Thanks - I'll take a look.

    If TsReader.ax doesn't find any PCR data, it will still 'seek' but with much reduced accuracy (which could produce the effect you are seeing).
     
  11. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    From the server logs I can at least tell that we're using the original PCR PID and that there is no chance of getting a fake PID mixed up. I can't tell how frequently PCR is delivered or whether there are jumps in it that we attempt to smooth out.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!