Operating System [solved] Windows 7 Pro x64 SP1 - Hibernate restarts System, devcon does not work... (1 Viewer)

muellinger
Country flag

MP Donator
  • Premium Supporter
  • June 9, 2009
    258
    36
    Home Country
    Germany Germany
    Hi everyone!
    This Problem is the last one i have to fix for getting a 100% WAF :)

    - I am using MediaPortal 1.2.2 incl. TVServer as a singleseat-system on Windows 7 Pro x64 SP1.
    - I have a standard MCE remote that works 100%.
    - I used the MCE Standby Tool to configure the system for hibernation (HybridSleep deactivated)

    When i press the PowerButton on the remote the system tries to get in hibernation but then the system reboots.
    But it seems, that the memory could be written on the harddisk because Windows behaves like it really was hibernated. "Windows continues..."

    So i tried using devcon from the Windows 7 DDK (64bit Version) to stop my SkyStar HD2 DVB-S Card (PCI) before
    entering Hibernation. When i let devcon scan the hwids, it finds the card. When i give it the disable signal for the correct hardware-id it tells me "no matching devices found." and fails.

    Had anyone similar problems? The windows event-log does not contain any errors.

    Thanks a lot!

    Carsten
     

    Lehmden
    Country flag

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    11,992
    3,647
    Lehmden
    Home Country
    Germany Germany
    Hi.
    I'm using an Asus P5B Board which provided similar Standby issues. The TV Card is not the reason for this "rebbot", it's the onboard USB controller. I can imagine your board is using quite the same (or similar) USB controller. If you try to disable "Allow this device to wakeup PC" (Don't know the right term as I'm not using an English version of Windows, It's in properties -> energy tab in Device Manager) on all USB devices including MCE Remote, Mouse and Keyboard, then you will get rid of those "reboots".
    Unbenannt.jpg

    This way you can't wake up your System by remote at all. I'm using this way and wakeup the HTPC by Wake On Lan or pressing the power button on case.

    This seems to be an issue of lots of Intel chipsets from ICH7 to ICH10. as I got exactly the same behavior with an Foxxcon ICH10 Board (actual used Asus Board has ICH8 chipset)..

    So If you want to get rid of this completely you have to change Board and CPU to a newer one, I fear.
     

    geichel

    Portal Pro
    January 11, 2008
    81
    17
    Dortmund
    Home Country
    Germany Germany
    Hallo, Carsten!
    Versuch erstmal in deinem Bios im Power-Menu die ACPI & ACPI 2.0 Support zu aktivieren. Stelle deinen Suspend Mode auf "S3".
    Unter der APM Konfiguration deaktiviere alle "PowerOnBla" Optionen.
    So funktioniert es bei mir. Im MediaPortal solltest du Suspend anstatt Hibernate benutzen, da im Suspend dein Betriebssystemzustand im Ram gehalten wird. Rechner fährt schneller hoch, und das Aufwecken des Rechners für Aufnahmen ist auch so möglich.
    Um dein Standy Problem zu lösen, deinstalliere ALLE unnötigen Programme. Bei mir läuft nur MediaPortal, TV Server, SAF 6.0 unter Windows 7 und sonst nichts weiter.
    Zu deiner TV Karte; Ich hatte ein ähnliches Problem mit einer Nova-T 500. Was helfen kann:
    -> TV Service ca 20-30 Sekunden verzögert starten lassen, da der TV Kartentreiber eine Zeit braucht, um die Karte zu installieren.
    -> Ansonsten Rechner nach jedem Hochfahren aus dem Standby einmal durchbooten lassen, ist nach meiner Erfahrung wesendlich zuverlässiger bei geplanten TV Aufnahmen.
    Vielleicht hilft Dir "http://sourceforge.net/projects/gmps/"
    ->Ansonsten kann ich dir ein kleines Tool schicken, das genau diese Aufgabe erledigt.
    Viel Erfolg!
    ge
     

    muellinger
    Country flag

    MP Donator
  • Premium Supporter
  • June 9, 2009
    258
    36
    Home Country
    Germany Germany
    Hi!

    Lehmden: I disabled wakeup for all USB-Devices, but not the MCE cause i wanted to use it for wake up. I'll try disabling it, too.
    Changing Board/CPU is not an option at the moment. So i'll live with that. When hibernation works, i'll sure find some way for the wake up.

    geichel: ACPI und ACPI 2.0 are active and all PowerOn-xyz are disabled.
    About using suspend instead of hibernate. I like the fact that hibernate powers off the system, while Standby seems to keep rotating
    the cpu's fan and the harddisk (as far as i could see in my former tests).

    Since my System seems to restart every time i am not sure how my TV-Card behaves after Standby/Hibernate. I'll test this later.
    I have PowerScheduler++ installed, using the "HTPC" Preset without any selfmade changes. Is GMPS better than it? Where are the differences / advantages?

    Thanks a lot for your help!

    Carsten
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    Home Country
    United Kingdom United Kingdom
    About using suspend instead of hibernate. I like the fact that hibernate powers off the system, while Standby seems to keep rotating
    the cpu's fan and the harddisk (as far as i could see in my former tests).
    Sounds like your motherboard does not support S3 only S1, which as you stated only partly powers down.

    What happens if you allow powerscheduler to hibernate system rather than remotes power button, does that work correctly.
     

    Lehmden
    Country flag

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    11,992
    3,647
    Lehmden
    Home Country
    Germany Germany
    Hi.
    What happens if you allow powerscheduler to hibernate system rather than remotes power button, does that work correctly.
    If it's the same issue that I have (I think it is), there it doesn't matter if I use PS++ or Power Button. The PC just restarts after half a second standby time, as long as I leave a single USB device (no matter which one) enabled for wakeup. If I disable this on all USB devices the system goes to S4 or S3 (no matter if it's via PS++ or power button) and wake up on scheduled recordings (EPG grabbing,...), power button or by WOL without problems...
     

    muellinger
    Country flag

    MP Donator
  • Premium Supporter
  • June 9, 2009
    258
    36
    Home Country
    Germany Germany
    Hi,
    first of all. Lehmdens tip to deactivate also the eHome IR wakeup in device manager did the trick.
    This also cured the problem that S3 did not turn off power to the FAN and HDD. This damn ICH7 USB-Controller was the bad guy.

    So for now we will wakeup the box with the cases PowerButton.

    In the BIOS i set the PowerSaving to S3 fix and not to auto. This works flawlessly and S3 is real quick in waking up. So i dont have to use hibernation
    any more. PowerScheduler++ also does what it has to do. And the TV Card works without any workarounds or resets. :)

    Thank you all for your really great help! You guys rock! (y)

    Carsten
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    Home Country
    United Kingdom United Kingdom
    Geez, and I thought the VIA usb controller Hauappauge used on my T500 was bad, that would do my head in not being able to use remotes power button to resume, is there no BIOS update to cure this!!
     

    Lehmden
    Country flag

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    11,992
    3,647
    Lehmden
    Home Country
    Germany Germany
    Hi.
    is there no BIOS update to cure this
    Unfortunately not.
    I can imagine this really is a hardware issue not solvable by bios update.
     

    muellinger
    Country flag

    MP Donator
  • Premium Supporter
  • June 9, 2009
    258
    36
    Home Country
    Germany Germany
    Like Lehmden said, this seems to be a known Hardware-Bug. I found several ICH7-based Boards (not only ASUS) that have this problem.
    What i am trying next is using the BIOS function to wake up by several events.

    regards carsten
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom