[solved] Some videos break the aspect ratio of the output resolution to TV (even the MePo GUI changes aspect ratio) (1 Viewer)

emphatic

Design Group
  • Team MediaPortal
  • August 25, 2006
    3,733
    1,194
    Alingsås
    Home Country
    Sweden Sweden
    • Thread starter
    • Moderator
    • #11
    Can you play the same scene in VLC or MPC-HC in windowed mode to verify black bars in the video?
    Have a look at the screenshot in the 3rd post of this thread. The video seems to be in 2:35:1 ratio but reported by VirtualDub to be 1920 x 1080 pixels in size. The blue block that I pasted the screen shot onto is 1920 x 1080 in size.

    I just tried opening the file in MPC-HC, and it seems that (at least in MPC-HC) the video file has black borders on top and bottom. When I opened it in VirtualDub, that seems to crop the black bars automatically.
     

    framug

    Super Moderator
  • Team MediaPortal
  • January 31, 2005
    6,012
    2,107
    South of France
    Home Country
    France France
    The Video Image Scaling was set to OFF in Intel's HD Graphics Control Panel. I have also tried it ON, but I can't see any difference = the black frame still appears.

    As this phenomena doesn't happen with all material (some is presented in full screen), this suggests to me that it might be an AR issue. If MePo outputs a resolution that my TV isn't all too happy about, maybe it compensates in some way with a "reversed over scan"?
    I have had overscan problems with my NUC (Intel Iris Xe Graphics).
    I was pretty sure of a driver problem (newer can't give the ability to set overscan).
    Then, I tried plenty of different drivers and settings, without effect.
    And finally, I found that, with this NUC, a TV setting was added (don't remember what).
    At the end, I dug inside TV settings and found how to fix the problem.
    I think this could be a TV set settings problem, somewhere...
     

    emphatic

    Design Group
  • Team MediaPortal
  • August 25, 2006
    3,733
    1,194
    Alingsås
    Home Country
    Sweden Sweden
    • Thread starter
    • Moderator
    • #13
    I have had overscan problems with my NUC (Intel Iris Xe Graphics).
    I was pretty sure of a driver problem (newer can't give the ability to set overscan).
    Then, I tried plenty of different drivers and settings, without effect.
    And finally, I found that, with this NUC, a TV setting was added (don't remember what).
    At the end, I dug inside TV settings and found how to fix the problem.
    I think this could be a TV set settings problem, somewhere...
    That was it! :)

    ohTao.png


    I had to set it to "Maintain display scaling". I think it was set to "Maintain Aspect Ratio", which added black bars to MediaPortal when playing videos that didn't conform to a strict 16:9 ratio, I suppose.

    Thanks to everyone for the patience and help, I can finally enjoy videos fully.
     

    Users who are viewing this thread

    Top Bottom