[SPANISH] csscript filmaffinity/IMDB grabber 2013/04/17 (1 Viewer)

gomorro69

Portal Member
April 13, 2010
18
15
48
Spain Spain
Tras los últimos cambios de la web de filmaffinity, he decidido modificar el grabber correspondiente.

Me he basado en el script de jumate en el post https://forum.team-mediaportal.com/t...-y-actualizado-23-03-2013.117622/#post-985447.

Mi última version es la v5.1 con muchas mejoras.
- Mejoras en la Gestión de Logs para depuracion.
- Mejoras de Busquedas aportadas por "jumate".
- Mejoras y simplificación de la Normalización.
- Mejoras en el Rating MPAA.
- Corrección de Errores de Excepciones.
- Adaptación completa a nueva WEB de filmaffinity.
- Mejora de Géneros para que se coloquen por separado.
- Mejora en la detección de resultado exacto (aunque no hace falta en realidad).
- Busqueda en imdb.com en lugar de imdb.es.
- Buscar en imdb.com por titulo original y titulo en español.
- Mantener el año en el título guardado para facilitar el refresco.
- Poner en TagLine el titulo original y el primer TagLine de IMDB si hay.
- Mejoras estéticas en Premios y Criticas
- .... y las que no recuerde.

Si tenéis algún problema o alguna mejora que aportar, no dudéis en decirlo.

Sl2

EDITADO 05/08/2013

Os dejo mi última versión, más rápida porque no usa IMDB.com y usando la API 3 de themoviedb ya que la API 2.1 dejará de funcionar el proximo 15 de Septiembre.

Sl2
 

Attachments

Last edited:

TIANO

Portal Member
December 2, 2012
5
0
48
Spain Spain
Hola gomorro,
gracias por el trabajo.
Llevaba un tiempo sin añadir pelis al MediaPortal y hoy me he dado cuenta que el grabber de filmaffinity ya no funciona con la actualización de su web.
El caso es que he querido meter el tuyo, como siempre, en la ruta C:\ProgramData\Team MediaPortal\MediaPortal\scripts\MovieInfo y al ir a la config para añadir el grabber no aparece en la lista desplegable y no puedo subirlo a la lista de Database. No tengo ni idea de como corregir esto, si me puedes echar una mano te lo agradecería enormemente.
Muchas gracias.
 

gomorro69

Portal Member
April 13, 2010
18
15
48
Spain Spain
Hola TIANO

Lo primero comentarte que este script solo funciona con MP 1.3.x, no con versiones anteriores.

Para asegurarte que funciona, primero actualiza los grabber y debería aparecerte el oficial de filmaffinity.

Luego simplemente sustituyes el script original en C:\ProgramData\Team MediaPortal\MediaPortal\scripts\MovieInfo por el nuevo y ya debería funcionar.

Otra opción es copiar el fichero nuevo en C:\ProgramData\Team MediaPortal\MediaPortal\scripts\MovieInfo pero con otro nombre y después abrir la configuración de MP. Debería reconocerte el nuevo fichero y aparecer en el desplegable.

Espero haber ayudado.
 

TIANO

Portal Member
December 2, 2012
5
0
48
Spain Spain
Muchas gracias gomorro por la respuesta,;)
revisaré la versión que tengo al llegar a casa y te cuento...

Saludos.

Edito: Tengo la versión 1.2.3.0,....por lo que no es extraño que no funcione. Ahora:
¿Hay algún grabber en español para esta versión que funcione? o en todo caso,
¿Puedo actualizar el MediaPortal a la última versión sin perder los datos catalogados de todas las pelis que tengo?
Muchas gracias.
 
Last edited:

gomorro69

Portal Member
April 13, 2010
18
15
48
Spain Spain
Muchas gracias gomorro por la respuesta,;)
revisaré la versión que tengo al llegar a casa y te cuento...

Saludos.

Edito: Tengo la versión 1.2.3.0,....por lo que no es extraño que no funcione. Ahora:
¿Hay algún grabber en español para esta versión que funcione? o en todo caso,
¿Puedo actualizar el MediaPortal a la última versión sin perder los datos catalogados de todas las pelis que tengo?
Muchas gracias.
Me experiencia es que se puede actualizar sin perder información ni configuración, pero es solo mi experiencia de usuario.

En cuanto al script para 1.2.x, creo que nadie lo ha preparado para la nueva modificación de filmaffinity y no creo que ya lo hagan (yo por lo menos no :) )

Sl2
 

TIANO

Portal Member
December 2, 2012
5
0
48
Spain Spain
Gracias de nuevo gomorro.(y)
Actualizaré entonces, que siempre es bueno ponerse al día ...

Muy amable por tu parte, saludos!

Edito: Probado con la versión 1.3.0 del MediaPortal y el grabber FUNCIONA DE MARAVILLA!

Muchas gracias.
 
Last edited:

alexdepalma

MP Donator
  • Premium Supporter
  • January 31, 2008
    540
    493
    Spain Spain
    Country flag
    Desde qué actualice a MP1.4 me fallan las carátulas, todas las que ofrece el grabber me salen en blanco.
    Me ofrece muchas del orden de 40 o más pero todas en blanco, excepcionalmente aparece alguna tras revisar la lista de carátulas.

    Gracias.
    A
     

    gomorro69

    Portal Member
    April 13, 2010
    18
    15
    48
    Spain Spain
    Desde qué actualice a MP1.4 me fallan las carátulas, todas las que ofrece el grabber me salen en blanco.
    Me ofrece muchas del orden de 40 o más pero todas en blanco, excepcionalmente aparece alguna tras revisar la lista de carátulas.

    Gracias.
    A

    Hola, lo que yo he notado en la versión 1.4 de MP es que se generan (no se cuando ni quien) unas imágenes .jpg en la carpeta donde está la película. Lo que yo he hecho es borrar estas imágenes y reconstruir nuevamente la base de datos.

    En el primer post he dejado mi última versión del grabber.

    Sl2
     

    Manuelito

    MP Donator
  • Premium Supporter
  • August 23, 2007
    98
    42
    Spain Spain
    Buenas gomorro69 (y gracias por tus horas "perdidas" con el script).

    ¿Es posible que tengas activada la opción de "Leave a thumb in video folder" en "GUI" -- "Thumbnails"?
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom