Spanish Scraper FilmAffinity.com with IMDb.es bonus to get fanarts -- v2.1.0 (1 Viewer)

vgallego65

MP Donator
  • Premium Supporter
  • January 26, 2006
    171
    7
    Spain Spain
    Country flag
    @vgallego65, that sounds more like another process is locking up the import. MediaInfo is a very known culprit for this. Check into updating the MediaInfo.DLL to the latest version, and see if that solves it. Another option is to disable MediaInfo during import.

    It could be something else, but then you will have to provide debug verbosity enabled log files that capture the 'problem', so it allow us to help you find what is causing it.
    Thank you very much RoChess I will test this evening and let you know.
     

    vgallego65

    MP Donator
  • Premium Supporter
  • January 26, 2006
    171
    7
    Spain Spain
    Country flag
    Hello RoChess, I have been looking for update my Mediainfo.DLL but I didn´t find where to update to a new dll version. I have a fresh install of MP 1.4 so I think must have the last Mediainfo.dll. Also I don´t know how disable mediainfo. Can you help me please?
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    You can download the DLL only from MediaInfo SF site, and just overwrite the DLL inside MediaPortal folder.

    And no, having an updated MediaPortal does not mean you have latest MediaInfo DLL, because the latter updates like every week sometimes, and MediaPortal once a year sometimes. As for disabling MediaInfo during MovPic import, its under the Gear icon inside importer tab.
     

    vgallego65

    MP Donator
  • Premium Supporter
  • January 26, 2006
    171
    7
    Spain Spain
    Country flag
    You can download the DLL only from MediaInfo SF site, and just overwrite the DLL inside MediaPortal folder.

    And no, having an updated MediaPortal does not mean you have latest MediaInfo DLL, because the latter updates like every week sometimes, and MediaPortal once a year sometimes. As for disabling MediaInfo during MovPic import, its under the Gear icon inside importer tab.
    thank you very much again.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    thank you very much again.
    You are welcome.

    PS: Keep in mind to get the 32-bit DLL of MediaInfo, because even on a 64-bit OS you are running a 32-bit version of MediaPortal which can only interact with 32-bit DLLs then.
     

    alamagar

    Portal Pro
    August 6, 2008
    51
    0
    Hi, scrapper has started to not recover score neither popularity from filmaffinity. and most of times not finding ttid from imdb and therefore failing to get backdrop too.

    has it been any change in filmaffinity or imdb webpage this week?

    thks in advance.
     
    Last edited:

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    Hi, scrapper has started to not recover score neither popularity from filmaffinity. and most of times not finding ttid from imdb and therefore failing to get backdrop too.

    has it been any change in filmaffinity or imdb webpage this week?

    thks in advance.
    Fixed with v2.0.6, they indeed changed HTML code again, so adjusted the regular expressions to match.

    However, on a test with "The Wolverine (2013)", it found the correct IMDb tt-ID via "Lobezno inmortal (2013)".

    This is a fuzzy match, meaning an IMDb search is done after a match has been found with the FilmAffinity search system. That means no user interaction is possible anymore, and the scraper-script has to be 100% positive it is the right movie. Would be a lot easier if FilmAffinity had a reference to the IMDb tt-ID number themselves, but they never it make it easy. Still the existing method works, because IMDb does have a large collection of alternative titles in their database. To make sure the movie found is the right one, a match on year is done as well. So if you are still having issues with movies, give me some more info please so I can find out what is the cause and possibly figure out a solution.
     

    peque

    Moderator - Spanish Forums
  • Premium Supporter
  • August 4, 2007
    859
    98
    Spain Spain
    Country flag
    I'm using 2.0.6 script, and again it doesn't recover ttID... I've tried with "Oblivion", "El Gran Gatsby", "Epic", "Iron Man 3", and "A Todo Gas 6".
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom