Stereo Sound on 5.1 Speaker Setup | Page 10

Discussion in 'General Support' started by Snoopy87, January 12, 2017.

  1. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Okay, please try the attached Core.dll.
    1. Close MP and MP Config.
    2. Open Windows File Explorer.
    3. Navigate to your MP install folder (default c:\Program Files (x86)\Team MediaPortal\MediaPortal).
    4. Make a backup of Core.dll.
    5. Download and extract the attached Core.dll to replace the standard one.
    Set WASAPI to exclusive mode.

    For output level...
    If I've done it right, 0 translates to -90 dB (inaudible) and 100 translates to +10 dB (very loud). I recommend to set value 75 (-15 dB) for a start. Even changes of 1 can make a significant difference so be careful unless you want to risk blowing up your AVR amp. ;)


     

    Attached Files:

    • Like Like x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Snoopy87

    Snoopy87 Portal Pro

    Joined:
    August 12, 2012
    Messages:
    468
    Likes Received:
    123
    Gender:
    Male
    Ratings:
    +166 / 10
    Home Country:
    Germany Germany
    Show System Specs
    Thanks a lot! The new version has still not effect :-( In log file it says that setting the volume was successfull...
     
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    :(
    Can you have a quick try with non-exclusive mode as well? (Just to check if it works. I know it's not a solution for you.)
     
  5. Snoopy87

    Snoopy87 Portal Pro

    Joined:
    August 12, 2012
    Messages:
    468
    Likes Received:
    123
    Gender:
    Male
    Ratings:
    +166 / 10
    Home Country:
    Germany Germany
    Show System Specs
    Ok I will test.

    By the way... It seems you set the Windows Speaker Volume... cause I also tried "0" and now I see that the Windows Speaker Volume is set to 0 ....
     
  6. Snoopy87

    Snoopy87 Portal Pro

    Joined:
    August 12, 2012
    Messages:
    468
    Likes Received:
    123
    Gender:
    Male
    Ratings:
    +166 / 10
    Home Country:
    Germany Germany
    Show System Specs
    With non ecklusive mode it is working. Again not the output volume was decreased but the general Windows Speaker Volume was decreased. Thats the reason why it is not working with the exclusive mode, because then the Windows Speaker Volume has no effect to the WASAPI signal.
     
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Okay, so at least this tells us we're not completely crazy.

    The "method" of control (Windows speaker volume vs. WASAPI signal volume) is not intentional.

    I'm currently scouring the BASS/Un4seen forum to try to find answers about why it isn't working. If possible, I'll try to produce another patch for you to try within the next few hours...
     
    • Thank You! Thank You! x 1
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    @Snoopy87
    Just to confirm: does your audio device have a "levels" tab containing volume control in control panel -> sound -> device properties?
     
  9. Snoopy87

    Snoopy87 Portal Pro

    Joined:
    August 12, 2012
    Messages:
    468
    Likes Received:
    123
    Gender:
    Male
    Ratings:
    +166 / 10
    Home Country:
    Germany Germany
    Show System Specs
    Yes.
     

    Attached Files:

    • sound.png
      sound.png
      File size:
      73.7 KB
      Uploaded:
      February 5, 2017
      Views:
      95
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!