Stereo Sound on 5.1 Speaker Setup (3 Viewers)

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Okay, please try the attached Core.dll.
    1. Close MP and MP Config.
    2. Open Windows File Explorer.
    3. Navigate to your MP install folder (default c:\Program Files (x86)\Team MediaPortal\MediaPortal).
    4. Make a backup of Core.dll.
    5. Download and extract the attached Core.dll to replace the standard one.
    Set WASAPI to exclusive mode.

    For output level...
    If I've done it right, 0 translates to -90 dB (inaudible) and 100 translates to +10 dB (very loud). I recommend to set value 75 (-15 dB) for a start. Even changes of 1 can make a significant difference so be careful unless you want to risk blowing up your AVR amp. ;)
     

    Attachments

    Snoopy87

    Portal Pro
    August 12, 2012
    468
    167
    Germany Germany
    Thanks a lot! The new version has still not effect :-( In log file it says that setting the volume was successfull...
     

    Snoopy87

    Portal Pro
    August 12, 2012
    468
    167
    Germany Germany
    Ok I will test.

    By the way... It seems you set the Windows Speaker Volume... cause I also tried "0" and now I see that the Windows Speaker Volume is set to 0 ....
     

    Snoopy87

    Portal Pro
    August 12, 2012
    468
    167
    Germany Germany
    With non ecklusive mode it is working. Again not the output volume was decreased but the general Windows Speaker Volume was decreased. Thats the reason why it is not working with the exclusive mode, because then the Windows Speaker Volume has no effect to the WASAPI signal.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    With non ecklusive mode it is working.
    Okay, so at least this tells us we're not completely crazy.

    Again not the output volume was decreased but the general Windows Speaker Volume was decreased. Thats the reason why it is not working with the exclusive mode, because then the Windows Speaker Volume has no effect to the WASAPI signal.
    The "method" of control (Windows speaker volume vs. WASAPI signal volume) is not intentional.

    I'm currently scouring the BASS/Un4seen forum to try to find answers about why it isn't working. If possible, I'll try to produce another patch for you to try within the next few hours...
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    @Snoopy87
    Just to confirm: does your audio device have a "levels" tab containing volume control in control panel -> sound -> device properties?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom