Still Unable to play Live or Recorded TV (1 Viewer)

porky996t

MP Donator
  • Premium Supporter
  • May 21, 2008
    1,013
    81
    Bolton, Lancashire, England
    England England
    Hi,

    I'm still having a problem in being able to play live or recorded TV with MP. This has been going on for around 10 months now, and I haven't really had the time to get around to fixing the issue.

    Find attached the logs, three from the separate TV server and one from the MP client. Just by way of information I tried tuning to BBC One at around 17:02 and the dialog box came up "Unable to play stream"

    Thanks in advance.
     

    Attachments

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    This is the problem (from MediaPortal.log at the client):

    Code:
    [2018-12-23 17:02:17,389] [Error  ] [MPMain   ] [ERROR] - TSReaderPlayer: Exception while creating DShow graph Retrieving the COM class factory for component with CLSID {B9559486-E1BB-45D3-A2A2-9A7AFE49B23F} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
    CLSID {B9559486-E1BB-45D3-A2A2-9A7AFE49B23F} is the CLSID for TsReader.ax, and it's saying it's not 'registered' in Windows.

    On the client, open an administrator command prompt at/in C:\Program Files (x86)\Team MediaPortal\MediaPortal (where the TsReader.ax file should be) and type:

    regsvr32 TsReader.ax

    Hopefully that will register it and report success. If it doesn't then try:

    regsvr32 -u TsReader.ax

    ...to un-register it, then type 'regsvr32 TsReader.ax' to try registering it again.

    If it still doesn't work, I suggest re-installing MP on the client.
     

    porky996t

    MP Donator
  • Premium Supporter
  • May 21, 2008
    1,013
    81
    Bolton, Lancashire, England
    England England
    Thanks! That's great, it is now working on my workstation and I can now watch TV. TBH the server has been playing up for quite sometime and I'm hoping I can put in the necessary time over the holidays to get the whole house system back up and running properly.

    Thanks again, I'm grateful for your help.
     

    porky996t

    MP Donator
  • Premium Supporter
  • May 21, 2008
    1,013
    81
    Bolton, Lancashire, England
    England England
    Just to add a bit further, this same issue happens on the Lounge Client which is win7 x 86. I'll just wipe clean and do a full re-install. This problem happening on the two machines lead me to think there was an issue on the Server - so when I can get to the Lounge PC I'll update to the version to match the TV server and see how it goes.

    Thanks again @Owlsroost I'm very grateful
     

    porky996t

    MP Donator
  • Premium Supporter
  • May 21, 2008
    1,013
    81
    Bolton, Lancashire, England
    England England
    I managed to get onto the lounge PC tonight, and looked through the logs again. I have the same issue as the other machine. I tried to register the TsReader using the admin command prompt as previously noted, but got the attached error message.

    Hmmm.. any ideas?

    EDIT: I reinstalled/repaired the Visual C++ files under Program Options and this then enabled me to register the TsRedaer.ax files - obviously something corrupt in C++ somewhere.
     

    Attachments

    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    ratata Non present codecs is still showing... MediaPortal 1 Talk 2
    P [solved] TV server no longer saving to NAS - (can still play from NAS) General Support 2
    high [Help Me!] Atlassian Fisheye/Crucible still used? Team Lounge 8
    N Onscreen keyboard to still accept input from real keyboard Feature Requests 6
    el Filou Is Windows Media Player still needed on Windows 10 ? MediaPortal 1 Talk 0
    Symphy Still being used? ASIO music player 0
    A 1.20 issues still exists in 1.21 pre-release Watch / Listen Media 13
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    M Unable to map virtual sent keys in the input device management General 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    megahorst Unable to delete unseen recording while TV runs in the background 1.19 11
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    Similar threads

























    Top Bottom