[solved] Stopped capturing live tv (1 Viewer)

irw

Portal Member
July 21, 2022
16
3
Home Country
United Kingdom United Kingdom
MP2 Version
2.4.1
Before you create this bug report:
  1. Make sure that your system (Windows, codecs and drivers) is up to date, matching the Requirements and you've filled in your System Specs.
  2. Have a look at our MediaPortal Wiki! Maybe the solution is already there.
  3. Have a look at our Jira (Bug and Issue Tracker)and the threads in this section, maybe your problem is already known.
  4. Search the forums for your problem, it's very likely that someone else already encountered the same problem.

Please always include log files with your Bug Report!
Check out our Wiki: Bug Reports and Log Files

==================================================================

Describe the Problem you encounter as detailed as possible! "It does not work" won't help the team to understand the problem.
Description:
Server and client worked until 25/5/23 then live TV failed and so no new recordings made.
Initial steps taken are:
Restart MediaPortal, then restart PC, then uninstall MediaPortal and reinstall it.
No change.
I believe there was a Windows update and then an Avast AV update so I suspended all Avast shields for an hour and kept trying but no live TV.
I tried but cannot reverse the Windows update.
Plenty of HDD space.
Checked aerial cable into TV tuner card. All secure.
MediaPortal loads fine but when a live program is selected the wait spinner spins for a long time then stops with no action.

I am able to watch programmes that were recorded up to the failure.
I have looked through all log files and found some with the word Error.
There are so many log files I hope I have uploaded them all and not missed any. I have prefixed the name with the folder to help. Being able to upload folders would be even better.

Describe as detailed as possible the steps that are required to encounter the issue. This info is critical for the team to understand the problem.
Steps to Reproduce:

Switch on, MediaPortal loads and try to watch TV. Nothing.




.
 

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,709
    3,492
    Stuttgart
    Home Country
    Germany Germany
    Sorry to say, but you did not check the description well ;) click on the wiki link and you will see how to set logs to debug mode. It also explains, that a click on the log collector creates a zip file of all logs, so there is no need to look for them individually.

    After setting the logging to debug, don’t forget to reproduce the problem before uploading.
     

    irw

    Portal Member
    July 21, 2022
    16
    3
    Home Country
    United Kingdom United Kingdom
    I think I was using some MediaPortal1 instructions which didn't help as my Forum Profile did not show System Specs. Hope I've got it right this time. I set the system to verbose first. Can you delete my post on the forum about this issue too please?
     

    Attachments

    • MediaPortal2-Logs-2023-05-28-11.36.35.zip
      8.9 MB

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,709
    3,492
    Stuttgart
    Home Country
    Germany Germany
    @morpheus_xx
    I reported in our internal thread I do not see TV logos. The logs of @irw are full of:
    [2023-05-27 13:10:00,584] [859872 ] [110 ] [ERROR] - SlimTv Logos: Error processing logo image.
    System.AggregateException: One or more errors occurred. ---> System.ServiceModel.CommunicationException: The server did not provide a meaningful reply; this might be caused by a contract mismatch, a premature session shutdown or an internal server error.
    at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
    at System.ServiceModel.Channels.ServiceChannel.SendAsyncResult.End(SendAsyncResult result)
    at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
    at System.ServiceModel.Channels.ServiceChannelProxy.TaskCreator.<>c__DisplayClass7_0`1.<CreateGenericTask>b__0(IAsyncResult asyncResult)
    at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at MediaPortal.LogoManager.LogoRepository.<Lookup>d__10.MoveNext()
    --- End of inner exception stack trace ---
    at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
    at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
    at System.Threading.Tasks.Task`1.get_Result()
    at MediaPortal.LogoManager.LogoRepository.Download(String[] channelName, ChannelType channelType, String regionCode)
    at MediaPortal.LogoManager.LogoRepository.Download(String channelName, ChannelType channelType, String regionCode)
    at MediaPortal.Plugins.SlimTv.SlimTvResources.FanartProvider.SlimTvFanartProvider.TryGetFanArt(String mediaType, String fanArtType, String name, Int32 maxWidth, Int32 maxHeight, Boolean singleRandom, IList`1& result)
    ---> (Inner Exception #0) System.ServiceModel.CommunicationException: The server did not provide a meaningful reply; this might be caused by a contract mismatch, a premature session shutdown or an internal server error.
    at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
    at System.ServiceModel.Channels.ServiceChannel.SendAsyncResult.End(SendAsyncResult result)
    at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
    at System.ServiceModel.Channels.ServiceChannelProxy.TaskCreator.<>c__DisplayClass7_0`1.<CreateGenericTask>b__0(IAsyncResult asyncResult)
    at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at MediaPortal.LogoManager.LogoRepository.<Lookup>d__10.MoveNext()<---
    Maybe there is a connection to my problem.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,709
    3,492
    Stuttgart
    Home Country
    Germany Germany
    MediaPortal loads fine but when a live program is selected the wait spinner spins for a long time then stops with no action.
    Can you check the TV configuration once. Is this still working and can you see TV-channels in the preview there? I think the windows update changed settings which broke the connection.
    • Option 1: In case you can not watch TV also in the configuration preview, you might need to reconfigure TV again.
    • Option 2: If even the TV configuration does not start, you need to remove the TV settings in "C:\ProgramData\Team MediaPortal\MP2-Server\SlimTVCore" (better backup) and reinstall MP2 again, so default settings are used
     

    irw

    Portal Member
    July 21, 2022
    16
    3
    Home Country
    United Kingdom United Kingdom
    First, thanks for such a speedy investigation as currently no TV for three days.
    If you asking me if I think there is a connection, then I have no idea. All I can say id that the day before everything worked then it stopped. I suspected a Windows or Avast update but maybe was wrong to do so.
    Because I was unsure what you or the logs mean by Logos, I checked the Wiki Glossary but nothing there. If you mean the imagery for each TV channel that appears on the TV Home screen or beside the live TV list, then they appear as usual.
     

    irw

    Portal Member
    July 21, 2022
    16
    3
    Home Country
    United Kingdom United Kingdom
    Sorry - I don't understand "Can you check the TV configuration once. Is this still working and can you see TV-channels in the preview there?" I don't know what you mean by configuration preview. By Configuration I assume this is the server. I've looked through all relevant menu items but don't see anything to allow preview.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,709
    3,492
    Stuttgart
    Home Country
    Germany Germany
    Sorry - I don't understand "Can you check the TV configuration once. Is this still working and can you see TV-channels in the preview there?" I don't know what you mean by configuration preview. By Configuration I assume this is the server. I've looked through all relevant menu items but don't see anything to allow preview.
    The preview in the "TV configuration" where you perfrom also the scan, the shortcut is on your desktop.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,709
    3,492
    Stuttgart
    Home Country
    Germany Germany
    First, thanks for such a speedy investigation as currently no TV for three days.
    If you asking me if I think there is a connection, then I have no idea. All I can say id that the day before everything worked then it stopped. I suspected a Windows or Avast update but maybe was wrong to do so.
    Because I was unsure what you or the logs mean by Logos, I checked the Wiki Glossary but nothing there. If you mean the imagery for each TV channel that appears on the TV Home screen or beside the live TV list, then they appear as usual.
    This post was not for you, but morpheus_xx, which I tagged ;)
     

    irw

    Portal Member
    July 21, 2022
    16
    3
    Home Country
    United Kingdom United Kingdom
    OK, I think I misinterpreted the word Preview. Yes, got the desktop icon OK and opened Configuration. I see all the channels and attach two screen prints for you to agree all looks OK.
     

    Attachments

    • Configuration Combinations.png
      Configuration Combinations.png
      210 KB
    • TV Mapping.png
      TV Mapping.png
      279.4 KB

    Users who are viewing this thread

    Top Bottom