1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange Scrolling

Discussion in 'MPTagThat' started by CyberSimian, December 17, 2017.

  1. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,014
    Likes Received:
    184
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +444 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Recently I transferred my CD collection to hard disk (I used the fre-ac converter, as I did not realise that MpTagThat could do this). However, some of the associated info is wrong, and I was trying to use MpTagThat to correct it. One of the recordings that I am trying to correct has resulted in some strange scrolling in MpTagThat.

    This is the situation: the recording is split musically into three parts, spread over two CDs, and stored by me in one folder. The result is that there are 58 tracks (files) in this folder. Each file name begins with the two-digit track number, from "01" to "58". But MpTagThat does not allow me to scroll to see tracks "01" to "06". Look at the following screen shots; notice that the vertical scroll bar is a different length in the two screen shots, and that the up-arrow that ought to be present at the top of the scroll-bar column is missing:



    top_of_list.jpg bottom_of_list.jpg

    I also tried with the top horizontal menu visible (the orange down-arrow near top right), but that exhibits the same problem. Is there some setting that I should be using to ensure that all files can be seen by scrolling? Thank you.

    -- from CyberSimian in the UK
     
    Last edited: December 17, 2017
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,479
    Likes Received:
    1,620
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,240 / 1
    Home Country:
    Austria Austria
    Sounds strange. I have tried it here and it works without any problems.
    Which version are you using?
     
  4. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,014
    Likes Received:
    184
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +444 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I am using MP 1.18 :), on Vista :eek:. The version of MpTagThat is 3.1.8.

    Since making the original post, I have realised that the strange scrolling occurs only when the MpTagThat panel is displayed windowed. If it is displayed fullscreen, the scrolling works correctly. :) When fullscreen, the vertical scroll bar is the same size whether it is at the top or bottom of the list (i.e. it does not appear to change size as the list is scrolled from top to bottom), and the up-arrow at the top of the scroll-bar column is visible.

    Possibly the strange scrolling is caused by some miscalculation in the layout of the panel when the number of tracks is large. In my case, the fullscreen panel accommodates 33 tracks, so I exited MpTagThat and reduced the number of tracks in the folder to 32, and then restarted MpTagThat. In fullscreen mode, all tracks are visible and no vertical scroll bar is displayed (since it is not needed). But when windowed, a vertical scroll bar is needed, but none is displayed (so the list cannot be scrolled vertically). :(

    -- from CyberSimian in the UK
     
  5. hwahrmann
    • Team MediaPortal

    hwahrmann Development Group

    Joined:
    September 15, 2004
    Messages:
    4,479
    Likes Received:
    1,620
    Gender:
    Male
    Location:
    Vienna, Austria
    Ratings:
    +2,240 / 1
    Home Country:
    Austria Austria
    i only have Windows 7 and 10 available and don't see the behaviour. even running in windowed mode.
     
  6. CyberSimian
    • Team MediaPortal

    CyberSimian Test Group

    Joined:
    June 10, 2013
    Messages:
    1,014
    Likes Received:
    184
    Gender:
    Male
    Location:
    Southampton
    Ratings:
    +444 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    My production system uses Vista, but I have Windows 7 in a test partition, so I installed MpTagThat into the test partition. I can confirm that the problem is not present in Windows 7. :) I guess that there must have been some change in the way that Windows handles certain API calls between Vista and 7. :(

    There was a brief discussion recently about whether MP should continue to support Vista. Although no decision was made (as far as I am aware), I suspect that MP's support of Vista is not long for this world. So I don't think that it is worthwhile spending any time trying to cure this Vista quirk. Thank you for looking at it.

    -- from CyberSimian in the UK
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Like Us On Facebook

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!