[Feature Req] Streaming from mapped network drives (1 Viewer)

SkinsFan0521

Portal Pro
October 19, 2011
54
1
United States of America United States of America
So, I know that it's a known issue that we can't stream from a NAS, but I thought that the solution is to change the logon information for the service? I've tried every combination that I can think of. I've tried changing the logon information in the Configurator, in each of the services, in both of the services, etc. I've tried with the firewall completely disabled and that doesn't change anything either.

I'm sure that the problem is because of the items being on the NAS because I copied a video into one of the local video folders and it works perfectly fine. When I try going to Videos > <my NAS> I see no videos, but when I go to Videos > <my local video folder> I see the video and it plays.

Also, my TV streaming works fine. I'm not sure if it matters or not, but I'm on MediaPortal 1.3 Alpha

I'd really appreciate any help with this!

Thanks a lot!
 
Last edited:

SkinsFan0521

Portal Pro
October 19, 2011
54
1
United States of America United States of America
Ok, well, after hours of trying to figure it out last night, I think I figured it out this morning.

I had everything in MP set up to use a mapped drive to my NAS. Well, I decided to test something out on a VM that I have and if I change TV Series, Moving Pictures, etc to use a unc patch, that works and I can connect to my network drive to stream through aMPdroid! I didn't need to change the user that the service runs as or anything like that. Just setting the plugins to use a unc path did the trick.

Now, I just need to make the changes in my live system and I can start streaming my stuff from anywhere in the world!

I didn't see that mentioned in any documentation or forum posts anywhere so I wanted to be sure to follow up with this post saying that I figured out the answer if anybody else out there is beating their heads against the wall.
 

TheBatfink

MP Donator
  • Premium Supporter
  • June 11, 2007
    1,285
    220
    Nottingham
    United Kingdom United Kingdom
    Country flag
    I can't stream from my whs server and I always use UNC paths for everything. Did it work on your production system then?

    Thanks
     

    psykix

    MP Donator
  • Premium Supporter
  • July 10, 2009
    785
    46
    Wirral
    United Kingdom United Kingdom
    Just noticed this thread, and I am having the same issue with my QNAP.

    Tried changing to UNC paths and it works fine now! Thanks very much!
     

    IchBinsShort

    Portal Pro
    January 3, 2008
    682
    54
    Germany Germany

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    S rotierende disk in streamed mp Skin Modifikationen 30
    C Streaming/transcoding MP2 vs MP1? General 4
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    P Streaming MediaPortal 1 Talk 5
    P Streaming to two clients from the same card Newcomers Forum 1
    L Non-PC device streaming... Newcomers Forum 1
    raffe How to add 500+ streams? OnlineVideos 1
    R Heavy pixelation on HD OTA Streams Installation, configuration support 1
    C streaming out UDP instead of RTSP Newcomers Forum 0
    C Recording back to back shows from IPTV streams General Support 8
    T Missing sound in online streaming service (SVTPlay) General Support 3
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    doskabouter Black screen while watching some iptv streams General Support 2
    II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
    amatesi MP2.2pre Client crash while streaming Live TV from remote MP2.2pre Server (both offline) 2.2 Archive 8
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    jmarc Recording IPTV streams General Support 1
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    C Is there a Tuner Stream Failure Alarm Plugin? MediaPortal 1 Plugins 1
    P [solved] MediaPortal 2 Won't stream HDHR Dual General 1
    M.Hulot Streamed MP behält gewählte Ansicht nicht bei Allgemeines Supportforum 4
    J Different video and audio streams. OnlineVideos 8
    M WebMediaPortal Stream LiveTV Problems MPExtended 2
    Similar threads

























    Top Bottom