[fixed] Subtitles .idx & .sub issue (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    I think too much lol :)

    I understand your point of view, with the team we decide that Autoload Subtitles means that do not autoload subtitle except forced one if available.
    About idx/sub we can't detect/check if the subtitle track is forced or not, because, it's not the whole subtitle track flag but the displayed sub that can be forced flag or non forced.
    All Forced and non Forced sub are mixed in the same track.
    On your sample, maybe some displayed sub are forced flag but for sure not few first.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi :)

    WIP :
    With help of cpp2005 on MPC-HC (dll), now it's possible to enable or not full/forced subtitle in live (when looking movie etc.)
    So i have made a patch for it in MP and StreamedMP skin.

    What is the purpose :
    Set Autoload to OFF -> Only forced sub will be selected by default and we can switch on other available subtitle, if the next subtitle stream is idx/sub, we can enable Full Sub option from the GUI and get/display all :)

    Thanks :)

    Ps : This feature will be include (i hope) in 1.3.0 and surely not in 1.2.0.
    Seb.
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    That's great news!

    Is there a way to try this out under Avalon skin?
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    I didn't know about Avalon, did test it, but just need to edit skin (Just is maybe not just), i want to say that we have to have :
    Patch for MP
    New DLL
    And skin files. :p
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi,

    This is for testing only :
    Attached binaries.
    strings_en.xml is to put in : "C:\ProgramData\Team MediaPortal\MediaPortal\language" folder
    I'm not really good in skin, so you can try with avalon by adding this in skin file (it's the one for StreamedMP):

    <control>
    <description>SubTitles Forced On/Off Checkbox</description>
    <type>checkmark</type>
    <id>803</id>
    <posX>908</posX>
    <posY>174</posY>
    <MarkWidth>20</MarkWidth>
    <MarkHeight>20</MarkHeight>
    <label>200092</label>
    <onup>801</onup>
    <ondown>802</ondown>
    <onleft>803</onleft>
    <onright>803</onright>
    <visible>no</visible>
    <animation effect="slide" start="1300,0" end="0,0" tween="quadratic" time="300" delay="0">visible</animation>
    </control>
    Thanks :)
     

    Attachments

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Sebastiii,

    I am trying to configure it but i cannot get it to work.

    And to avoid any issues i enabled the default skin and try it with that and still no go.

    Could you please tell me if i need latest SVN for that to work?

    Or can i just copy and replace the 3 files u link?

    Some more detailed steps would be welcome since i am not able to try it out.

    My current setup is MP 1.2.0 BETA and Default Wide skin.

    Thanx in advance.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Hi Kotik,

    can you post log ?
    Yes the dll are made on latest SVN, so maybe need dialog.dll too.
    This a new files.
    I have create dir :
    Put mediaportal dir in program files mediaportal dir.
    Skin in c:\ProgramData\Team MediaPortal\MediaPortal\
    language in c:\ProgramData\Team MediaPortal\MediaPortal\

    Set Autoload subtitle to off and start mp now to go menu -> go to "Y" key and select Subtitle sub menu, here so you see "Forced Only".
    Look the screenshot :)
    Thanks.
    Seb.
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    mickb Subtitles My TVSeries 9
    M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
    J How to change y position of subtitles General 3
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    S Remote button to change audio and subtitle on / off General 10
    P [solved] ATSC subtitles not fixed yet? General 2
    E Swedish subtitles problem General 2
    ratata Someone stole my subtitles... General Support 0
    Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    S Display non english folder name, subtitle, etc. General 23
    S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
    S [solved] Live TV subtitle issue if not using 100% font General 31
    D [solved] How to configure subtitle color in MP 2.2.1? General 5
    S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
    G [fixed] [MP2-611] Having problems with subtitles (ATSC) 2.2 Archive 14
    S Australia live TV teletext subtitle General 4
    J How to save recorded Movies and TV Series to sub-folders? Newcomers Forum 1
    R TV menu icon does not work to return from sub-menu item Submit: Bug Reports 4
    Top Bottom