[fixed] Subtitles .idx & .sub issue (1 Viewer)

Kotik

MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Ok got it working. Thanx.

    So here we go to the questions:)

    1. Am i right to believe that currently u have to disable Forced Sub option under the Y menu for every movie that u start watching?

    2. If the answer to 1 is YES then is it possible to have the same option but this time add it to MP configuration menu and make it global? Under the global/general subtitle options just add this option?

    Cause currently the user has to press lots of buttons on each movie start just to get this working.

    Other than that, it is working great :)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Ok got it working. Thanx.

    So here we go to the questions:)

    1. Am i right to believe that currently u have to disable Forced Sub option under the Y menu for every movie that u start watching?

    2. If the answer to 1 is YES then is it possible to have the same option but this time add it to MP configuration menu and make it global? Under the global/general subtitle options just add this option?

    Cause currently the user has to press lots of buttons on each movie start just to get this working.

    Other than that, it is working great :)
    Cool,

    If you want to disable Forced Sub by "Y" key, maybe it's better to make autoload subtitle to ON ?, I didn't follow you lol :)

    Except for idx/sub, if autoload is OFF (so user don't want sub except forced one) and if user want to see another sub, it can be done by switching subtitle.

    Now if you want to see all subtitle in idx/sub, we have to disable forced flag by the menu "Y", i mean, that if you want this option (Forced Enable in "Y" menu) by default, you need to put autoload sub to ON in configuration.
    And if user who want to see only forced sub in idx/sub, Autoload subtitle must be set to OFF.

    I have try to working on menu config (but it didn't solve that you want, look the screenshot).

    Ps : Idx/Sub is a special subtitle format.

    I think that you want is an option in configuration for IDX/SUB to override setting for Full Sub or Forced Sub but that it can be enable or disable from the GUI.

    This need special feature to detect selected sub if it's IDX/SUB or not. i think it's a big rework and don't know if it's possible easily.

    Thanks,
    Seb.
     

    Attachments

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    So lets see,

    Lets say that you have all your movies with .IDX/SUB.

    And you don't want any subtitles when the movie starts BUT you want to be able to activate them during the movie and you want to be able to switch BUT you want to be able to also see the movie without subtitles.

    Before 1.2 BETA all you had to do is the following:

    Auto Load-->OFF, start the movie, press f9 check if you do have subtitles for the movie and what kind of languages they are and then just select one.

    Now you cannot do this anymore.

    So what i would like is to be able to do the same thing under 1.2 BETA.

    I am still trying to find a nice way to do this, but it has to be simple and not user confusing.

    I do understand that we need Forced Subs and that .IDX/SUB is a special format.

    P.S. so if i understand correctly MP at the moment tags all the .IDX/SUB as Forced Subtitles and that's why if you don't have the Auto Load option ON it wont display them?
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Before 1.2.0; forced flag didn't work or not totally.
    Now that forced flag is working, all work like it does (based on actual setting).

    When forced flag didn't work before 1.2.0Beta), when you set autoload to off, subtitle was not enable by default but you can select it later when looking movie.
    Now forced flag is working correctly, it didn't auto enable subtitle except if forced sub was found. (IDX/SUB can contain forced sub in his track)
    Like IDX/SUB is a mixed format, the fact to autoload to OFF, make it display only subtitle marked as forced in your alone selection (here english in your sample).
    So in this mode, if you sample contain some forced flag inside your English Track, it will be displayed. (Example : your english track can contain 10 subtitles and inside 10 Subs, it can be 3 sub marked as Forced) Did you follow ? :)

    Now i understand that all your IDX/SUB surely didn't contain some subtitle with the forced flag, but like the splitter can't know it, if user set he want only forced sub, it's normal that you can see any sub (this is why we add a GUI function to disable it but like you note need to be set each start of movie).

    I think if you have look @ the screenshot above that i have add a third option. "subtitle won't be auto loaded", it's mean that it's that you want, none subtitle will be enable by default by can't be enable when you play your movie. it's like before 1.2.0Beta.

    And we have these other option :
    "Subtitle will be auto loaded by language preference" equal to autoload sub to ON.
    "Subtitle will only display forced subtitles *" equal to autoload sub to OFF.

    If you want i can provide you by PM this new feature and you can tell me if it answer to your hope :)
    Thanks.
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    What are you waiting for??? :)

    PM go go :)

    And thank you once more for dedicating your time into this.
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Yes Sebastiii,

    Will try it out right away cause i was busy with work the last couple of days.


    EDIT:

    Getting the following error:

    2011-07-16 03:50:49.683201 [ERROR][MPMain(1)]: PluginManager: WindowPlugins, Version=1.1.7.28039, Culture=neutral, PublicKeyToken=null is tagged as incompatible with the current MediaPortal version and won't be loaded!
    2011-07-16 03:50:50.194230 [ERROR][MPMain(1)]: PluginManager: Dialogs, Version=1.1.7.28039, Culture=neutral, PublicKeyToken=null is tagged as incompatible with the current MediaPortal version and won't be loaded!
    2011-07-16 03:50:51.148285 [ERROR][MPMain(1)]: Exception: System.NullReferenceException: Object reference not set to an instance of an object.
    at MediaPortal.GUI.Library.GUIWindowManager.ActivateWindow(Int32 newWindowId, Boolean replaceWindow, Boolean skipHistory, String loadParameter)
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Thanks for the new file will try it.

    Just want to inform you that i managed to make it to work yesterday by just replacing all the files except for WindowPlugins.dll and Dialogs.dll :) Since i was interested more in the global option like i told you :) and you rock!!! it is exactly what i was asking for :)

    Thank you very much Sebastiii and Team.

    But i will try the new version anyway.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    Nice :)

    You need to replace WindowPlugins.dll to enable/disable forced option on screen otherwise it didn't work :) Dialogs.dll is based on recent change (SVN from core.dll).
    It's nice if it's work :)
    Thanks.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    mickb Subtitles My TVSeries 9
    M.Hulot Blu-ray: Es werden nicht nur Forced Subtitles angezeigt Allgemeines Supportforum 1
    J How to change y position of subtitles General 3
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    S Remote button to change audio and subtitle on / off General 10
    P [solved] ATSC subtitles not fixed yet? General 2
    E Swedish subtitles problem General 2
    ratata Someone stole my subtitles... General Support 0
    Dark Eyes Display subtitles on a separate display or device MediaPortal 1 Plugins 0
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    S Display non english folder name, subtitle, etc. General 23
    S [solved] Movie SRT subtitle didn't display on client 2.2 Archive 18
    S [solved] Live TV subtitle issue if not using 100% font General 31
    D [solved] How to configure subtitle color in MP 2.2.1? General 5
    S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
    G [fixed] [MP2-611] Having problems with subtitles (ATSC) 2.2 Archive 14
    S Australia live TV teletext subtitle General 4
    J How to save recorded Movies and TV Series to sub-folders? Newcomers Forum 1
    R TV menu icon does not work to return from sub-menu item Submit: Bug Reports 4
    Top Bottom