SVT Play | Page 24

Discussion in 'OnlineVideos' started by Johan, November 20, 2010.

  1. emphatic
    • Team MediaPortal

    emphatic Design Group

    Joined:
    August 25, 2006
    Messages:
    3,586
    Likes Received:
    828
    Gender:
    Male
    Occupation:
    Surface treatment
    Location:
    Alingsås
    Ratings:
    +1,083 / 2
    Home Country:
    Sweden Sweden
    Show System Specs

    Just tried Idol and it's working better than I've ever could dream of. Subtitle support! OMG.



    Emph
     
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Ministerk
    • Super User

    Ministerk Super User

    Joined:
    November 28, 2007
    Messages:
    970
    Likes Received:
    401
    Occupation:
    Systems developer
    Location:
    Uppsala
    Ratings:
    +831 / 3
    Home Country:
    Sweden Sweden
    Show System Specs
    Yeah, I sneaked in subtitle support a while ago... The subtitle format on TV4Play is smil which is a bit tricky, lots of different attributes and tags allowed. If you notice some strange formatting in the converted srt subtitles please tell me about it.
     
    • Thank You! Thank You! x 2
  4. Pastill

    Pastill Portal Pro

    Joined:
    September 2, 2007
    Messages:
    74
    Likes Received:
    4
    Ratings:
    +4 / 0
    Yes. I created a new group and called it "Favoriter" and found a thumb formed as a yellow star.
    So now all is OK ( but how do I get rid of the old Favorites. I cleaned all contents but ....

    Only Place that Microsoft Decoder were set was in TV H.234. All other settíngs were LAV ! ?
    Now Codec settings on all media is on LAV.

    Still this problem with Picture freezing after 10s on SVT, TV4, a German station on HD ( but not SD) and ....
    YouTube ( eaven on HD), CNN and ... is OK though.
    All ( 5 or 6 ?) tests on Configuration Codec page performed OK.

    Attach new log where you first find YouTube ( two different filetypes and highest def ) working OK and then SVT where Picture freeze.
     
  5. Ministerk
    • Super User

    Ministerk Super User

    Joined:
    November 28, 2007
    Messages:
    970
    Likes Received:
    401
    Occupation:
    Systems developer
    Location:
    Uppsala
    Ratings:
    +831 / 3
    Home Country:
    Sweden Sweden
    Show System Specs
    It's strange, when I look at the logs I see no LAV codec.

    The first video, MACKLEMORE & RYAN LEWIS - THRIFT SHOP FEAT. WANZ (OFFICIAL VIDEO) (1920x1080 | mp4 (37), plays with Microsoft:
    [08-25 18:57:13,566] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> Microsoft DTV-DVD Video Decoder --> Enhanced Video Renderer
    [08-25 18:57:13,676] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> Microsoft DTV-DVD Audio Decoder --> DirectSound: Realtek Digital Output(Optical) (Realtek High Definition Audio)

    The second, Carly Rae Jepsen - Call Me Maybe (1920x1080 | webm (46), with ffdshow:
    [08-25 18:57:50,252] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> ffdshow Video Decoder --> Enhanced Video Renderer
    [08-25 18:57:50,402] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> LAV Audio Decoder --> DirectSound: Realtek Digital Output(Optical) (Realtek High Definition Audio)

    We se that the above videos uses different video containers (mp4 and webm/mkv) and uses two differnt video and audio codecs.

    SVTPlay uses microsoft:
    [08-25 18:58:50,847] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> Microsoft DTV-DVD Video Decoder --> Enhanced Video Renderer
    [08-25 18:58:50,997] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> Microsoft DTV-DVD Audio Decoder --> DirectSound: Realtek Digital Output(Optical) (Realtek High

    It seems the Mediaportal settings are ignored and maybe the DirectShow video codec merits are used instead. @Pastill can you check if have ticked the "Automatic Decoder Settings" under Codecs and renderers in configuration.

    Do you have or had any other codecs/packs installed on your computer? Many codecs aren't always a good thing, maybe try to uninstall all codecs and only install the necessary.

    I think this is all that I can contribute with right now, i'm no expert, if problems still exists you might consider to start a new forum thread.

    Edit:
    You can check which codecs being used by pressing Shift+1 while playing videos. + some altering of text above

    Edit again:
    If "Automatic Decoder Settings" isn't check maybe check it, save and close config, uncheck it again and save and then maybe restart computer just to be sure...
     
    Last edited: August 26, 2013
  6. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Automatic Decoder Settings should be unchecked -> when checked it will let the Windows System figure out what codec to use, instead of preferring the selected ones in MP Config (which looks like what is happening here).
     
    • Agree Agree x 1
  7. Ministerk
    • Super User

    Ministerk Super User

    Joined:
    November 28, 2007
    Messages:
    970
    Likes Received:
    401
    Occupation:
    Systems developer
    Location:
    Uppsala
    Ratings:
    +831 / 3
    Home Country:
    Sweden Sweden
    Show System Specs
    Thanks for clarifying, this was what I was trying to say in my rambling above :whistle:...
     
  8. Pastill

    Pastill Portal Pro

    Joined:
    September 2, 2007
    Messages:
    74
    Likes Received:
    4
    Ratings:
    +4 / 0

    Done now. Don't know when and how it was checked. Perhaps the warning text "did it". It's not clear in text the real effect of un-/checking.

    But video was working ok before unchecking.
    Updated BIOS, graphic driver and SAF ( incl LAV) and altered just a few settings.
    After that everything is ok.,

    It was a long time since "codec packs" were installed, more problems than help with that. ( So perhaps I should uninstal SAF )
     
  9. Ministerk
    • Super User

    Ministerk Super User

    Joined:
    November 28, 2007
    Messages:
    970
    Likes Received:
    401
    Occupation:
    Systems developer
    Location:
    Uppsala
    Ratings:
    +831 / 3
    Home Country:
    Sweden Sweden
    Show System Specs
    Great (y)!
     
  10. Ministerk
    • Super User

    Ministerk Super User

    Joined:
    November 28, 2007
    Messages:
    970
    Likes Received:
    401
    Occupation:
    Systems developer
    Location:
    Uppsala
    Ratings:
    +831 / 3
    Home Country:
    Sweden Sweden
    Show System Specs
    FYI
    It has been reported here in the forums and now also through OnlineVideos that videos doesn't play properly in SVTPlay (and TV4Play).
    If you got this problem please try this to downgrade MediaPortalUrlSourceSplitter in MediaPortal Extension Manager to version 1.0.0.2868 and see if that fixes the problems.

    A bug report has been filed here. If you get problems please report with logs in that thread.

    Sorry for cross posting, but I know more peoples follow this thread than the other threads mentioned in this post.
     
    Last edited: October 7, 2013
    • Thank You! Thank You! x 2
    • Informative Informative x 2
    • Like Like x 1
  11. Ministerk
    • Super User

    Ministerk Super User

    Joined:
    November 28, 2007
    Messages:
    970
    Likes Received:
    401
    Occupation:
    Systems developer
    Location:
    Uppsala
    Ratings:
    +831 / 3
    Home Country:
    Sweden Sweden
    Show System Specs
    Hi,

    SVT have to (is forced to) use Flash Access 3 DRM protection on Homeland. This is the only show (right now...) using this kind of copy protection on SVTPlay. I cannot get this to play (only some quick shots in the dark).

    A small question to someone more knowledgeable, @offbyone, can online videos play this kind of copyright protected content at all? If the answer is "I do not know" or "yes off course", I will provide logs and fiddler stuff later on.

    Link to message @svt: http://www.svt.se/tittarservice/hitta-svar/teknik/homeland-kraver-flash-access-3 (in Swedish)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!