TBS: CI/CAM support and other improvements (3 Viewers)

shummi

Portal Pro
February 24, 2010
51
2
Home Country
Denmark Denmark
Hi

I have tryed your patch, but it is crasing my TV servise, I know MDAPI isen't supported, and I don't expect your support.
So this is just for your info.

First I have updated the TBS6984 driver to 1.0.1.5, and tryed DiSeq simple a,b and Level AA,AB,BA,BB, this dosn't work

Then i installed your patch, but my TV server crash every time i start live TV, i have tryed all 3 Dlls.
I think it is due to missing CAM module, I can see in TV.log that it is looking for CAM on every installed cards.

If you like i can make some more tests, just tell me what to try.

BR Shummi
 

mm1352000
Country flag

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,207
    Home Country
    New Zealand New Zealand
    • Thread starter
    • Moderator
    • #12
    Hi Shummi

    I guess you must be having the same crash as DJBlu. I honestly can't see any reason for it in the code although I must surely be overlooking something. Could you please try the attached TVLibrary.dll and post logs after trying it - M***I doesn't matter in this case.

    mm
     

    Attachments

    shummi

    Portal Pro
    February 24, 2010
    51
    2
    Home Country
    Denmark Denmark
    HI

    I will try this tomorrow, this is my production server, and my wife uses it.

    When i go to CAM menu in tv server, it also crases, i don't without your (old) patch.

    /Shummi
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,207
    Home Country
    New Zealand New Zealand
    • Thread starter
    • Moderator
    • #14
    When i go to CAM menu in tv server, it also crases, i don't without your (old) patch.
    That is because the crash is in tuner initialisation - the tuner has to be initialised when you try to view the CAM menu.

    I look forward to the test results...
     

    shummi

    Portal Pro
    February 24, 2010
    51
    2
    Home Country
    Denmark Denmark
    Hi

    It seems to work with this Dll.

    I haven't tried DiSeq yet, it require a channel rescan.

    Logs attached

    -------------------------

    I have an other question regarding channel handling

    After a complete scan, channels with different provider but same name, is placed under one channel, but with different tuning details.
    eg. Disney Channel have 5, but I can only receive 2 of them, dosen't that make channel change slower, if so can I avoid this?

    BR Shummi
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,207
    Home Country
    New Zealand New Zealand
    • Thread starter
    • Moderator
    • #16
    Hi shummi

    Thanks for testing. :D

    To be honest I don't understand why this DLL works and the others don't. I have only added some debug. Unfortunately your logs don't show the tuner initialisation which is where the crash was happening. Any chance of restarting TV Server, tuning a few channels, and providing another set of logs?

    I haven't tried DiSeq yet, it require a channel rescan.
    No worries. :)

    I have an other question regarding channel handling

    After a complete scan, channels with different provider but same name, is placed under one channel, but with different tuning details.
    eg. Disney Channel have 5, but I can only receive 2 of them, dosen't that make channel change slower, if so can I avoid this?
    It might make it slower. Could you export your channel list and post it here - I'll check the Disney channel and see why there are 5 tuning details.

    mm
     

    shummi

    Portal Pro
    February 24, 2010
    51
    2
    Home Country
    Denmark Denmark
    hi

    I have tried to recreate the fault, but it only appear randomly with the old patch (EXG), and only if i have activated my Haupauge DVB-t card

    I have attached both logs.

    let me know if I can do more, if I see the fault i will send my complete log.

    ------------------

    Channel list attached, Disney Channel is line 148

    BR Shummi
     

    Attachments

    DJBlu
    Country flag

    Portal Pro
    August 14, 2007
    1,670
    813
    Llanelli
    Home Country
    United Kingdom United Kingdom
    Hi mm1352000

    Here is some new logs.

    This morning, the TV server was crashed, i cleared logs and restarted, this i first log, (with EPG), then i renamed TVGuide.xml, if this was the issue, but i still crashes, this is 2. log (no EPG)

    BR Shummi
    You are still using m*api mate.

    Uninstall it completely and test it again.
     

    mm1352000
    Country flag

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,546
    8,207
    Home Country
    New Zealand New Zealand
    • Thread starter
    • Moderator
    • #20
    Hi folks

    These crashes are strange - they don't seem to be happening where I expected them to be happening and at present I'm not able to reproduce them. It would help from my perspective if you could use the watchdog to collect logs (Log Files - MediaPortal Wiki) - alternatively export the system and application event logs. That way I can see what module is actually crashing.

    mm
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 3)

    Top Bottom