Test mit MP2.1 Final (1 Viewer)

Status
Not open for further replies.

aspik

Development Group
  • Team MediaPortal
  • April 14, 2008
    1,383
    553
    Hab nun die Bereiche Windows-Protokolle (Anwendung, Sicherheit, Installation, System, Weitere Ereignisse) durchforstet. Ist jedoch nichts weiteres mit diesem Zeitstempel vorhanden. Eine SQLite exception ist nicht zu finden. Sorry. Gibt es an anderer Stelle vielleicht noch ein Log?
    Kannst du es zuversichtlich reproduzieren? Stürzt der Server immer beim import von Musik Dateien ab? Ist es vielleicht immer einer bestimmte mp3/flac Datei? Man kann es an dem abgebrochenen Log sehen, in dem angehängtem Log ist es:
    [2017-06-23 00:21:03,464] [379913 ] [78 ] [INFO ] - Media item 95a40d31-79f5-40ea-b64b-7726320f1457 with name Boom boom: 7 - Hittin' The Bottle Again (1007 John Lee Hooker - Hittin' The Bottle Again.mp3) imported (150 ms)

    Könntest du bitte für die zukünftigen Tests das Logging aug DEBUG stellen? Danke :)
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Was nicht geht:
    Überschneidungen werden nicht berücksichtigt, was jedoch bekannt ist und in einem der nächsten Releases gefixt werden soll.
    MP2-607 Add Recording Conflicts Management

    Jedoch hab ich ein großes Problem beim Auffinden meiner Aufnahmen. Diese werden nämlich nicht angezeigt. Zwar sind diese im EPG sichtbar und auch das Aufnahmezeichen erscheint im MP2-Gui. Ebenso unter Schedules in der TV Configuration. Jedoch wird dies nicht automatisch in die Aufnahmen übernommen, weder während noch nach der Aufnahme.
    Das habe ich einmal von jemand anderem gehört, kann es aber nicht nachstellen. Hier funktioniert das alles problemlos.

    Zwar ist die Aufnahme unter dem Standardordner Users\Public\Recorded TV\ zu finden
    Das ist kein Standardordner - vielleicht unter WMC - aber sicher nicht unter MediaPortal, wo die Aufnahmen standardmäßig im Pfad ...\TeamMediaportal\... zu liegen kommen.

    Übrigens sollte in der Setup von MP2 geprüft werden ob der Ordner Recorded TV auch vorhanden ist
    Eigentlich nicht. Der Aufnahmeordner muss in der TV Configuration definiert werden und wird danach automatisch als Share angelegt. Es spielt keine Rolle, ob Recorded TV vorhanden ist oder nicht, denn dieser Ordner muss explizit an-navigiert werden. Gibt es ihn nicht, kann er auch gar nicht erst ausgewählt werden.

    Was teilweise etwas länger gedauert hat, wenn ich Medien aus der Freigabe herausnehme. Dies hat teilweise auch mehrere Stunden gedauert und in seltenen Fällen auch gar nicht funktioniert (also waren noch sichtbar).
    Das ist kein korrektes Verhalten. Wenn ich hier ein paar ts-Files lösche und durch mkv ersetze, ist es eine Sache von Augenblicken, bis die alten weg und die neuen in der Datenbank da sind.

    Gut wäre jedoch, wenn man ein Medienelement mit der Navigation auswählt, dieses kurz prüft, ob dieses noch da ist, falls nicht sollte es ausgegraut oder ausgeblendet werden.
    Ein nicht vorhandene Medienelement verschwindet aus der Datenbank. Getriggert wird das durch Veränderungen der Dateien, die Änderungen werden dann erst nach etwa 5 min eingelesen, damit nicht bei jeder einzelnen Datei sofort ein neuer Reimport anläuft. Wenn es das nicht von alleine tut, kannst du mal probeweise händisch einen Reimport anstoßen.
     

    heiserfeger77

    Portal Pro
    November 10, 2009
    275
    63
    Germany Germany
    Country flag
    Das ist kein Standardordner - vielleicht unter WMC - aber sicher nicht unter MediaPortal, wo die Aufnahmen standardmäßig im Pfad ...\TeamMediaportal\... zu liegen kommen.
    Eigentlich nicht. Der Aufnahmeordner muss in der TV Configuration definiert werden und wird danach automatisch als Share angelegt. Es spielt keine Rolle, ob Recorded TV vorhanden ist oder nicht, denn dieser Ordner muss explizit an-navigiert werden. Gibt es ihn nicht, kann er auch gar nicht erst ausgewählt werden.
    Falsch. Hab es gerade nochmals mit einer frischen Installation (Also neues Windows vom Media Creation-Stick) installiert. Hier gibt es den Recorded TV-Ordner nicht. Ruft man erstmalig die TV-Configuration auf, wird als hinterlegter Ordner C:\Users\Public\Recorded TV\ angegeben, auch wenn dieser nicht vorhanden ist. Erst wenn man den Ordner-Öffnen Dialog auswählt, kann man natürlich den nicht vorhandenen Ordner nicht auswählen, sondern nur einen anderen.

    Hab mittlerweile rausgefunden, dass die alte Installation wohl ausversehen auf Öffentliches Netzwerk gelaufen ist, was ich zwar geändert habe, aber die Probleme dadurch nicht gelöst wurden. Habe also sicherheitshalber nochmals ne Neuinstallation gemacht. Test dauert nun wieder ein bißchen, aber ich werde weiterberichten.

    Vielleicht liegen die anderen Probleme auch an dieser Tatsache, da hier die Firewall dazwischen gefunkt hat. Ich berichte sobald ich wieder etwas mehr weis.
     

    heiserfeger77

    Portal Pro
    November 10, 2009
    275
    63
    Germany Germany
    Country flag
    Kannst du es zuversichtlich reproduzieren? Stürzt der Server immer beim import von Musik Dateien ab? Ist es vielleicht immer einer bestimmte mp3/flac Datei? Man kann es an dem abgebrochenen Log sehen, in dem angehängtem Log ist es:
    [2017-06-23 00:21:03,464] [379913 ] [78 ] [INFO ] - Media item 95a40d31-79f5-40ea-b64b-7726320f1457 with name Boom boom: 7 - Hittin' The Bottle Again (1007 John Lee Hooker - Hittin' The Bottle Again.mp3) imported (150 ms)

    Könntest du bitte für die zukünftigen Tests das Logging aug DEBUG stellen? Danke :)
    Ich kann dir zum überprüfen alles zur Verfügung stellen. Ob es immer bei der gleichen Datei passiert, kann ich nicht mehr nachvollziehen, da ich zwecks kleiner aber kompletter Logs immer die kompletten Logs vor einer neuen Aktion lösche. Ich werde nun nochmals zwei komplett neue Serverinstallation hochziehen (Virtuelle Maschinen) und werde dort den Import ausschließlich auf den Musikteil beziehen um dieses Problem mal etwas genauer zu untersuchen.

    Wie stelle ich dir das Logging aus Debug bereit?
    PS: Kannst du mir den neuen Logging Collector schon bereitstellen, der auch die Ereignisanzeige von Windows mit sammelt, vielleicht hilft dir das besser das Problem einzugrenzen?
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,622
    2,387
    Stuttgart
    Germany Germany
    Country flag
    PS: Kannst du mir den neuen Logging Collector schon bereitstellen, der auch die Ereignisanzeige von Windows mit sammelt, vielleicht hilft dir das besser das Problem einzugrenzen?
    Schau mal im Wiki, ist dort beschrieben wie man Debug Logs erstellt.
     

    heiserfeger77

    Portal Pro
    November 10, 2009
    275
    63
    Germany Germany
    Country flag
    Schau mal im Wiki, ist dort beschrieben wie man Debug Logs erstellt.
    Ok habs gefunden. Werde dies für diese beiden Testmaschinen mal vorerst eingeschaltet lassen. Mehr von mir, wenn ich die Maschinen oben habe und den ersten Scan meiner Musik hinter mir habe.
     

    heiserfeger77

    Portal Pro
    November 10, 2009
    275
    63
    Germany Germany
    Country flag
    Ok. ich hab nun die beiden Maschinen hochgezogen mit einem Standard Media-Creation-Image von Windows 10 Pro 64Bit. Ansonsten wurde nichts installiert. Die Maschinen haben beide 4GB Arbeitsspeicher und sind gleichzeitig auf einem i7-3820 gelaufen. Die beiden VM haben über eine Netzwerkbrücke Zugriff auf den Server, wo die Shares liegen. Die TV-Configuration wurde nicht gestartet, auch die sonstige Konfiguration (Skins, Einstellungen) wurde nicht angerührt.

    Einzige vorgenommenen Einstellungen ist die Einstellungen für das Debug-Logging und das hinzufügen des Musik-Shares, welcher über Netzwerkfreigabe auf dem Realserver liegt.

    Danach wurde die Oberfläche auf Medienübersicht gestellt, um zu sehen, ob sich dort noch etwas tut, oder der Scan abgebrochen oder fertig sein soll.

    Nun beide Server haben heute Nachmittag wieder den Dienst beendet und der Scan war noch nicht abgeschlossen. Aus den Logs habe ich nichts besonderes herauslesen. Auch sind beide bei unterschiedlichen Dateien abgeschmiert. Die Logs habe ich mal angehängt von beiden Maschinen.

    Falls noch weitere Infos benötigt werden, dann mir Bescheid geben. Kann bei Benötigung auch einen weiteren Server bereitstellen oder diese beiden weiter mit Infos füttern.

    Die Ereignisanzeigen von beiden VM sehen ähnlich aus. Unter System und Anwendung ist an den entsprechenden Zeitstempeln 15:27 und 15:29 die MP2-Server abgestürzt. Falls gewünscht, kann ich die Logs auch noch mit anhängen. Ein Verweis auf SQL ist nirgens vorhanden.

    Scheint also ein Problem sein, dass sich bei mir beliebig reproduzieren lässt.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Hast du die Möglichkeit, das Ganze auch in einer echten physischen Maschine zu machen?

    Ein Absturz von Windows-Diensten ohne Spuren in der Ereignisanzeige ist streng genommen gar nicht möglich. Durch einen Test in einer echten Umgebung könnte so die VM als potentielle Ursache ausgeschlossen werden. Ich kann dir für das weitere testen auch einen nueren Build zur Verfügung stellen, der für die Logs zusätzlich noch die Ereignisportokolle einsammelt.
     

    heiserfeger77

    Portal Pro
    November 10, 2009
    275
    63
    Germany Germany
    Country flag
    Ja. Ich kann dies auch auf einer realen Maschine testen. Dann einfach her mit dem neueren Build. Der Absturz wurde nachtürlich in der Ereignisanzeige gezeigt, nur hatte aspik einen gewissen Fehler dort vermisst. Ich kann dies auf bis zu 3 realen Maschinen durchführen.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Es wurden nur die Netzwerkangaben für den Share hinterlegt und der Zugriff auf das Musikverzeichnis.
    Leider alles in INFO, wobei man in DEBUG vermutlich auch nicht wesentluich mehr sehen wird. Außer einer einzigen Meldung im Event-Log geben die Logs deshalb nichts her:

    06/29/2017 21:07:41 Service Control Manager Dienst MediaPortal 2 Server Service" wurde unerwartet beendet. Dies ist bereits 1 Mal passiert."
     
    Last edited:
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    high attachment test Testforum 0
    azzuro [News] MediaPortal 1.24 Pre-Release ready for testing! News and Announcements 0
    HTPCSourcer [Finished] Nereus: Test results #1 MediaPortal 2 196
    ajs [solved] MP1.23 Temporary Bugfixes - Test General Support 8
    morpheus_xx Test builds of MP2.3 WiP, x64, Nereus and more... MediaPortal 2 44
    ajs [News] MediaPortal 1.23 Pre-Release ready for testing! News and Announcements 6
    O [News] MediaPortal 1.22 Pre-Release ready for testing! News and Announcements 2
    E [solved] No Live TV in MP2.2 Client - Can TEST Successfully in "MediaPortal 2 TV Configuration" utility General 8
    morpheus_xx General Testing TVE 3.5 Sat>IP support (MP2 only) TV Engine 47
    O [News] MediaPortal 1.21 Pre-Release ready for testing! News and Announcements 6
    D [solved] Initital testing with second client - cannot play recorded TV General 33
    O Core Testing of the new TsWriter.ax TV Engine 77
    ge2301 MP 2.2 Release - Testing Archive 86
    high [News] MediaPortal 1.20 Pre-Release ready for testing! News and Announcements 10
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 11
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    k12158 [solved] Keine Zugriff auf NAS Ordner mit Recordings und TimeShift Allgemeines Support- und Diskussionsforum 6
    mrbonsen neuer versuch mit MP2 Allgemeines Support- und Diskussionsforum 18
    M.Hulot Probleme mit den Filtern Allgemeines Supportforum 3
    Wondermusic [Verkauf] Thermaltake DH102 mit Touchscreen und Hardware Marktplatz 1
    K Wie funktioniert PiP mit der Fernbedienung? Allgemeines Support- und Diskussionsforum 3
    H TV-Darstellungsfehler mit nvidia 1050TI TV / Streaming 0
    F [solved] Mediaportal (1 oder 2) Installation mit Fehler bei DirectX9.0 unter Windows 10 Allgemeines Support- und Diskussionsforum 10
    Similar threads

























    Top Bottom