themoviedb.org - Covers downloaded in the wrong language (1 Viewer)

vuego

Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,597
    746
    Göteborg
    Home Country
    Sweden Sweden
    Country flag
    Lately, I've not been getting the English cover as number one but instead other languages. Sometimes I can manually toggle the next one or two covers to find the English cover however sometimes I need to manually download six or even nine covers to find the English one and in some cases there's no English cover at all.

    My data sources are set up as Manually retrieve covers and I've got only themoviedb.org enabled for cover sources.

    Example
    When opening the web page I see the first six covers, all in English however Moving Pictures downloads the German, Spanish and French posters.

    Is there anything I can do to configure Moving Pictures to prefer English covers or is an update to the scraper script necessary?

    Thanks!
     

    Attachments

    • movingpictures-themoviedb.log
      5.6 KB · Views: 0

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,402
    1,877
    Country flag
    There isn't much scraper-script debugging on the internal scripts such as TMDb, especially when it comes to the cover node.

    Feel free to look at the C# code to see the workflow, and verify that TMDb entries contain the fanart you would want. Otherwise activate alternative sources, such as Fanart.tv one, or IMDb+, etc. which you would only activate for the cover node.
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,597
    746
    Göteborg
    Home Country
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #4
    That's strange. It doesn't seem to work that way for me. I changed to English in the Data Sources tab in Moving Pictures even though I'm not sure if it's used since it's gray when selecting Manually manage movie data sources.

    Importer Settings.PNG


    MediaPortal is usually set to Swedish however for troubleshooting I changed it to English and re-sent the movie to importer to let Moving Pictures import it again but I still get the German cover first.

    Movie Manager.PNG


    I've tried enabling only fanart.tv instead but I'm not sure I like it since the first cover often is an image only without the movie name.
    Preferably I'd like to use MediaPortal in Swedish and Moving Pictures to download the Swedish cover if available or else the English version :) I'm pretty sure this is the way I had it setup for a long time so I wonder what did happen.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,402
    1,877
    Country flag
    @vuego well way back IMDb+ had Swedish support, and would force English covers, which TMDb would then supplement as needed. Sucks that "nyheter24.se" stopped working as an IMDb tt-ID proxy.
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,597
    746
    Göteborg
    Home Country
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #6
    If your language is set to English then it will prefer English covers first.
    I see. I've made a couple of more tests and I guess what I'm missing is the possibility to get the movie details in Swedish but the cover in English (or Swedish if available).

    I've tried Automatic English and that works as expected - both movie details and cover is downloaded in English.
    Next I tried Automatic Swedish and Manual filmtipset.se for movie details and themoviedb for covers - movie details is in Swedish but the cover in my test case was Portuguese, Russian and English. The same result for both automatic and manual.

    Do you know how the language is determined when using Manually manage movie details? I would expect that automatic English and manual themoviedb only (all others disabled) would have the same result however it seems that using themoviedb manually equals automatic Swedish for me.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,402
    1,877
    Country flag
    If you set language to English, but force filmtipset.se for movies, wouldn't the movies be in Swedish, but covers in English?
     

    vuego

    Documentation Group
  • Team MediaPortal
  • August 5, 2006
    1,597
    746
    Göteborg
    Home Country
    Sweden Sweden
    Country flag
    • Thread starter
    • Moderator
    • #8
    It isn't possible to set a language when manually managing the data sources. The language selection gets grayed out. This option seems to only apply to automatic scraping. However I tried it anyway but the result is German cover first.

    Automatic English Manual filmtipset themoviedb.png


    Even selecting themoviedb for movie details and covers I get the German cover for some reason.

    Automatic English Manual themoviedb themoviedb.png

    If I could force themoviedb cover scraper to use English first (and maybe Swedish second) even when using Manually manage movie data sources I think it would work.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,402
    1,877
    Country flag
    Well one dirty trick is to adjust the filmtipset XML scraper-script to list itself as an English one, and then just disable all the other movie-detail source ones (or adjust order). Then you can keep things set to automatic with language selection. The TMDB scraper is internal and C# based, so will be a much longer delay waiting for that one to get fixed.

    This way you can fix it in a few seconds for the time being, and you'll be good to go.
     

    Users who are viewing this thread

    Similar threads

    It is possible IMDb+ did not update as sometimes Moving-Pictures goes crazy on the script-table. In those rare cases when you have issues, first check the IMDb+ plugin, and look at the info page to see what current version of the IMDb+ Scraper-Script is installed, and make sure it lines up to the current published version at GitHub...
    It is possible IMDb+ did not update as sometimes Moving-Pictures goes crazy on the script-table. In those rare cases when you have...
    I've recently tried the upgrade of Mediaportal to 1.25 and come across a strange occurance. All my movie DVD covers and backdrops...
    Replies
    9
    Views
    1K
    We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common user requirements out of the box. Aside from its support for Live TV and Radio, it offers a complete media server for music, movies, and TV shows. Info is automatically downloaded from various sources to...
    We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common...
    We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common...
    Replies
    0
    Views
    766
    Thanks for this new release of MP. The link on the presentation page of the new version is incorrect. It goes on the MP 1.24 thread.
    Thanks for this new release of MP. The link on the presentation page of the new version is incorrect. It goes on the MP 1.24 thread.
    We have just released MediaPortal 1.25 Final - Summer 2020 Edition Highlights of this release Bugfixes: [MP1-4966] - Update...
    Replies
    1
    Views
    2K
    If you do have all pictures in MP1 there is a simple process of creating nfo files. See the 2.2.1 release news that references a tool for this purpose. This way you can within minutes use all your fanart and make it available in MP2.
    If you do have all pictures in MP1 there is a simple process of creating nfo files. See the 2.2.1 release news that references a...
    Have just installed 2.2.1 on a test machine to see if the problem I reported with 2.2 where foreign TV series displayed...
    Replies
    6
    Views
    622
    Sad to see you replied so late, I've long since moved from 32bit to 64bit, so you've gone through all that trouble to help me for nothing. Thanks anyway. Emph
    Sad to see you replied so late, I've long since moved from 32bit to 64bit, so you've gone through all that trouble to help me for...
    ************************************************* EDIT 2019-04-29: New version, see Gitlad for change log. Thank you SINCowboy So...
    Replies
    25
    Views
    8K
    Top Bottom