Trailers Plugin v1.3.0 (Play/Stream/DL for MovingPictures, My Films, My Videos..) [2020-02-23] (2 Viewers)

catavolt

Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    14,324
    10,375
    Königstein (Taunus)
    Home Country
    Germany Germany
    @ltfearme Hi Damien,
    since some time the trailers plugin don´t work correct anymore: Looking up any movie/episode the trailers marked "Online" in the respective dialog won´t play, but still possible watching in Youtube ;)
    Also trying to configure in MP Config gives me an error that a value must not be "0" but between "Minimum" and Maximum".
    Any idea?
     
    Last edited:

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    Also trying to configure in MP Config gives me an error that a value must not be "0" but between "Minimum" and Maximum".
    Sounds like a setting might be corrupted or invalid in MediaPortal.xml...could maybe start by looking at the Trailer settings and see what is 0 or delete the whole section and re-configure the plugin. If you can attach your mediaportal.xml, I will look when I get the chance to see if I can fix issue (and prevent from occurring).
     

    catavolt

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    14,324
    10,375
    Königstein (Taunus)
    Home Country
    Germany Germany
    @ltfearme
    Damien, could not find any clue in MediaPortal.xml.
    So I deleted Trailers plugin and tried to re-install.
    During installation process, installer tried to download something but stops with 404 error file could not be found on remote server:

    Screenshot 2020-11-15 121155.jpg

    Any idea?
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    Oh dear! That might be some other plugin I have packaged in there such as the Extensions plugin. I will take a look and re-package if needed without said dependency.

    Please try re-installing but unselect the other plugins as part of the install.

    At a bare minimum you only need the Trailers.dll so you can extract that out of the package using winzip or similar too.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    Don´t even get options shown to select/unselect ;)
    That's odd, it must think you are doing an upgrade vs a new install - I think the extensions installer remembers previous options on upgrade.

    1605566433179.png


    From the above, the issue is most likely due to extensions or onlinevideos failing to install (my guess is extensions).

    If you go to C:\ProgramData\Team MediaPortal\MediaPortal\Installer\V2\ you can probably try cleanup what the MPEI thinks is already installed by editing InstalledExtensions.xml e.g. remove reference to MyTrailers from there (search for b4293f64-9e83-4f1f-b2e3-8bdea2a37425, and remove the whole PackageClass element that it exists in)

    Let me know if you then can re-install and de-select the extensions plugin.
     

    catavolt

    Design Group Manager
  • Team MediaPortal
  • August 13, 2007
    14,324
    10,375
    Königstein (Taunus)
    Home Country
    Germany Germany
    Well, and now the great "surprise":
    Trying to configure from Extension plugin (or from MP Config) shows the error of value must not be 0 but between Minimum and Maximum:

    13-13-05.jpg 13-13-07.jpg

    Opening MP, and going to Extensions - Trailers let me configure the plugin without problems :confused::oops:

    13-13-10.jpg 13-13-24.jpg

    ;)
     

    Users who are viewing this thread

    Top Bottom