Trakt not working with latest 4TR stable release (only beta) (1 Viewer)

struggles

Portal Member
May 12, 2009
5
1
Garland, TX
United States of America United States of America
Trakt is fantastic! I think I have everything working except for 4TR (For The Record).

I am using 4TR version 1.6.0.2 (the latest available non-beta version) with MediaPortal 1.2.2

I checked the Trakt log and it appears that the plugin is looking for a later version of 4TR. Is the beta version of 4TR required?

Code:
...

2/8/2012 3:47:42 PM[Library Sync][21][Info] Library Sync Complete for all enabled plugins.
2/8/2012 3:48:59 PM[Scrobble][9][Error] Error getting scrobble state from '4TR TV Recordings'
2/8/2012 3:48:59 PM[Scrobble][9][Error] Could not load file or assembly 'ForTheRecord.Entities, Version=1.6.1.0, Culture=neutral, PublicKeyToken=a9a5dfc20b8d6175' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
2/8/2012 3:48:59 PM[Scrobble][9][Info] File was not recognised in your enabled plugin libraries
2/8/2012 3:50:24 PM[MPMain][1][Info] Saving Settings
2/8/2012 3:50:24 PM[MPMain][1][Info] Goodbye
Thanks for the Trakt plugin and website.
 

ltfearme

Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,700
    7,084
    Sydney
    Australia Australia
    Country flag
    Re: 4TR is not working

    Yes struggles, sorry I should of been more clear in release notes that we need v1.6.1+ and not v1.6+.

    I tried to get both working together (which was hard given I couldn't test both at the same time) but thought the beta should be released publicly soon I imagine and wasn't worth the effort.

    If you really want a dll that is compatible I can compile you one, all you need to give me is a zip file with the following dlls:
    Code:
    ForTheRecord.Entities.dll
    ForTheRecord.ServiceAgents.dll
    ForTheRecord.ServiceContracts.dll
    ForTheRecord.UI.MediaPortal.dll
    Im not sure why ForTheRecord.Entities is having compatibility issues as it seems backwards compatible. I suspect when yet another beta or official release of 4TR is announced I will need to release again.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,700
    7,084
    Sydney
    Australia Australia
    Country flag
    Post updated with latest version, I have been meaning to ask FTR developers about compatibility issues.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Lichloathe Trakt for MP2 question General 7
    ajs Trakt error when start with MP crash Trakt 1
    thepahakurki Trakt error: Invalid or missing file Trakt 8
    ajs Trakt crashed Mediaportal if no Internet in home lan Trakt 2
    fischy667 wrong/no sync with trakt on some series Trakt 2
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    M.Hulot After Update 1.25 internal blu-ray-player doesn't work General Support 8
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 1
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    V Do you have to have a smart tv for it to work? Newcomers Forum 4
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    D Does Schedules Direct work with mp 1.24? General Support 3
    J [solved] Blu-ray disc playback does not work. Bugreports 15
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    ratata [solved] Can't get two virtual IPTV cards to work side by side... General Support 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    mickb [solved] Mediaportal Stops working General Support 5
    C Importer works super slow My TVSeries 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    A 1.24.0 CD art grabber not working in Shares view 1.24-1.26 Pre Release 17
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    Similar threads

























    Top Bottom