TsReader - TV black screen and RTSP 'infinite loop' fixes (1 Viewer)

Status
Not open for further replies.

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    • Thread starter
    • Moderator
    • #11

    glenn 1990

    Portal Pro
    July 1, 2010
    247
    36
    Belgium Belgium
    As requested, supplied both unc and rtsp for comparison + FTR logs, would say there is a good 2 second difference, and I am using the loopback adapter with fixed ip.

    View attachment 98812

    View attachment 98813

    View attachment 98814

    :D
    New version 0_4_17a added - can you try this with 4TR + RTSP please ?

    Thanks,

    Tony
    What's the problem with 4TR, slow zapping??

    The 1.6.0.x release restarts the player on channel change to avoid the RTSP issues, so this will stay slow with every tsreader.
    But this hack is removed in the 1.6.1 beta releases, because there is some progress in fixing the issue.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    • Thread starter
    • Moderator
    • #13
    The extra delay that Ray was getting was due to the TsReader mod - I could see that from the log. The 4TR client/server behaves differently to MP client/server.

    Tony
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    • Thread starter
    • Moderator
    • #15
    Hi Ray,

    It looks like the latest version is working how it should :)

    The zapping delay is a mixture of how 4TR is handling the zapping (as glenn1990 points out, it's completely rebuilding the graph on a channel change when using RTSP - which is the most reliable but slowest thing to do), and how long it takes TsReader.ax to find the first GOP boundary after the stream data start to arrive - which depends on how the stream is encoded and where it 'jumps in' relative to the GOP structure, amongst other things.

    Thanks for the testing.

    Tony
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    I have tested the 0.4.7.1a binary, and it is working fine with 1.2.2 + some other fixes. I didn't do any comparisons, but all seems fine so far.

    Mark
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    These fixes are now approved and merged to the Release_1.2.X and master GIT branches. They will be in the next release (1.2.3).

    Should we now close this thread?

    Mark
     

    esas

    Portal Pro
    November 14, 2006
    160
    27
    Norway Norway
    Just wanted to say that I've been testing 0.4.7.1a for a while, and it doesn't seem to break anything. Hoping that future updates will include work from your noStopMod-thread..
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    H random black screen live tv and videos (amended) General Support 0
    G Occasional Black screen on Live TV and Recorded TV Watch / Listen Media 5
    Terra some H265 videos stay black, audio is playing General Support 4
    doskabouter Black screen while watching some iptv streams General Support 2
    T frequent black screen no audio on playback NOT from beginning Watch / Listen Media 0
    G MadVR, black TV Picture 1.20 Pre Release 1
    C video wont open, screen goes black and reverts to video menu General Support 3
    J Blue Screen Error Submit: Bug Reports 0
    azzuro [fixed] 5011: Version label in Splash screen - pos, size from skin MediaPortal 1 61
    F After resume, TV Server connection screen is shown General Support 4
    M [Duplicate] Always enter full screen when entering TV from main Menu Feature Requests 1
    M Change size of the splash screen Skins and Plugins Installer (MPEI) 2
    T Animated circular icon persists in centre of screen. General 10
    P MP2 Client Screen Flickering on Resume General 2
    Rob Hexenmeister Work arounds for an alternative home screen General Support 3
    lisag Can I get MP1 to open in the Recorded TV screen? MediaPortal 1 Talk 2
    R Media portal resumes with wrong screen resolution General Support 3
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    N [Finished] MP2-803 - Delete full series doesn't work when viewing a program in the extended schedule screen MediaPortal 2 12
    morpheus_xx [Finished] [MP2-802] TV-Settings availability in all TV screens MediaPortal 2 12
    G How to access Scheduled Recordings without going through TV Home screen General Support 3
    Rob Hexenmeister Radio Guide descriptions in myradio.xml (screen 30) MediaPortal 1 Skins 3
    L MP Playback Freezes When Unpausing from Minimized Screen General Support 6
    ge2301 [Finished] [MP2-776] Improve busy screen appearance MediaPortal 2 14
    Similar threads

























    Top Bottom