TV playback intermittently stops on clients (1 Viewer)

Antony N (NZ)

New Member
September 10, 2018
2
0
40
New Zealand New Zealand
Hi guys

for some reason i have been having a problem with tv playback. other playback of files works fine so still able to watch movies etc but when playing back TV, it intermittently stalls then stops.

i have checked the obvious like networking and disabling the standard AV in windows 10 but this does not seem to solve the issue at all. I have even tried to roll back to older drivers for video on the client but still the same problem.

my client machines are NUCs running windows 10, connected via GB ethernet to cisco switches. my server machine is running windows 10 as well with a decent proc and memory etc. This has setup has been running with no real issues at all for the past few years and has developed this annoying issue.. and of course I am pulling my hair oput as it seems like something so simple.

Any help would be appreciated.

thanks Ant
 

Attachments

Jasmeet_181

Portal Pro
September 5, 2007
399
324
United Kingdom United Kingdom
Country flag
Hello Antony, the TSWriter log shows a number of continuity errors:
[2018-09-10 05:58:47,655] [54a8648] [1260] - Recorder:pid 1c2 Continuity error... a ( prev c ) - bad signal?
[2018-09-10 05:58:47,655] [54a8648] [1260] - Recorder:pid 19a Continuity error... b ( prev d ) - bad signal?
[2018-09-10 05:58:47,655] [54a8648] [1260] - Recorder:pid 190 Continuity error... d ( prev 1 ) - bad signal?
[2018-09-10 05:58:47,733] [54a8648] [1260] - Recorder: RECORD Info : Program clock reference forward jump ( 294696 ).
[2018-09-10 06:09:13,485] [54a8648] [1260] - Recorder:pid 1c2 Continuity error... 7 ( prev 8 ) - bad signal?
[2018-09-10 06:09:13,485] [54a8648] [1260] - Recorder:pid 19a Continuity error... a ( prev 7 ) - bad signal?
[2018-09-10 06:09:13,485] [54a8648] [1260] - Recorder:pid 190 Continuity error... e ( prev 4 ) - bad signal?
[2018-09-10 06:09:13,563] [54a8648] [1260] - Recorder: RECORD Info : Program clock reference forward jump ( 41178 ).
[2018-09-10 06:19:03,957] [54a8648] [1260] - Recorder:pid 1c2 Continuity error... 3 ( prev 1 ) - bad signal?
[2018-09-10 06:19:03,957] [54a8648] [1260] - Recorder:pid 19a Continuity error... a ( prev e ) - bad signal?
[2018-09-10 06:19:03,957] [54a8648] [1260] - Recorder:pid 190 Continuity error... 1 ( prev 3 ) - bad signal?
[2018-09-10 06:19:04,020] [54a8648] [1260] - Recorder: RECORD Info : Program clock reference forward jump ( 64000 ).
[2018-09-10 06:19:13,432] [54a8648] [1260] - Recorder:pid 1c2 Continuity error... f ( prev b ) - bad signal?
[2018-09-10 06:19:13,432] [54a8648] [1260] - Recorder:pid 19a Continuity error... 1 ( prev d ) - bad signal?
[2018-09-10 06:19:13,432] [54a8648] [1260] - Recorder:pid 190 Continuity error... 4 ( prev 7 ) - bad signal?
[2018-09-10 06:19:13,510] [54a8648] [1260] - Recorder: RECORD Info : Program clock reference forward jump ( 214534 ).
[2018-09-10 06:19:34,007] [54a8648] [1260] - Recorder:pid 1c2 Continuity error... 2 ( prev f ) - bad signal?
[2018-09-10 06:19:34,007] [54a8648] [1260] - Recorder:pid 19a Continuity error... 7 ( prev a ) - bad signal?
[2018-09-10 06:19:34,007] [54a8648] [1260] - Recorder:pid 190 Continuity error... 5 ( prev 1 ) - bad signal?
[2018-09-10 06:19:34,035] [54a8648] [1260] - Recorder: RECORD Info : Program clock reference forward jump ( 131771 ).
[2018-09-10 06:39:43,042] [54a8648] [1260] - Recorder:pid 1c2 Continuity error... c ( prev 9 ) - bad signal?
[2018-09-10 06:39:43,042] [54a8648] [1260] - Recorder:pid 19a Continuity error... 2 ( prev 2 ) - bad signal?
[2018-09-10 06:39:43,042] [54a8648] [1260] - Recorder:pid 190 Continuity error... d ( prev b ) - bad signal?
The TV Server developer has previously posted this advice:
The most common causes of continuity errors are:
  1. Signal strength and/or quality issues.
  2. HDD load, often caused by security software scanning TV Server's install, timeshift, recording, and/or settings directories.
How do you diagnose and resolve the problem?

In short, first thing I would do is check for patterns.
Does the problem only occur with:
  • certain tuners
  • certain channels
    • encrypted channels
    • HD channels
    • channels broadcast from a certain transmitter
  • when timeshifting
  • when recording
Usually if you can find the pattern you'll be able to isolate the cause.
 

Antony N (NZ)

New Member
September 10, 2018
2
0
40
New Zealand New Zealand
ok i will have a look at IO on the server, but off the same set of drives I can stream mkv files no issue.

this issue is only with playback as recording is fine. It seems like it skips a bit and stutters then locks and drops. some times it is fine with no issue at all.

i just want to say there are no other issues with playback of other media just when streaming tv and only tv.

this issue also has only appeared in the last few months, this same server and client combo has been fine for the last 4.5 years.

thanks
 

Jasmeet_181

Portal Pro
September 5, 2007
399
324
United Kingdom United Kingdom
Country flag
Looking at your tvserver_TVService logs, your signal quality varies and is often quite low (20 or 25 out of 100). The signal level is always 0 so the driver probably isn't reporting it, which isn't a problem in itself.
[2018-09-08 17:50:14,143] [Log ] [scheduler thread] [INFO ] - Scheduler: Time to record Three 5:50 p.m.-7:00 p.m. Newshub Live At 6pm
[2018-09-08 17:50:14,143] [Log ] [scheduler thread] [INFO ] - Controller: find free card for channel Three
[2018-09-08 17:50:14,143] [Log ] [scheduler thread] [INFO ] - Controller: find card for channel Three
[2018-09-08 17:50:14,143] [Log ] [scheduler thread] [INFO ] - Controller: got 1 tuning details for Three
[2018-09-08 17:50:14,143] [Log ] [scheduler thread] [INFO ] - Controller: channel #1 DVBT:tv:Mediaworks Three Freq:562000 ONID:8746 TSID:29 SID:1300 PMT:0x12C FTA:True LCN:3 BandWidth:8
...
[2018-09-08 17:50:15,315] [Log ] [scheduler thread] [DEBUG] - card: Tuner locked: True
[2018-09-08 17:50:15,315] [Log ] [scheduler thread] [INFO ] - **************************************************
[2018-09-08 17:50:15,315] [Log ] [scheduler thread] [INFO ] - ***** SIGNAL LEVEL: 0, SIGNAL QUALITY: 25 *****
[2018-09-08 17:50:15,315] [Log ] [scheduler thread] [INFO ] - **************************************************
[2018-09-09 17:50:00,154] [Log ] [scheduler thread] [INFO ] - Scheduler: Time to record Three 5:50 p.m.-7:00 p.m. Newshub Live At 6pm
[2018-09-09 17:50:00,154] [Log ] [scheduler thread] [INFO ] - Controller: find free card for channel Three
[2018-09-09 17:50:00,154] [Log ] [scheduler thread] [INFO ] - Controller: find card for channel Three
[2018-09-09 17:50:00,154] [Log ] [scheduler thread] [INFO ] - Controller: got 1 tuning details for Three
[2018-09-09 17:50:00,154] [Log ] [scheduler thread] [INFO ] - Controller: channel #1 DVBT:tv:Mediaworks Three Freq:562000 ONID:8746 TSID:29 SID:1300 PMT:0x12C FTA:True LCN:3 BandWidth:8
...
[2018-09-09 17:50:01,310] [Log ] [scheduler thread] [DEBUG] - card: Tuner locked: True
[2018-09-09 17:50:01,310] [Log ] [scheduler thread] [INFO ] - **************************************************
[2018-09-09 17:50:01,310] [Log ] [scheduler thread] [INFO ] - ***** SIGNAL LEVEL: 0, SIGNAL QUALITY: 20 *****
[2018-09-09 17:50:01,310] [Log ] [scheduler thread] [INFO ] - **************************************************
 

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,539
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    If you play one of the 'problem' recordings *locally* on the server, does it play OK?

    If you play a 'problem' recording remotely several times, does it stop/stutter in the same places?

    Those tests should tell you if it's the actual recording file that is corrupted, or if it's a remote playback problem. Let us know the results and we'll try to give further advice.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    K Flickering live TV playback Newcomers Forum 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    doskabouter [Help Me!] Playback of iTunes Movie Trailers Developer Discussions 0
    I Video Playback Stuttering General Support 45
    horned_reaper [solved] Music playback hangs General Support 58
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    A 1.24.0 1.24 Kills 3D MVC playback on MadVr 1.24 Pre Release 66
    Z [solved] DVD playback is super glitchy General 2
    A Working server, no video playback on client General 5
    L MP Playback Freezes When Unpausing from Minimized Screen General Support 6
    Cowboy Playback Problem with CTD or sometimes BSOD watch/edit Videos 0
    Glith Sound stops working after first playback 1.21 88
    G Mediaportal2 supported formats General 1
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    joecrow Refresh rate not returned to default after 3D playback 1.21 Pre Release 0
    bta489 [solved] Stuttering playback of edited recordings watch/edit Videos 2
    T frequent black screen no audio on playback NOT from beginning Watch / Listen Media 0
    M Music playback stops after certain files 1.19 0
    J Bluray playback: How to revert back to Select Play Mode after stopping playback? Watch / Listen Media 2
    joecrow BD Playback with External Player (Unnecessary Menu) 1.19 5
    osre Audio issues with MKV Playback in MP2.1.3 General 5
    joecrow MP 1.19 BD Playback with External Player (Unnecessary Menu) General Support 0
    R How to launch Stereoscopic Player for 3D MKV OffTopic 4
    toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
    Similar threads

























    Top Bottom