TV Recordings folder coming up empty (1 Viewer)

onetoomany

Portal Pro
July 5, 2005
122
2
UK
I've upgraded my tv server to 1.3.0 and one of my clients (plus DJBlu's Sky EPG plugin patch). The 1.3.0 was a clean install on both the client and server.

On the 1.2.3 client, no problems - lots of recordings visible and playable.
On the 1.3.0 client, the "My Recordings" screen comes up empty. There is an error in the log file:
Code:
2013-04-06 23:10:48.309490 [ERROR][MPMain(1)]: TvRecorded: Error fetching recordings from database The number of returned rows 0 did not match the expected count of 1.
I can watch live TV, and schedule new recordings though.

I've completely uninstalled the client and reinstalled, but I get the same issue.

I've attached the tv client and server log files.

Richard.
 

Attachments

kiwijunglist
Country flag

Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    Home Country
    New Zealand New Zealand
    Haven't looked at your logs, but this may work.

    Stop tvservice (Windows key -> type services.msc -> press enter)

    Backup and then delete your tvrecordings database file
    (I'm guessing it should be .db3 extension and located under start->team mp->mp->user files, on your server pc)

    Open tvserver config

    Import your tv recordings directory
    http://wiki.team-mediaportal.com/1_...guration/TV-Server_Configuration/07_Recording
     
    Last edited:

    Edalex
    Country flag

    Community Plugin Dev
  • Premium Supporter
  • January 3, 2008
    2,909
    1,217
    Saratov
    Home Country
    Russian Federation Russian Federation
    Backup and then delete your tvrecordings database file
    (I'm guessing it should be .db3 extension and located under start->team mp->mp->user files, on your server pc)
    Nope it is a table in TvServer MySQL/MSSQL db
     

    kiwijunglist
    Country flag

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    Home Country
    New Zealand New Zealand
    Error Message When running TV Setup - "Failed to Create Database"

    If when doing a re-installation of MSSQL or TV server you receive the error "Failed to Create Database", it may be because the MSSQL database files were not deleted from the hard drive. To resolve this issue please follow the steps below :
    1. Ensure the TVLIBRARY database is deleted in the SQL management GUI
    2. Browse to C:\program files\microsoft SQL Server\MSSQL.1\MSSQL\DATA\ and ensure there are fo files that start with TvLibrary. If so, either rename or delete these files.
    3. Now you should be able to run TVSetup.exe and it should create the new database.
    http://wiki.team-mediaportal.com/1_...ng_TV_Setup_-_.22Failed_to_Create_Database.22

    I'm guessing exsiting tv recordings database is corrupt.
     
    Last edited:

    onetoomany

    Portal Pro
    July 5, 2005
    122
    2
    UK
    I'll try dropping the database and deleting db backup files on the server and see what happens...
     

    onetoomany

    Portal Pro
    July 5, 2005
    122
    2
    UK
    Its been a week since I've had a chance to watch tv and try this.

    I dropped the database on the server, and allowed the config program to recreate it. The issue still remains.
    I have installed the 1.3.0 client software onto a second (clean) client, and the recordings folder is still empty - this suggests that it is a server problem not a client problem.

    The only non standard things about my config are:
    1. Different folder for recorded TV
    2. Running the TV service under its own username
     

    onetoomany

    Portal Pro
    July 5, 2005
    122
    2
    UK
    Import has run successfully.
    The TV server has been happily running and recording TV under 1.3.0 for the past couple of weeks.
    I've been happily watching recorded TV from a 1.2.3 client (for both TV programmes recorded prior to my server upgrade and those post upgrade)
    No success from a 1.3.0 client though. Strangely, I can watch live TV on the 1.3.0 client, and buffer etc...
     

    jameson_uk
    Country flag

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    Home Country
    United Kingdom United Kingdom
    Import has run successfully.
    The TV server has been happily running and recording TV under 1.3.0 for the past couple of weeks.
    I've been happily watching recorded TV from a 1.2.3 client (for both TV programmes recorded prior to my server upgrade and those post upgrade)
    No success from a 1.3.0 client though. Strangely, I can watch live TV on the 1.3.0 client, and buffer etc...
    Can you access post upgrade recordings on 1.3 client and do you have any tools to look at the database tables installed?
     

    onetoomany

    Portal Pro
    July 5, 2005
    122
    2
    UK
    No access to any post upgrade recordings on the 1.3.0 client - but I can access them on the 1.2.3 client.
    I am on MS SQL, so can open up the workbench and run various queries / examine table structures.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom