[solved] TV Server after upgrading from MP 1.18 to MP 2.2 (1 Viewer)

roedler86

MP Donator
  • Premium Supporter
  • August 25, 2015
    91
    15
    Germany Germany
    Country flag
    Hello guys,

    I just upgraded my MP installation from MP 1.18 to MP 2.2.

    Everything’s works almost fine, except my TV settings.

    What did I do?
    1. Exported all settings from TV Server (1.18)
    2. Deinstalled old installation completely
    3. Installed MP 2.2 with installer
    4. Imported all settings to TV Server (1.20)
    At the moment I can watch the recorded stuff, but I cannot see live tv neither epg.

    I’m wondering that there is no TVServer service like before. Is it renamed?

    What more details can I provided you?
     

    roedler86

    MP Donator
  • Premium Supporter
  • August 25, 2015
    91
    15
    Germany Germany
    Country flag
    Thanks for your reply.

    My server settings (imported from MP 1):
    Server.PNG

    My MediaPortal TV screen looks like:
    Client.PNG


    Client and Server logs attached.
     

    Attachments

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Client and Server logs attached.
    Full logs in DEBUG please. You may use the LOgCollector on your desktop that will collect all data and zip it together for you.

    The server log is full of this:
    [2018-12-28 23:53:24,570] [7744066] [XmlTvImporter] [ERROR] - XML tv import error loading C:\Program Files (x86)\EPG-Buddy\TVGuide_2.xml err:Root element is missing.
    Apparently your EPG Buddy xml file is corrupted.
     

    roedler86

    MP Donator
  • Premium Supporter
  • August 25, 2015
    91
    15
    Germany Germany
    Country flag
    Apparently your EPG Buddy xml file is corrupted.
    Thank you for the hint.

    I saw this entry in the log file yesterday and tried to fix it. But it still didn’t work. That’s why I posted this thread and went to bed.
    Today, epg disabled, everything works fine. Except for the epg of course, but with this I will deal later.

    So, thanks for your help.
     

    roedler86

    MP Donator
  • Premium Supporter
  • August 25, 2015
    91
    15
    Germany Germany
    Country flag
    Sadly, it’s not solved. I checked the connecetion on the server directly, which is working. But today, I checked my client (with the same MP 2.2) and there is still no TV:
    Client.PNG


    On the server it looks (except the issing epg data) good and I can watch TV:
    Capture.PNG


    I enables debug logging and pulled the log files on the client. Thanks for any kind of help...
     

    Attachments

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    One more thing: the screenshot is from 29.12. 0:56, however, you haven't added any log from that time.

    It is difficult to see anything in the logs without knowing at what time you were trying to watch TV. Please reproduce the issue, colelct both client and server logs, upload them and tell us at what time you were experiencing the troubles.
     

    roedler86

    MP Donator
  • Premium Supporter
  • August 25, 2015
    91
    15
    Germany Germany
    Country flag
    Thanks for your effort.

    I tried a couple of minutes before ( 7 pm) .
    Starting conditions:
    • server was in sleep / hibernate state.
    • client was restated
    1. I tried to watch TV on the server —> failed
    2. Restartet MP client on the server and tried again —> worked
    3. tried to watch TVon the client —> failed
    4. Restarted MP client on the Client —> failed
    5. collect Logs on client
    6. collect logs on server
    Thanks again and a happy new year!
     

    Attachments

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Your server log indicates the existence of five o_O DD tuners:
    [2018-12-31 11:36:47,529] [3583 ] [TVService] [INFO ] - Detected new digital BDA tuner device Digital Devices DVB-C MediaCenter Tuner 1 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884eb0-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,542] [3596 ] [TVService] [INFO ] - tuner type = DvbS
    [2018-12-31 11:36:47,542] [3596 ] [TVService] [INFO ] - Controller: add device Digital Devices DVB-C MediaCenter Tuner 1 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884eb0-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,547] [3602 ] [TVService] [INFO ] - Detected new digital BDA tuner device Digital Devices DVB-C/C2 Tuner 1 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884e70-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,555] [3609 ] [TVService] [INFO ] - tuner type = DvbC
    [2018-12-31 11:36:47,556] [3610 ] [TVService] [INFO ] - Controller: add device Digital Devices DVB-C/C2 Tuner 1 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884e70-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,560] [3614 ] [TVService] [INFO ] - Detected new digital BDA tuner device Digital Devices DVB-T/T2 Tuner 1 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884e60-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,568] [3622 ] [TVService] [INFO ] - tuner type = DvbT
    [2018-12-31 11:36:47,568] [3622 ] [TVService] [INFO ] - Controller: add device Digital Devices DVB-T/T2 Tuner 1 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884e60-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,573] [3627 ] [TVService] [INFO ] - Detected new digital BDA tuner device Digital Devices DVB-C MediaCenter Tuner 2 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884eb1-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,582] [3636 ] [TVService] [INFO ] - tuner type = DvbS
    [2018-12-31 11:36:47,582] [3636 ] [TVService] [INFO ] - Controller: add device Digital Devices DVB-C MediaCenter Tuner 2 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884eb1-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,586] [3640 ] [TVService] [INFO ] - Detected new digital BDA tuner device Digital Devices DVB-C/C2 Tuner 2 @device:pnp:\\?\dd_dvb#ven_dd01&dev_0006&subsys_0032dd01&rev_00&tuner#7&34c2ffb8&0&2#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{8b884e71-fbca-11de-b16f-000000004d56}
    [2018-12-31 11:36:47,596] [3650 ] [TVService] [INFO ] - tuner type = DvbC
    2x DVB-S
    2x DVB-C
    1x DVB-T

    This appears as a pretty strange setup. What kind of TV signal are you actually using? Do all tuners really receive working TV signals? If yes, you'll need to scan each tuner type card separately (and map it to the second card of the same tuner).
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 10
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    toricred [solved] Configuring TV Server to use NAS General 1
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    T Server / client channel logo location Installation, configuration support 6
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    J TV Server setup question Newcomers Forum 0
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    I [solved] Connection to TV Server MySQL General Support 8
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    F After resume, TV Server connection screen is shown General Support 4
    R TV server crash with WintTV quadHD General 0
    R MP Server und Fileshare Einsteigerforum 4
    R [further infos missing] some movies freezing evry seconds Submit: Bug Reports 9
    I MP Server goes into suspend, because it doesn't detect the MP Client General Support 6
    S software to send analog to iptv server OffTopic 11
    geeky_herman Recent server upheaval with thegamesdb.net My Emulators 0
    Lehmden [WiP] [MP2-824] DLNA Server functionality MediaPortal 2 27
    A Client/Server Setup: Slow TV Startup Television (MyTV frontend and TV-Server) 0
    Similar threads

























    Top Bottom