TV Server dies when trying to scan for rtsp IP Channels

Discussion in 'Watch / Listen Media' started by pur_berger, January 11, 2015.

  1. pur_berger
    • Super User

    pur_berger Super User

    Joined:
    May 14, 2007
    Messages:
    1,679
    Likes Received:
    183
    Gender:
    Male
    Location:
    Vienna
    Ratings:
    +270 / 1
    Home Country:
    Austria Austria
    Show System Specs
    I'm trying to add some IPTV Channels (rtsp) to the TV Server but as soon I do the scan it dies. Doing the same with VODServer in between it works (most of the times)

    The Adress looks like this
    rtsp://user:password@192.168.0.26:88/videoMain



    When I check the address over the urlsourcve splitter it won't display (Red X)

    Doing the same as http stream is working

    Using 2.1.5.5485 Urlssource splitter and MP 1.10
     
    Last edited: January 11, 2015
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    The IPTV filter is crashing... but it looks like your camera is [currently] not compatible due to the requirement for username/password:
    Show Spoiler

    11-01-2015 21:05:41.530 [1480] [{73CB9EE2-C063-4B72-BC7F-5A532432BD3F}] [Verbose] MPUrlSourceSplitter_Protocol_Rtsp: instance 'Main': CurlWorker(): RTSP response:
    RTSP/1.0 401 Unauthorized
    CSeq: 2
    Date: Sun, Jan 11 2015 20:05:42 GMT
    WWW-Authenticate: Digest realm="Foscam IPCam Living Video", nonce="22f8e3388933964afd4306ccc0b00869"


    11-01-2015 21:05:41.531 [ af4] [{73CB9EE2-C063-4B72-BC7F-5A532432BD3F}] [Error] MPUrlSourceSplitter_Protocol_Rtsp: instance 'Main': Initialize(): RTSP DESCRIBE response status code not success: 401 (Unauthorized)
    11-01-2015 21:05:41.533 [ af4] [{73CB9EE2-C063-4B72-BC7F-5A532432BD3F}] [Error] MPUrlSourceSplitter_Protocol_Rtsp: instance 'Main': Initialize(): error while sending RTSP DESCRIBE: 0xFFFFFF7E


    Perhaps @georgius can help you with this.
     
    • Thank You! Thank You! x 1
  4. georgius
    • Premium Supporter

    georgius Retired Team Member

    Joined:
    October 31, 2010
    Messages:
    1,376
    Likes Received:
    437
    Gender:
    Male
    Occupation:
    Software Architect
    Location:
    Bratislava
    Ratings:
    +668 / 0
    Home Country:
    Slovakia Slovakia
    Show System Specs
    Two problems:
    1. crash caused by filter and TV service incompatibility - will be fixed in several days
    2. authentication is not supported (and probably will not be supported)
     
    • Thank You! Thank You! x 2
  5. pur_berger
    • Super User

    pur_berger Super User

    Joined:
    May 14, 2007
    Messages:
    1,679
    Likes Received:
    183
    Gender:
    Male
    Location:
    Vienna
    Ratings:
    +270 / 1
    Home Country:
    Austria Austria
    Show System Specs
    Ahhhhh - ok - good to know - THX.
     
  6. georgius
    • Premium Supporter

    georgius Retired Team Member

    Joined:
    October 31, 2010
    Messages:
    1,376
    Likes Received:
    437
    Gender:
    Male
    Occupation:
    Software Architect
    Location:
    Bratislava
    Ratings:
    +668 / 0
    Home Country:
    Slovakia Slovakia
    Show System Specs
    The first mentioned problem is fixed by filter version 2.1.6.5489.
     
    • Thank You! Thank You! x 2
  7. pur_berger
    • Super User

    pur_berger Super User

    Joined:
    May 14, 2007
    Messages:
    1,679
    Likes Received:
    183
    Gender:
    Male
    Location:
    Vienna
    Ratings:
    +270 / 1
    Home Country:
    Austria Austria
    Show System Specs
    updated already - working good.
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  8. clarkey2r

    clarkey2r Portal Pro

    Joined:
    February 9, 2009
    Messages:
    215
    Likes Received:
    3
    Ratings:
    +3 / 1
    Home Country:
    United Kingdom United Kingdom
    Sorry to drag up an old(ish) thread but, I run a TV-Server separately from the clients, does the mediaportal splitter need to be installed on my TV-Server or clients (already is)?
     
  9. georgius
    • Premium Supporter

    georgius Retired Team Member

    Joined:
    October 31, 2010
    Messages:
    1,376
    Likes Received:
    437
    Gender:
    Male
    Occupation:
    Software Architect
    Location:
    Bratislava
    Ratings:
    +668 / 0
    Home Country:
    Slovakia Slovakia
    Show System Specs
    For IPTV it must be installed on TV server, for OnlineVideos it must be on clients.
     
  10. clarkey2r

    clarkey2r Portal Pro

    Joined:
    February 9, 2009
    Messages:
    215
    Likes Received:
    3
    Ratings:
    +3 / 1
    Home Country:
    United Kingdom United Kingdom
    Thanks for the quick reply, unless I'm missing something, is there a way to install the splitter without using the mediaportal extension tool?
     
  11. georgius
    • Premium Supporter

    georgius Retired Team Member

    Joined:
    October 31, 2010
    Messages:
    1,376
    Likes Received:
    437
    Gender:
    Male
    Occupation:
    Software Architect
    Location:
    Bratislava
    Ratings:
    +668 / 0
    Home Country:
    Slovakia Slovakia
    Show System Specs
    On TV server is missing MPEI installer? I never have such installation, but it is possible.

    Steps:
    1. stop TV service
    2. under TV service folder (default is "C:\Program Files\Team MediaPortal\MediaPortal TV Server" for x86 systems (32bit) or "C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server" for x64 (64bit) systems) create folder "MPUrlSourceSplitter"
    3. copy to "MPUrlSourceSplitter" folder filter files from any client (I assume that you have same filter version on all clients) - by default in "C:\Program Files\Team MediaPortal\MediaPortal\MPUrlSourceSplitter" for x86 or "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter" for x64
    4. run command prompt under administrator privileges
    5. type for x86:
      Code (Text):
      1. regsvr32 "C:\Program Files\Team MediaPortal\MediaPortal TV Server\MPUrlSourceSplitter\MPUrlSourceSplitter.ax"
      or for x64:
      Code (Text):
      1. regsvr32 "C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\MPUrlSourceSplitter\MPUrlSourceSplitter.ax"
    6. information message about successful registration should appear
    7. start TV service
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!