TV Server dies when trying to scan for rtsp IP Channels (1 Viewer)

pur_berger

Super User
  • Team MediaPortal
  • Super User
  • May 14, 2007
    1,679
    309
    47
    Vienna
    Austria Austria
    Country flag
    I'm trying to add some IPTV Channels (rtsp) to the TV Server but as soon I do the scan it dies. Doing the same with VODServer in between it works (most of the times)

    The Adress looks like this
    rtsp://user:password@192.168.0.26:88/videoMain

    When I check the address over the urlsourcve splitter it won't display (Red X)

    Doing the same as http stream is working

    Using 2.1.5.5485 Urlssource splitter and MP 1.10
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    The IPTV filter is crashing... but it looks like your camera is [currently] not compatible due to the requirement for username/password:
    [collapse]
    11-01-2015 21:05:41.530 [1480] [{73CB9EE2-C063-4B72-BC7F-5A532432BD3F}] [Verbose] MPUrlSourceSplitter_Protocol_Rtsp: instance 'Main': CurlWorker(): RTSP response:
    RTSP/1.0 401 Unauthorized
    CSeq: 2
    Date: Sun, Jan 11 2015 20:05:42 GMT
    WWW-Authenticate: Digest realm="Foscam IPCam Living Video", nonce="22f8e3388933964afd4306ccc0b00869"


    11-01-2015 21:05:41.531 [ af4] [{73CB9EE2-C063-4B72-BC7F-5A532432BD3F}] [Error] MPUrlSourceSplitter_Protocol_Rtsp: instance 'Main': Initialize(): RTSP DESCRIBE response status code not success: 401 (Unauthorized)
    11-01-2015 21:05:41.533 [ af4] [{73CB9EE2-C063-4B72-BC7F-5A532432BD3F}] [Error] MPUrlSourceSplitter_Protocol_Rtsp: instance 'Main': Initialize(): error while sending RTSP DESCRIBE: 0xFFFFFF7E[/collapse]

    Perhaps @georgius can help you with this.
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    Two problems:
    1. crash caused by filter and TV service incompatibility - will be fixed in several days
    2. authentication is not supported (and probably will not be supported)
     

    pur_berger

    Super User
  • Team MediaPortal
  • Super User
  • May 14, 2007
    1,679
    309
    47
    Vienna
    Austria Austria
    Country flag
    Two problems:
    1. crash caused by filter and TV service incompatibility - will be fixed in several days
    2. authentication is not supported (and probably will not be supported)
    Ahhhhh - ok - good to know - THX.
     

    pur_berger

    Super User
  • Team MediaPortal
  • Super User
  • May 14, 2007
    1,679
    309
    47
    Vienna
    Austria Austria
    Country flag

    clarkey2r

    Portal Pro
    February 9, 2009
    215
    3
    United Kingdom United Kingdom
    Sorry to drag up an old(ish) thread but, I run a TV-Server separately from the clients, does the mediaportal splitter need to be installed on my TV-Server or clients (already is)?
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    Sorry to drag up an old(ish) thread but, I run a TV-Server separately from the clients, does the mediaportal splitter need to be installed on my TV-Server or clients (already is)?
    For IPTV it must be installed on TV server, for OnlineVideos it must be on clients.
     

    clarkey2r

    Portal Pro
    February 9, 2009
    215
    3
    United Kingdom United Kingdom
    Sorry to drag up an old(ish) thread but, I run a TV-Server separately from the clients, does the mediaportal splitter need to be installed on my TV-Server or clients (already is)?
    For IPTV it must be installed on TV server, for OnlineVideos it must be on clients.
    Thanks for the quick reply, unless I'm missing something, is there a way to install the splitter without using the mediaportal extension tool?
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    Sorry to drag up an old(ish) thread but, I run a TV-Server separately from the clients, does the mediaportal splitter need to be installed on my TV-Server or clients (already is)?
    For IPTV it must be installed on TV server, for OnlineVideos it must be on clients.
    Thanks for the quick reply, unless I'm missing something, is there a way to install the splitter without using the mediaportal extension tool?
    On TV server is missing MPEI installer? I never have such installation, but it is possible.

    Steps:
    1. stop TV service
    2. under TV service folder (default is "C:\Program Files\Team MediaPortal\MediaPortal TV Server" for x86 systems (32bit) or "C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server" for x64 (64bit) systems) create folder "MPUrlSourceSplitter"
    3. copy to "MPUrlSourceSplitter" folder filter files from any client (I assume that you have same filter version on all clients) - by default in "C:\Program Files\Team MediaPortal\MediaPortal\MPUrlSourceSplitter" for x86 or "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter" for x64
    4. run command prompt under administrator privileges
    5. type for x86:
      Code:
      regsvr32 "C:\Program Files\Team MediaPortal\MediaPortal TV Server\MPUrlSourceSplitter\MPUrlSourceSplitter.ax"
      or for x64:
      Code:
      regsvr32 "C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\MPUrlSourceSplitter\MPUrlSourceSplitter.ax"
    6. information message about successful registration should appear
    7. start TV service
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 10
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    toricred [solved] Configuring TV Server to use NAS General 1
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    T Server / client channel logo location Installation, configuration support 6
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    J TV Server setup question Newcomers Forum 0
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    I [solved] Connection to TV Server MySQL General Support 8
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    F After resume, TV Server connection screen is shown General Support 4
    R TV server crash with WintTV quadHD General 0
    R MP Server und Fileshare Einsteigerforum 4
    R [further infos missing] some movies freezing evry seconds Submit: Bug Reports 9
    I MP Server goes into suspend, because it doesn't detect the MP Client General Support 6
    S software to send analog to iptv server OffTopic 11
    geeky_herman Recent server upheaval with thegamesdb.net My Emulators 0
    Lehmden [WiP] [MP2-824] DLNA Server functionality MediaPortal 2 27
    A Client/Server Setup: Slow TV Startup Television (MyTV frontend and TV-Server) 0
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    R [solved] MediaPortal: TV Server und HD Sender Installationsprobleme? 2
    Similar threads

























    Top Bottom