[solved] - TV Server Service preventing sleep

Discussion in 'General Support' started by Stéphane Lenclud, November 6, 2018.

  1. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    After years of running my single sit MP1 24/7 I decided to save myself some money and make sure it goes to sleep whenever it needs to.
    However it just won't. Power Scheduler is enabled and setup but in fact TV server service is preventing Windows to go to sleep. If I stop the TV service Windows goes to sleep as expected.



    If I use active sleep from Power Scheduler it just goes to sleep after the defined timer from the last time it woke up even though someone is using the PC. So this is not usable either.

    It seems like the TV Server keeps turning power request on and off.
    Running powercfg -requests often comes back empty but if I keep running it in short interval it will inevitably show:
    [SERVICE] \Device\HarddiskVolume2\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\TvService.exe (TVService)

    I'm still on MP 1.16. Is there a way to configure this so that it works? Am I running an older broken version of Power Scheduler?
    Is there an option in the basic TV Server configuration that I'm missing?
     

    Attached Files:

    Last edited: November 6, 2018
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Could be an issue with a wrongly configured EPG. Can you post a screenshot of how you've set it up, particularly the page with the channel selection(s)?
     
    • Thank You! Thank You! x 1
  4. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
  5. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Yep, your EPG is not correctly set up.

    You have ticked each channel. What is now happening is that the EPG of the first channel is read. However, it is very likely that this channel broadcasts not just info for this spoecific channel but for the whole bouquet, which is then read and stored - taking some time. Then the next channel is treated in the same manner, taking again a lot of time and, more ipotant, most likely reading and writing redundant information that was already gathered.

    There are two solutions that I suggest:
    1. Tick only the very minimum number of channels, i.e. only one for a given provider.
    2. Use the EPG Grabber (Lehmden) instead. Since you are in Germany this would be the most convenient and efficient way to go. This would get you a 99% complete EPG since almost everything can automatically be read from free online sources (TV Movie). In my cases I then only need to add 3-4 channels (mainly Sky Sports/Bundesliga where you tick only one to get all Bundesliga channels automatically.=
     
    • Thank You! Thank You! x 1
  6. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    That should not prevent the computer to go to sleep though since "Do not put the computer to sleep while grabbing EPG" is not set.
     
  7. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    It does in all cases:. a running EPG grabber will change the Windows computer state from idle to busy. Test the hypothesis by completely deactivating the grabber. You should see your PC going to sleep after the preset time.
     
    • Thank You! Thank You! x 1
  8. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    I was just testing without Power Scheduler activated and it still would not go to sleep. That means the TV server itself is indeed requesting power and preventing sleep. I'll do more testing.
     
  9. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Sure, as you like.:) However, I did this years ago, and found my explanation to be 100% accurate. In fact your EPG grabber is running into a time out because the max time (30 min) is not long enough to allow a full grab of each ticked channel in your EPG. Even 120 min will probably not be sufficient.

    Every few months I am giving the same explanations and advice to somebody who has been doing the same that you did.;)
     
    • Thank You! Thank You! x 1
  10. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    It did go to sleep after disabling "EPG grabbing while idle" and restarting the service.
    They are indeed :) Thanks a lot mate!

    Looks to me like we ought to fix that in TV server at some point.
     
  11. Stéphane Lenclud
    • Team MediaPortal

    Stéphane Lenclud Development Group

    Joined:
    April 29, 2013
    Messages:
    2,563
    Likes Received:
    657
    Gender:
    Male
    Ratings:
    +1,270 / 8
    Home Country:
    Germany Germany
    Show System Specs
    So I've re-enabled "EPG grabbing while idle" this time making sure I have a limited TV Epg Grabber channel selection.
    Sure enough it did go to sleep once it was done grabbing.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!