TV service not available (1 Viewer)

JayD

New Member
April 30, 2019
4
0
52
Canada Canada
Country flag
I was running the near latest version 1 Mediaportal without issues on the same box. I did a full uninstall and installed 2.2.1. I had issues launching the TV config. I re-installed again and it seemed fine. Now after a period of time the tv service becomes unavailable and I cannot launch the tv config app again. The processes are running and do not seem hung as I can restart them and all works again for a while. The attached logs were generated as the issue was occurring.

Specs:
64 bit Win 7 Pro
AMD Athalon II X4 630 Proc 2.8 GHz
4 GB Ram

Multiple HDD
 

Attachments

JayD

New Member
April 30, 2019
4
0
52
Canada Canada
Country flag
In my latest case it appears the Mediaportal service actually crashed. Restarted it and it is ok again.
 

JayD

New Member
April 30, 2019
4
0
52
Canada Canada
Country flag
It appears the crash of the service coincides with the share refresh. i change the refresh time and the crash time changed with it.

Windows app log error:
Log Name: Application
Source: Application Error
Date: 5/3/2019 6:03:51 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: HT
Description:
Faulting application name: MP2-Server.exe, version: 2.2.1904.12006, time stamp: 0x5cb0f336
Faulting module name: ntdll.dll, version: 6.1.7601.24408, time stamp: 0x5c92f05b
Exception code: 0xc0000374
Fault offset: 0x000ce9a3
Faulting process id: 0x79c
Faulting application start time: 0x01d501615f7ce08e
Faulting application path: C:\Program Files (x86)\Team MediaPortal\MP2-Server\MP2-Server.exe
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
Report Id: c020c492-6d8a-11e9-967e-90e6bacd1623
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-05-03T10:03:51.000000000Z" />
<EventRecordID>95446</EventRecordID>
<Channel>Application</Channel>
<Computer>HT</Computer>
<Security />
</System>
<EventData>
<Data>MP2-Server.exe</Data>
<Data>2.2.1904.12006</Data>
<Data>5cb0f336</Data>
<Data>ntdll.dll</Data>
<Data>6.1.7601.24408</Data>
<Data>5c92f05b</Data>
<Data>c0000374</Data>
<Data>000ce9a3</Data>
<Data>79c</Data>
<Data>01d501615f7ce08e</Data>
<Data>C:\Program Files (x86)\Team MediaPortal\MP2-Server\MP2-Server.exe</Data>
<Data>C:\Windows\SysWOW64\ntdll.dll</Data>
<Data>c020c492-6d8a-11e9-967e-90e6bacd1623</Data>
</EventData>
</Event>
 

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Are you using any additional plugins? What is this:
    Application: MPExtended.Applications.ServiceConfigurator.exe
     

    JayD

    New Member
    April 30, 2019
    4
    0
    52
    Canada Canada
    Country flag
    MPExtended is required for MPTVscheduler and previous to that ampdroid. Both are Andriod based streaming apps. On a side issue, I am able to get MPTVscheduler to connect to the server but streaming crashes.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    I can't say anything about your additional applications as these are not officially supported. It looks like your problems are connected to their use.
     

    superforever

    Portal Pro
    April 13, 2009
    148
    12
    Country flag
    I think I have similar problem, seems like after PC wake up from sleep.

    I have to reboot it to get TV service back but I couldn't find the MP Service in Windows Services to restart it. In MP1 the service name it TV Service but MP2 is difference?
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    In MP1 the service name it TV Service but MP2 is difference?
    In MP2 TV Server is running as a plugin. The only Windows service is the “MP2 Server Service”. Instead rebooting you can restart this service.

    The issue could be related to initialization troubles of your TV card. There is a setting in TV Config to delay the startup. Might be worth a try.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    L Service keeps crashing General 3
    X [solved] Display needs to be turned on for TV services to function General 1
    T [solved] failed to-startup tvservice Installation, configuration support 1
    F [solved] Could not find the MediaPortal.Common.Logging.ILogger service after upgrading from 2.2.2 to 2.2.3 General 2
    DHosein Mediaportal & Antimalware Service High CPU issue General Support 2
    Z TV-Service in falscher Version Installationsprobleme? 9
    T Missing sound in online streaming service (SVTPlay) General Support 3
    emphatic Pictures in the cloud - would a plugin be possible for services like Google Photos MediaPortal 1 Plugins 1
    K sudden complication watching recorded TV Newcomers Forum 6
    P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
    M [solved] Setup Issue - Hanging on Starting Services General 3
    ajs Sync databases by Media Sync Service MediaPortal 1 Talk 26
    BlueMax1916 [Question] What does MP2 Server Service have to do with ...microsoft.com/filestreamingservice...? MediaPortal 2 3
    Holzi [solved] MediaPortal 2 will not install - Failed to start services MediaPortal 2 1
    Stéphane Lenclud [solved] TV Server Service preventing sleep General Support 18
    D Remove "Old" client names from Service Monitor? General 5
    B Server service on the service monitor keeps stopping randomly. Client can't see server status. 2.2 Archive 5
    D Upgrade to MP2.2 pre release fails with failure to start service 2.2 Archive 32
    T MP2.2 Pre Release fails installation with not starting the MP2-service 2.2 Archive 4
    F MP2 - V2.1 MP2 TV Service won't start Older releases 3
    P No TV provider available (yet)? General 1
    morpheus_xx [Finished] [MP2-802] TV-Settings availability in all TV screens MediaPortal 2 12
    T No data available using xmltv and mc2xml xmlTV 2
    J [solved] Clients do not see available MP2 server in the network General 3
    M VPN: Mediaportal TV-Server ist not using all available bandwidth which results in TV stuttering Newcomers Forum 0
    Similar threads

























    Top Bottom