TV Stuttering (1 Viewer)

64mike53

Portal Member
October 31, 2011
22
6
Home Country
Netherlands Netherlands
I really like Mediaportal tv server but the only problem I have with the tv server is that I have around every minute a stuttering screen on Live TV.
I tried a lot on codecs and tried another tv server like ArgusTV. With ArgusTV as tv server there where no problems on stuttering with Mediaportal as client. The only problem is that I don't want to use ArgusTV but Mediaportal tv server.

I tried a lot of things with codecs and did some research on the forums but can't find a good explanation about the problem.
I attached some log files and screenshots of the load. The error I see in the logs is "Video Continuity error". The stuttering is about 3-5 seconds and then the screen is normal.
 

Attachments

  • Client load, screen, debug.png
    Client load, screen, debug.png
    1.8 MB
  • server monitor.PNG
    server monitor.PNG
    28.3 KB
  • TsReader Log Client.txt
    34 KB
  • TsWriter Log Server.txt
    115 KB

64mike53

Portal Member
October 31, 2011
22
6
Home Country
Netherlands Netherlands
It looks like the problem is only with HD channels. When there are a lot of pixels changing then the stuttering is more then with slow changing of pixels.

Does anyone know a solution?
 

HomeY

Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    47
    ::1
    Home Country
    Netherlands Netherlands

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Home Country
    Slovakia Slovakia
    Continuity errors are on TV server side, so it has no relevance to refresh rate. If he made some recordings, these recordings will also have problem - doesn't matter which player you use. Complete set of logs can be much more helpful.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    47
    ::1
    Home Country
    Netherlands Netherlands
    Continuity errors are on TV server side, so it has no relevance to refresh rate. If he made some recordings, these recordings will also have problem - doesn't matter which player you use. Complete set of logs can be much more helpful.
    True, i just had a quick peak @ the screenshot, and noticed a 60Hz display. That'll never run smooth for him, since he's got 50FPS PAL TV.
    but indeed just noticed the huge number of continuity errors, so that seems closer to the source of his problem :) but in the end he still needs to set the right refresh rate for nice playback ;)
     

    64mike53

    Portal Member
    October 31, 2011
    22
    6
    Home Country
    Netherlands Netherlands
    Thanks for the reactions. I uploaded the server logs.

    I hope someone can find something because at the moment watching TV is not very good:)
     

    64mike53

    Portal Member
    October 31, 2011
    22
    6
    Home Country
    Netherlands Netherlands
    I tried to look at the internet today and looked throught all the topics that are in common with my problem but can't find a solution.

    I know there are a lot of iops to the timeshift or recording disk with mediaportal tv server. Maybe I have a different setup because I have a server with vmware esx v5. In the server there is a HP smart array P410 as storage controller and have 2 WD green disks in RAID 0. The disks are only for timeshift and recordings so nothing else is writing/reading from these disks.

    I don't know if it is a problem with virtualisation or storage controller?
     

    64mike53

    Portal Member
    October 31, 2011
    22
    6
    Home Country
    Netherlands Netherlands
    Does anyone has a suggestion for this? The problem still exist. I switched to UNC path connection and it is a little bit better but the problem is still there.

    I used the same setup for argusTV and it worked perfect but has not the functionality I want. Could someone help me in the right direction?
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    47
    ::1
    Home Country
    Netherlands Netherlands
    Missed some posts Mike, sorry for that.

    Just read that you're using VMWare. You mean you have installed the TV Server part in a VMWare environment?
    Are you using fixed IPs between your Client and Server (recommended)?
    No A/V software scanning the Timeshift/Recording folders?
     

    64mike53

    Portal Member
    October 31, 2011
    22
    6
    Home Country
    Netherlands Netherlands
    Missed some posts Mike, sorry for that.

    Just read that you're using VMWare. You mean you have installed the TV Server part in a VMWare environment?
    Are you using fixed IPs between your Client and Server (recommended)?
    No A/V software scanning the Timeshift/Recording folders?

    No problem. I use esx 5.0 and installed Windows 7 professional x64 as OS. This virtual had only the mediaportal tv service role installed on the system. It also has a fixed ip and there is no firewall enabled or antivirus installed on server or client.
     

    Users who are viewing this thread

    Top Bottom