TV timeshifting freeze on Recording ending

Discussion in '1.2.x' started by doveman, December 17, 2011.

  1. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    MediaPortal Version: v1.2.1
    MediaPortal Skin: StreamedMP
    Windows Version: Win7 Ult 64
    CPU Type: Phenom II X4 955
    HDD: 2TB Samsung F4
    Memory: 8GB DDR3 1600Mhz
    Motherboard: MSI 990FXA-GD80
    Video Card: HD6950 2GB
    Video Card Driver: 11.10
    Sound Card: onboard Realtek AC97 (ALC892)
    Sound Card AC3: no AC3
    Sound Card Driver: 6.01.6482
    1. TV Card: Hauppauge Nova-T 500
    1. TV Card Type: DVB-T
    1. TV Card Driver: 4.3.27240
    MPEG2 Video Codec: Cyberlink PDVD11
    MPEG2 Audio Codec: ffdshow
    h.264 Video Codec: ffdshow
    Satelite/CableTV Provider:
    HTPC Case: Custom
    Cooling: Scythe 120mm Bottom Intake Fan, TRUE Rev. c CPU HSF
    Power Supply: Antec CP-850
    Remote: Nova-T 500
    TV: Sony XBR800 36"
    TV - HTPC Connection: DVI

    I was watching a programme on CH.4 when it suddenly froze (static picture, no sound), just before a pop-up appeared to notify me that my recording on BBC1 had finished.



    My earlier bug report may be related https://forum.team-mediaportal.com/...cheduled-recording-despite-dual-tuner-103589/
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. tourettes
    • Team MediaPortal

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    17-12-2011 20:53:33.901 [1558]--- Buffer-empty rate control testing ----
    17-12-2011 20:53:33.901 [1558]---------- v0.0.38 XXX -------------------

    You aren't using official release, please try to reproduce the issue with clean installation. We cannot give any support or analyse the issues based on custom installations.
     
  4. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Yeah, sorry. I'll post any further such bug reports in the Experimental TsReader development thread.
     
  5. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,828
    Location:
    Cambridge
    Ratings:
    +4,130 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Actually Tourettes said "please try to reproduce the issue with clean installation" (my bold) - you have other patches/mods applied e.g. the CC patch, as well as an experimental TsReader.ax.

    If you compare the TsReader-2011-12-17.Log with the evr.log, something has decided to close down EVR presenter at 20:53:47.338:

    Code (Text):
    1.  
    2. 17-12-2011 20:53:47.338 [1558]MPEVRCustomPresenter::Cleanup()
    3. 17-12-2011 20:53:47.338 [1558]EVRCustomPresenter::dtor - instance 0x100fe268
    4. 17-12-2011 20:53:47.338 [1558]Stopping workers...
    5.  
    when TsReader.ax is still running (and data is being accepted by the downstream decode filters), and EVR presenter hasn't seen a clock pause or stop command.....

    Tony
     
  6. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Well I don't recall having strange problems like this until after installing nostopmod recently, so I'm probably unlikely to be able to reproduce it with a clean installation. I've upgraded to the 1.2.2 tsreader now and it seems to be working OK. If it starts happening again and I report it in the tsreader thread, I'm sure someone will tell me if they're certain it's unrelated and then I can check with sebastii whether it might be connected to the CC patch, but I've had that installed for a while without problems so I think it's more likely to be something to do with the nostopmod.

    If necessary, after that I'll try and reproduce it with a clean installation, but with intermittent bugs that's rather hard for me as I need at least the part_DWM dshowhelper for playback to work properly on my dual-screen system, so I can't really run a clean installation for extended periods of time in order to try and catch intermittent bugs.
     
  7. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,828
    Location:
    Cambridge
    Ratings:
    +4,130 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I'm not saying it's the CC patch causing the problem - there's nothing really definite in the logs that might pinpoint what went wrong, it's just that the sequence of events in evr.log isn't normal.

    Tony
     
  8. tourettes
    • Team MediaPortal

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Maybe it was some older EVR presenter instance that was closed down?Who knows how long the GC will delay up the cleaning - it is possible to get a bit mixed up logs...
     
  9. tourettes
    • Team MediaPortal

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    As no one else has reported such issue it is quite likely that some of the modifications is causing it (of course it could be just a well hidden bug in the official release as well).

    Trying to fix an issue based on logs is quite hard but trying to fix an issue based logs where code doesn't match the release is quite impossible. It is quite likely that devs spend the time on the first case than the 2nd case.
     
  10. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I agree (with both points).
     
  11. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,828
    Location:
    Cambridge
    Ratings:
    +4,130 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Good point - it is a different instance that's being closed....

    doveman - have you had this happen repeatedly ? Was MP frozen at this point, or could you recover things by stopping playback ?

    Tony
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!