TVGuide's Hebrew text is a mess when running on XP

Discussion in 'Installation, configuration support' started by Shay1000, December 31, 2011.

  1. Shay1000

    Shay1000 Portal Member

    Joined:
    December 19, 2011
    Messages:
    9
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Israel Israel
    Hi I am running MediaPortal 1.2.1 TV server on Windows7. All is working fine. TVGuide is showing perfectly on that machine and on a second Windows7 client machine.
    However, on an XP machine, the same version of MediaPortal, is showing the TVGuide and programs info in a wrong way. The letters are messed up, the letters are being duplicated etc. This is not readable.



    Here is a snapshot from the XP remote client ( appears wrong ):
    [​IMG]

    Here is a snapshot from a remote Windows7 client ( appears correctly ):
    [​IMG]

    Can I somehow make the XP client to display the text correctly?
    I would appreciate any suggestions for me to check.
    Thanks!
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Holzi
    • Team MediaPortal

    Holzi Super Moderator

    Joined:
    April 21, 2010
    Messages:
    7,928
    Likes Received:
    1,591
    Gender:
    Male
    Location:
    Ba-Wü
    Ratings:
    +2,228 / 8
    Home Country:
    Germany Germany
    Show System Specs
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,730
    Ratings:
    +8,196 / 17
    Home Country:
    New Zealand New Zealand
    Hi and welcome Shay1000 :)

    What are the native languages that you've configured on each of those PCs? The required fonts might be missing from XP unless they are intentionally installed.

    mm
     
  5. Shay1000

    Shay1000 Portal Member

    Joined:
    December 19, 2011
    Messages:
    9
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Israel Israel
    Thanks. Already feels like home :)

    Two observations I have:
    1. If I change the MediaPortal's Language to Hebrew on that XP machine, the TVGuide is showing OK. This is the workaround I am currently using ( which should be fine, as that XP laptop is for my wife to select shows to record from bed ).

    2. The "mess" up behavior is actually that MediaPortal is making the words into palindrome. So if the word is "hello" it is showing as "helloolleh" - just with Hebrew letters. So I don't think this is about missing fonts, because they are seen. Probably something with the text processing/right-to-left/enconding handling.


    Thanks again!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!