MP2 - V2.5 TVMosaic Provider for MP2 (6 Viewers)

ge2301

Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    2ddd599b0ea09a0f4b59660b375e3729a94cfad1.png


    The current TV engine (TVE3) for Media Portal 1 and 2 was developed long time before and is not state of the art any more.
    Accordingly we decided to develop the TVMosaic plugin as alternative TV provider. TVMosaic CE is freeware and can be configured by web browser. Because it is not bonded to windows it may run on many platforms.

    [COLOR=%s]Please note, that the plugin is currently in beta state and many functionalities could not be implemented yet. Within this thread you may follow the latest updates and support to test beta versions.[/COLOR]

    Any opinions and of course interested developers are welcome.

    • There is already a branch with provider plugin as base and merged WIP2.4 branch.
    • Jira: MP2-883
    • Installer: Please do not use the official MP2.4 installer, but one from below, which have specific fixes and plugins included.
    TVMosaic API documentation
    TVMosaic Forum

    Downloads:​

    1. 2022-01-02: Download
    2. 2022-01-03: Download - Fixed channel order and live EPG time
    3. 2022-01-05: Download - Fixed availability of program description, schedules are visible and work
    4. 2022-01-07: Download - Added gerne labels to EPG screens and recording details
    5. 2022-01-31: Download - TVMosaic settings on server, thumbnails and genres for recordings, new media source category
    6. 2022-02-03: Download - Fixed handling fo series schedules
    7. 2022-03-30: Download - Added experimental timeshift support
    8. 2022-04-01: Download - Fixed channel change / restart of same channel
    9. 2022-04-02: Download - Fixed stop on channel change, added caching for frequently accessed data
    10. 2022-04-08: Download - Probably fixed EPG gaps due to wrong time conversion. Added EPG data caching
    11. 2022-05-09: Download - Fixed build issue with OnlineVideos plugin
    12. 2022-06-22: Download - Recordings are automatically imported from TVMosaic share (playback only until import time)
    13. 2022-07-01: Download - Added functionality to delete recordings made with TVMosaic within MP2-Client
    14. 2022-10-17: Download - Custom Installer incl. TVMosaic

    Instructions:​

    1. [COLOR=%s]Install the linked version of MP2.4. It already contains all needed plugins[/COLOR]
    2. (Optional for updates) Move out the "C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\SlimTv.NativeProvider" folder (there can be only one TV provider registered. If you would like to use the TVE3 later, do not delete it, but move it out of the MP2-Installation)
    3. (Optional for updates) Extract the contents of attached plugin to "C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\" with subfolders (finally a folder "SlimTv.TvMosaic" should be present in the plugin folder.
    Recovery instructions: In case you want to get the original TVE3 back, just move out "SlimTv.TvMosaic" from plugins and move back "SlimTv.NativeProvider".

    Configuration in TV settings of MP2-Client:
    • Server address: <name> or IP for the device on which TVMosaic-service runs (default: "localhost", so nothing to enter, if on same device as MP2-Client). By default the port is already set to "9270"
    • UserName: Can be set, if required
    • Password: Can be set if required
    • Since 2022-01-31 you need to add a new media source with the category "TVMosaic" to import recordings
    Possible Setups:
    1645181592103.png

     

    Attachments

    • MP2_2.4.1.MP2-672_CustomInstaller.zip
      208.8 MB

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    • Thread starter
    • Admin
    • #2
    With the public release of MP2 - Version 2.4 the beta TVMosaic plugin can be directly used with it.
    You don't need a special installer anymore. Accordingly the installation instructions in first post were updated.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,194
    1,541
    Home Country
    Germany Germany
    Are there any settings for this or do I need to change anything in my setup to get this working, if yes can you point me to a wiki. The plugin is not shown in the settings/plugin gui and selecting TV and EPG just brings up the rotating dots and hangs MP2.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    • Thread starter
    • Admin
    • #4
    Are there any settings for this or do I need to change anything in my setup to get this working, if yes can you point me to a wiki. The plugin is not shown in the settings/plugin gui and selecting TV and EPG just brings up the rotating dots and hangs MP2.
    It replaces the TVE3, so "TV" in settings is TVMosaic, if you follow the instructions in first post. You'll also find 3 new settings then, but they can be also ignored. To to configure the TVMosaic TV server you'll need to read on their page, linked in first post.
    In case you configured everything and still do see only loading dots, please upload debug logs here to see, what happened. The plugin is WIP, so only basic functionality is given so far.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,194
    1,541
    Home Country
    Germany Germany
    OK now have it configured and scanned and can see all the channels in the EPG but still can't play anything, after a brief pause an error icon (? in a circle)appears in the top left of the screen and when clicked is as shown in the screenshot below. Attached logs were cleared prior to trying to play Das Erste.
    moz-1.jpg
     

    Attachments

    • MediaPortal2-Logs-2021-12-31-16.38.56.zip
      181.6 KB
    Last edited:

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    • Thread starter
    • Admin
    • #6
    OK now have it configured and scanned and can see all the channels in the EPG but still can't play anything, after a brief pause an error icon (? in a circle)appears in the top left of the screen and when clicked is as shown in the screenshot below. Attached logs were cleared prior to trying to play Das Erste.
    View attachment 209664
    The logs show the mentioned error, but description is really too short:
    [2021-12-31 16:38:14,756] [59324 ] [AMQ 'UPnPRendererPlugin'] [ERROR] - Player Error
    I've unfortunately no idea what the rout cause could be. @harryzwo the plugin worked for you with MP2.4, right?
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,194
    1,541
    Home Country
    Germany Germany
    The logs show the mentioned error, but description is really too short:
    [2021-12-31 16:38:14,756] [59324 ] [AMQ 'UPnPRendererPlugin'] [ERROR] - Player Error
    Should it just default to the MP2 player or do I need to set up or configure something?
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    • Thread starter
    • Admin
    • #8
    Should it just default to the MP2 player or do I need to set up or configure something?
    I did not reconfigure anything, when I tried it. I just did what is described in first post and it directly worked.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,194
    1,541
    Home Country
    Germany Germany
    Seems to be a problem with the 2.4 released version, I found the old base version which I had downloaded a while ago but never used, uninstalled 2.4 release installed the base version and and Mosaic plugin and TV now plays!
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    8,188
    3,242
    Stuttgart
    Home Country
    Germany Germany
    Seems to be a problem with the 2.4 released version, I found the old base version which I had downloaded a while ago but never used, uninstalled 2.4 release installed the base version and and Mosaic plugin and TV now plays!
    Yeah, seems so. Same was reported in the german thread. @morpheus_xx seems something was not integrated inro 2.4 release, that was part of the TVMosaic branch. I understood it was integrated completely. Shall I merge master into TVMosaik branch and recreate a new installer for first post?
     

    Users who are viewing this thread

    Top Bottom