TVServer may not handle aspect ratios correctly (for analog)? (1 Viewer)

Al_Capone

MP Donator
  • Premium Supporter
  • September 26, 2006
    527
    19
    Norway Norway
    TV-Server Version: 1.0 RC1 SVN 19158
    MediaPortal Version: 1.0 RC1 SVN 19158 +updated TsReader.ax
    MediaPortal Skin: Bluetwo Wide
    Windows Version: XP SP2
    CPU Type: Pentium Mobile 1,73Ghz
    HDD: 160GB toshiba 2,5" SATA
    Memory: 1GB
    Motherboard: Aopen
    Video Card: Nvidia 8400GS
    Video Card Driver: 169.28
    Sound Card: Realtek ALC880 (onboard)
    Sound Card AC3: Realtek ALC880 (onboard)
    Sound Card Driver: 5.10.00.5345
    1. TV Card: Hauppauge WinPVR USB2 (hardware compression)
    1. TV Card Type: Analog
    1. TV Card Driver: 24023
    2. TV Card: FireDTV S2, Firmware 1.4.0
    2. TV Card Type: Sat
    2. TV Card Driver: 4.4N
    MPEG2 Video Codec: ffdshow tryouts 1723
    MPEG2 Audio Codec: ffdshow tryouts 1723
    h.264 Video Codec: ffdshow tryouts 1723
    Satelite/CableTV Provider: canal digital
    HTPC Case: XC Cube mini
    Cooling: internal fan
    Power Supply: XC Cube-mini's standard
    Remote: FireFly
    TV: Widescreen 26" monitor, DLP projector
    TV - HTPC Connection: DVI


    This is not really a bug - but I suspect it to be one - needs to be confirmed.
    -Widescreen monitor is using it's native resolution.
    -the screen calibration is done, and the square is completely .. square.

    now: Satellite channels looks OK.
    but the analog TV, "Hauppauge WinPVR USB2 (hardware compression)" is "never" looking perfectly normal, no matter what aspect ratio is selected.

    Could somebody comment on this ?
    .Maybe it's a Norwegian phenomenon, as Norwegian terrestrial TV often messes up cropping/aspect ratios, at least over shorter time, like commercials and news.

    I suspect there's something fishy about the analog TV.
    - it worked "perfectly" in version 2.3.0 - and no TV server.

    Please tell me what you think about this .. - remember - SAT and movies/episodes (AVI) are *always* ok.
     

    asd7000

    Portal Pro
    May 17, 2008
    412
    23
    I have the same Problem with my Creatix CTX946 Hybrid DVB-T Cards with Hardware Encoder for analog. DVB-T Video is fine but the analog tv has the problems you discribed. You can try a different codec for mpeg2 in my TV. But there may be other problems like missing deinterlacing or sometimes timeshift errors ( powerdvd 8 ). Right now i just searching for the best codec!

    Regards Rüdy
     

    monkeywiz

    New Member
    March 31, 2006
    4
    0
    Having a similar problem, aspect ratios watching TV in 2.3.0 was fine, but since upgrading to 1.0.0.0 RC1 yesterday aspect ration needs manually choosing for each channel, and none of them seem perfect (or if they do not reaching the edges of the screen), I'm having a look through to see if any codecs etc were deleted when I switched.

    Windpws XP, Hauppage Nova T Cards, ATI Radeon x800 gto
     

    jeroen94704

    New Member
    June 24, 2008
    3
    0
    Eindhoven
    Netherlands Netherlands
    Same problem here. My TV is widescreen, but it seems like MP treats it as 4:3 when playing TV, since 4:3 shows fill the whole screen, while widescreen shows stubbornly have black bars above and below the picture. The net effect is that everything is stretched horizontally.

    I tried both with the MPV and ffdshow codecs, and even fiddled with the AR settings in ffdshow, as described in another thread, yet nothing seems to make any difference. I also went through the screen calibration, and the square used to correct the AR is indeed perfectly square (I even measured it with a tape-measure).

    How does MP determine the aspect ratio of the screen it is being used on? The resolution of my screen is 1280x768, which works out to something closer to 16:10 than 16:9. Could that be part of the problem? I believe 1280x768 is a pretty common resolution for widescreen panels though.

    System info: Windows XP w/ SP2, MP 1.0.0.0 RC1 (ReVision skin), Hauppauge PVR-250 + PVR-500 with latest drivers, Asus M2NVP-VM mobo with latest NVIDIA drivers.

    Any help is appreciated.

    Thanks,

    Jeroen
     

    asd7000

    Portal Pro
    May 17, 2008
    412
    23
    jup 1.0.0.0RC2 fixed that problem for me too. Another option is chance codec from MPV to PowerDVD or something else!
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    badboyxx TV card is listed as unknown in TV-server config General 4
    G MP 1.21 TVserver race condition when cant delete recording triggered by episode management General Support 0
    T How do I install the Kodi TVServer plugin General 8
    C Manual Control doesn't work anymore inside TVServer General Support 4
    I TVServer issues Installation, configuration support 2
    T Things I wish I had known setting up and first using TVServer for good reception of DVB-T Installation, configuration support 0
    krebbi "TvServer: Failed to execute remote TV server operation" - Stream doesn't start General Support 2
    regeszter MPExtended (Mobil access) for MP2 only for TV access WebService and Mobile Access 46
    M Collection was modified; enumeration operation may not execute General Support 0
    C Can the XmlTv Plugin handle 600+ channels? General 3
    N [Approved] [MP2-198-200] Playlist handling patches Submit: Code Patches 4
    gpnash Ceton eth6 now handling 6 tuners Installation, configuration support 7
    C How well can MediaPortal handle 10,000+ recordings? MediaPortal 1 Talk 3
    Alberto83 [Finished] [MP2-752] Improve recording handling MediaPortal 2 34
    E [Pending] Handling Multifile Cue Submit: code patches (MediaPortal/TV-Server/etc.) 56
    H MP 2.2 - Rework thumbnail handling Archive 43
    Top Bottom