TvService dies on hybrid group creation (1 Viewer)

antcodd

Portal Member
November 21, 2007
9
1
New Zealand New Zealand
TV-Server Version: 1.0 RC4
MediaPortal Version: 1.0 RC4
MediaPortal Skin: Blue3 Wide
Windows Version: Windows Vista Home Premium SP1
CPU Type: AMD Athlon64 3500+
HDD: Western Digital 250GB
Memory: 2GB PC2400 DDR
Motherboard: Asus A8N SLI Deluxe
Video Card: ATI Radeon HD4850
Video Card Driver: Catalyst 8.11
Sound Card: Realtek ALC850 AC'97
Sound Card AC3: no AC3
Sound Card Driver: 6.0.1.6285
1. TV Card: Hauppauge HVR-900 revision B2C0
1. TV Card Type: DVB-T/Analog hybrid
1. TV Card Driver:
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
h.264 Video Codec: Cyberlink PowerCinema 6
Satelite/CableTV Provider: Freeview | HD New Zealand
HTPC Case:
Cooling:
Power Supply:
Remote:
TV:
TV - HTPC Connection:

Hi, now that we're getting so close to 1.0 final I thought I'd finally report bugs that I thought would be found by someone else and reported :p

When I create or remove the hybrid card group for my Hauppauge HVR-900 the TvService dies immediately. I have tried this with a clean install. This happened in RC3 from what I remember too.

Please find attached logs straight from a clean install with only creating the hybrid group. I can download the source and find the line where the exception is thrown if necessary (I have Visual C# 2008 Express installed).

The TvService also died the first time I opened Scheduled Recordings with nothing set up. I can't reproduce this so it must only happen on clean install (the logs for that are gone). I'll try reinstalling the TVEngine and see if it does it again.

Regards,
Anthony

ps: looks like there is a ToString() mistake with the last line of tv.log: System.Threading.ThreadExceptionEventArgs doesn't look very helpful (presumably it is supposed to show something more helpful).
 

antcodd

Portal Member
November 21, 2007
9
1
New Zealand New Zealand
I did some testing with the TvService dieing when opening Scheduled Recordings. It seems to occur exactly once the first time the tree item is selected from Recording Settings to Scheduled Recordings, regardless of whether it is first run or if the tv card is set up or scheduled recordings being imported from RC3. This would explain why every time I try a new release it seems extremely buggy then seems fine because both of these bugs only occur once in normal set up (as I am unlikely to change hybrid groups).

Perhaps the initial configuration of the scheduled recordings is not happening right but it gets far enough to work fine once the settings are initialized or something?

I'm posting this bug here as the symptoms and error messages are almost identical. Please find the logs attached from another clean install.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
T [solved] failed to-startup tvservice Installation, configuration support 1
D TVService Probleme - getCards() Installationsprobleme? 1
Requiem TVService stops Television (MyTV frontend and TV-Server) 4
Pat Clark TVservice can't seem to initialize HDHomeRun channels Television (MyTV frontend and TV-Server) 0
Golf4 Client verliert immer wieder die Verbindung Allgemeines Support- und Diskussionsforum 4
Mainhattan Olli [solved] MediaPortal 2.2.1 und die aufzunehmenden Sendungen Allgemeines Support- und Diskussionsforum 6
Kolbenschieber Wenn die HTPC-Uhr rückwärts läuft... Tipps, Tricks & Tutorials 0
Lehmden Media-Buddy, die "eierlegende Wollmilchsau" unter den Medien-Tools. 3rd Party Software 83
II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
muellinger MePo 1.19 und PowerDVD 12 für Blu-Ray. Tips für die Konfiguration benötigt Video & DVD 5
olli14 Inhalt der Moving Pictures Datenbank in die Plex Datenbank kopieren MediaPortal Café 69
BlueMax1916 Problems with MP1 client process dying when resuming from standby, probably MovingPictures related Moving Pictures 2
BlueMax1916 Problems with MP1 client dying after resuming from standby General Support 2
Top Bottom