Unable to delete unseen recording while TV runs in the background (1 Viewer)

megahorst

Super User
  • Team MediaPortal
  • Super User
  • July 8, 2006
    879
    259
    Germany Germany
    Country flag
    MediaPortal Version: 1.19.0

    Description
    It is not possible to delete an unseen recording while TV is running in the background.
    The used Skin is ARES

    Steps to Reproduce:
    Behaviour while TV is not running in the background:

    1. select an unseen tv recording
    2. press "0" on the remote to trigger deletion
    3. MePo asks if the unseen recording should realy be deleted

    Behaviour while TV is running in the background:
    1. select an unseen tv recording
    2. press "0" on the remote to trigger deletion
    3. The dialog with the question delete / not delete is not shown and deletion is not triggered
    4. press stop on the remote to end the TV in the background
    5. press again "0" on the remote to trigger deletion
    6. Now MePo asks if the unseen recording should realy be deleted
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,016
    1,248
    Southampton
    United Kingdom United Kingdom
    Country flag
    It is not possible to delete an unseen recording while TV is running in the background.The used Skin is ARES
    I tried to reproduce your problem using a variety of setups. I checked all combinations of the following:

    (1a) MP 1.18 (my production system).
    (1b) MP 1.20pre (a build from several days ago; not the most-recent build).

    (2a) The "Ares" skin.
    (2b) My own "ClassicWide" skin (used on my production system).

    (3a) The Ortek/Hama remote control using the "Centarea HID" plus AutoHotKey script, with my customised config file for the remote control (used on my production system).
    (3b) Standard MCE RC6 remote control using "General HID" with the default "Classic" configuration.

    In all cases, the test gave the expected result -- an unwatched recording could be deleted whether or not live TV was playing.

    I notice from your system specs that you are using TV-Remote via HDMI-CEC to USB bridge from pulse-eight.com. I have never used such a setup, and so cannot suggest what might be wrong. I think that you will need to employ the usual process of looking for clues:

    (1) Did it ever work as expected?
    (2) If it did, when did it stop working correctly?
    (3) What had you changed when it stopped working? (Windows updates? New version of MP? Installed new software [Chrome, iTunes, ...]? Changed settings?)

    -- from CyberSimian in the UK
     

    joEhSuper

    MP Donator
  • Premium Supporter
  • June 2, 2011
    758
    319
    Austria Austria
    Country flag
    It is not possible to delete an unseen recording while TV is running in the background.
    All I can say is that I can confirm this (using PureVisionHD). I'm not at home - so I can't test right now. If I remember right (very unsure...): could it be, that it only happens when client is not same PC as TV-Server? :unsure::unsure::unsure: So maybe a problem relatet to permissions?
     

    megahorst

    Super User
  • Team MediaPortal
  • Super User
  • July 8, 2006
    879
    259
    Germany Germany
    Country flag
    Can you reproduce using F9 and delete menu?
    It's the same. The dialog delete? Yes/no is not shown and the show is not deleted if TV is running in the background. If TV is not running, everything is fine.

    Gesendet von meinem SM-G965F mit Tapatalk
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    It's the same. The dialog delete? Yes/no is not shown and the show is not deleted if TV is running in the background. If TV is not running, everything is fine.

    Gesendet von meinem SM-G965F mit Tapatalk
    Which skin do you use?
     

    megahorst

    Super User
  • Team MediaPortal
  • Super User
  • July 8, 2006
    879
    259
    Germany Germany
    Country flag
    Ares

    Gesendet von meinem SM-G965F mit Tapatalk
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    It's the same. The dialog delete? Yes/no is not shown and the show is not deleted if TV is running in the background. If TV is not running, everything is fine.

    Gesendet von meinem SM-G965F mit Tapatalk
    I can not reproduce. I can delete the unwatched recording from context menu.
     

    AlfredO

    MP Donator
  • Premium Supporter
  • August 26, 2009
    32
    2
    Weinheim
    Germany Germany
    Country flag
    same here as megahorst.
    MP 1.18 server and client on different systems
    Skin: Default and StreamedMP
    The dialog delete? Yes/no is not shown and the show is not deleted if TV is running in the background. If TV is not running, everything is fine. It's no difference between seen and unseen recordings.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R [solved] Unable to delete single recording General 2
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    M Unable to map virtual sent keys in the input device management General 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    morpheus_xx Was this spam? I deleted it... Online Facilities 4
    P Recordings not showing up unless re-imported and not possible to delete General 0
    R [solved] MP will not delete recordings that are on NAS Television (MyTV frontend and TV-Server) 23
    N [Finished] [MP2-781] Enable one-click deletion of grouped TV recordings MediaPortal 2 70
    G MP 1.21 TVserver race condition when cant delete recording triggered by episode management General Support 0
    N [Finished] MP2-803 - Delete full series doesn't work when viewing a program in the extended schedule screen MediaPortal 2 12
    N [solved] Cannot delete recordings from remote client MediaPortal 2 32
    G [solved] How do you delete media in Mediaportal2? General 14
    R Mediaportal will not delete Recorded TV items that do not exist MediaPortal 1 Talk 0
    Frans Nijhuis [further infos missing] Deleting all TV channels and all channel groups in "MP 2 TV configuration" fails 2.2 Archive 1
    H [fixed] Series programming/deleting 2.2 Archive 1
    Similar threads

























    Top Bottom