Updating mpe1 and dependencies

Discussion in 'Skins and Plugins Installer (MPEI)' started by cane, April 17, 2013.

  1. cane
    • Premium Supporter

    cane MP Donator

    Joined:
    October 20, 2007
    Messages:
    129
    Likes Received:
    24
    Location:
    Zagreb
    Ratings:
    +26 / 0
    Home Country:
    Croatia Croatia
    Show System Specs
    I'm trying to update my installer in MpeMaker to work with MP 1.3.0. But I'm unable to change min and max version numbers, the options are grayed out.
    Looked in wiki and searched forum but couldn't find any solution. And is there somewhere in wiki list of versions and "release" names - for instance MP 1.2.3 equals version 1.1.6.27644??


     

    Attached Files:

    • mpemaker.jpg
      mpemaker.jpg
      File size:
      60 KB
      Uploaded:
      April 17, 2013
      Views:
      124
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Remove and Re-add the MediaPortal Dependency, it will automatically use the correct API version (which is independent from the actual release version) - depending on which MP version you are creatring the package. so for an MP 1.3 compatible mpe you need to create it with MP 1.3 installed.
    If your plugin has DLLs it will search them for the compatiblity attributes and automatically add dependencies.
     
    • Like Like x 1
  4. cane
    • Premium Supporter

    cane MP Donator

    Joined:
    October 20, 2007
    Messages:
    129
    Likes Received:
    24
    Location:
    Zagreb
    Ratings:
    +26 / 0
    Home Country:
    Croatia Croatia
    Show System Specs
    Thanks for help offbyone.
    In the end I started from new package, I got some other errors while trying to update old package.
    One thin still puzzles me. In my dll in AssemblyInfo.cs I have [assembly: CompatibleVersion("1.2.100.1","1.1.6.27644")], and the plugin works with MP 1.3.0.
    But in MpeMakerit still says <Message>requires MediaPortal version 1.1.6.27644 to 1.1.6.27644.</Message>.
    Why it doesn't say from 1.1.6.27644 to 1.2.100.1??
     
  5. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    That's just the default message that is inserted there as guide for the User. It does not check any DLLs at that point (since you might not have added all yet), but as you can edit it - just write what MP version you suggest to the user.
     
    • Like Like x 1
  6. cane
    • Premium Supporter

    cane MP Donator

    Joined:
    October 20, 2007
    Messages:
    129
    Likes Received:
    24
    Location:
    Zagreb
    Ratings:
    +26 / 0
    Home Country:
    Croatia Croatia
    Show System Specs
    Thanks for clarification offbyone.
     
  7. kesar
    • Premium Supporter

    kesar MP Donator

    Joined:
    August 4, 2008
    Messages:
    154
    Likes Received:
    7
    Location:
    Warsaw
    Ratings:
    +7 / 0
    Home Country:
    Poland Poland
    Show System Specs
    Hi,
    I posted this message in General Support section, but have no answer yet, so I thought this might be the right place.

    I just installed 1.3 final and find out that so many plugins are still not compatible that using it is not so fun anymore.
    I reinstalled MP to 1.2.3 version and suddenly can't install Rockstar anymore. I get "Dependency check error" window and inside "Rockstar dependencies" information that min and max version of MP is 1.1.6.27644 (?#$#%!$). It also says that "current version" of MP is the above (1.1.6.27644).

    Did again full (%$!@%!$%) uninstall of MP and reinstalled again with the same effect. I cleaned the regsitry, trying to find this number and removed all things with "team media portal" in names. I also deleted all files of MP. Nothing has changed, so I am lost a little. Searched all forum for some tips - still no clue.

    Additionally I'm affraid it might also impact my other plugins.
    The same goes with InfoService.
    My IRSS version seems incompatible suddenly.

    So something is really messed up with the latest 1.3. And - sorry - the testers did a bad job naming it FINAL (&$#%@^$). Also some files still say it's alpha.

    So if any one could direct me, what should I do. Please help!
     
    Last edited: April 21, 2013
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!