Upgrade 1.26 Problem (1 Viewer)

technoweary

MP Donator
  • Premium Supporter
  • June 14, 2015
    158
    10
    43
    Great Britain (UK) Great Britain (UK)
    Country flag
    Hi everyone
    I hope you are all well
    Wondering if anyone has a idea about .Net4 and the new 1.26 MediaPortal update
    The update told me it could not complete the update from 1.23 to 1.26 due to .Net4 being required
    I searched and downloaded .Net 4.8, (the only option available) but the update is not happy with this and refused again
    Unfortunately I could not resume the original MediaPortal 1.23 either so resorted to a complete re-install, but no luck as the latest version still asks for .Net4
    Having re-installed Win7 I upgraded and tried win10. MediaPortal 1.26 was happy with this but I discovered that EPG Collector / XmlTv cannot be scheduled in the Win10 Task Scheduler under Win10 as the Collecter .exe will not start
    So, (17 hours later!), Here I am with no Media Centre and wondering what the next best step is?
    Any tips or suggestions would be most appreciated
    Regards to all
    TW
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,188
    1,343
    Southampton
    United Kingdom United Kingdom
    Country flag
    I discovered that EPG Collector / XmlTv cannot be scheduled in the Win10 Task Scheduler under Win10 as the Collecter .exe will not start
    So, (17 hours later!), Here I am with no Media Centre and wondering what the next best step is?
    Instead of "EPG Collector" or "XmlTv", use the EPG that is broadcast with the TV signals and processed by "TV Server". There are separate systems for DVB-T/T2 and DVB-S/S2. Refer to this page in the Wiki.

    Aside: apparently, Microsoft changed an XML version number in the task definition file, and tools that still specify the old version number do not work properly. See this post. I don't know whether this applies to "EPG Collector" or "XmlTv", as I have never used those tools.

    -- from CyberSimian in the UK
     

    technoweary

    MP Donator
  • Premium Supporter
  • June 14, 2015
    158
    10
    43
    Great Britain (UK) Great Britain (UK)
    Country flag
    Instead of "EPG Collector" or "XmlTv", use the EPG that is broadcast with the TV signals and processed by "TV Server". There are separate systems for DVB-T/T2 and DVB-S/S2. Refer to this page in the Wiki.

    Aside: apparently, Microsoft changed an XML version number in the task definition file, and tools that still specify the old version number do not work properly. See this post. I don't know whether this applies to "EPG Collector" or "XmlTv", as I have never used those tools.

    -- from CyberSimian in the UK
    Hi Cybersimian, hope you are well
    I'm using EPG Collector since the DVB-S EPG data channel went away, and as far as I know that is the current situation. To be honest it was such a stress-out trying to find out why the DVB-S EPG disappeared I do not wish to go back there!

    I remember you helped out during that debacle!

    I'm wondering what version of MediaPortal is prior to the .Net4 situation. Windows 7 is perfectly OK running MediaPortal 1.23 so I have no problems going back to an older version.
    I think my best option is to make my way back through the versions until the .Net issue goes away. I wish I had not fiddled around now

    Thanks for your help on this. If you do know what the latest version to run in Win7 is I would appreciate the info
    Regards
    TW
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,188
    1,343
    Southampton
    United Kingdom United Kingdom
    Country flag
    I'm using EPG Collector since the DVB-S EPG data channel went away, and as far as I know that is the current situation.
    I had forgotten about that o_O. I don't have satellite TV, so I cannot comment from personal experience, but I would have expected there to have been a continuous series of complaints from MP satellite users if this was a permanent problem (rather than a temporary blip). Did you see this post from Ronski?

    I'm wondering what version of MediaPortal is prior to the .Net4 situation.
    I have not yet installed MP 1.26, but MP 1.25 is working well on 64-bit Windows 7. I don't know how Net4 relates to MP versions. The problem may be with Net4 on your system, and not a problem with a specific version of MP.

    -- from CyberSimian in the UK
     

    technoweary

    MP Donator
  • Premium Supporter
  • June 14, 2015
    158
    10
    43
    Great Britain (UK) Great Britain (UK)
    Country flag
    I had forgotten about that o_O. I don't have satellite TV, so I cannot comment from personal experience, but I would have expected there to have been a continuous series of complaints from MP satellite users if this was a permanent problem (rather than a temporary blip). Did you see this post from Ronski?


    I have not yet installed MP 1.26, but MP 1.25 is working well on 64-bit Windows 7. I don't know how Net4 relates to MP versions. The problem may be with Net4 on your system, and not a problem with a specific version of MP.

    -- from CyberSimian in the UK
    At the moment I am trying to get MediaPortal installed on Windows 7
    I'll take another look at the EPG Grabber for DVB-S FreeSAT if I get MediaPortal up and running on Win7

    Working on this right now and may be getting somewhere so I'll provide details as I hope the info is useful to others

    The problem originates with MediaPortal on Windows 7 "Has Stopped Working" error and the MediaPortal Installer cannot install without .NET4
    Windows 7 started out with .NET3.5 I think
    If you download and install .NET4 the MediaPortal installer will give "MediaPortal Installer has Stopped Working" error
    I had the same trouble with MediaPortal ver 1.22 to 1.26 that the systems will not install without .NET4 and the MediaPortal installer immediately "Stopped Working" upon install
    However, searching discovered that .NET 4.8 will overcome this known issue, BUT
    .NET4.8 will not install into Win7 and gets all grumpy about Root Certificates, However
    On the Stack Overflow site a fix is suggested by Downloading the certificate from Microsoft and installing it on Windows 7
    This did allow .NET4.8 to install and after that I had no problems installing MediaPortal 1.26 onto Windows 7 SP1

    I've a lot more to do to get it all up and running so hopefully I can confirm it all went well later

    Hope this is useful

    Regards
    TW
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    G 1.27.0 Problem with One Button Music after upgrade to MP 1.27.0 pre General Support 15
    A [solved] DiseqC problems after upgrade to 1.25 General Support 14
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    L MP2 - V2.3 Troubles upgrading from MP2 2.2.3 to 2.3 General 0
    B 1.26.0 Error Upgrading Data Base (FanArtHandler log) on Holiday implemention ... MP 1.26 Pre Release Fanart Handler 6
    ajs [fixed] 5044: Upgrade NSIS to actual Version MediaPortal 1 21
    morpheus_xx [Finished] "What's New" plugin for MP2 upgrades MediaPortal 2 20
    A [solved] Upgraded HTPC. Cannot install MP anymore Installation, configuration support 3
    DHosein 1.25 Upgrade and movie covers/backdrops General Support 9
    cerberus Erfahrungsbericht Upgrade Win 10.1909 MP 1.24 Installationsprobleme? 2
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    F [solved] Could not find the MediaPortal.Common.Logging.ILogger service after upgrading from 2.2.2 to 2.2.3 General 2
    T Upgrading HTPC for 4K General 5
    joecrow Online Videos fails after MP 1.23 upgrade. 1.23 Pre Release 37
    johns11 Multiple programs responding to IR commands since upgrade from 1.12 Remotes 3
    D PC rebuild & MP2 upgrade - how to preserve database and settings? General 1
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    R [solved] TV Server after upgrading from MP 1.18 to MP 2.2 General 14
    caveman Upgrade from Mediaportal 1.X to 2.2 General 6
    B Is it Feasible to upgrade a working Mediaportal 1.20.100.0 to V2? Newcomers Forum 1
    T [further infos missing] MP2.2 client crashes on open (after upgrade) 2.2 Archive 34
    J Things I noticed with MP2.2 almost within minutes after upgrading it over the 2.13 version General 6
    D Upgrade to MP2.2 pre release fails with failure to start service 2.2 Archive 32
    nominefi tuning problem TV-Server 0

    Similar threads

    Top Bottom