Version 2.8.0 beta | Page 3

Discussion in 'ASIO music player' started by Symphy, January 26, 2014.

  1. Symphy
    • Team MediaPortal

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    494
    Likes Received:
    132
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +152 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    @Helios61

    Thanx for the file!
    Is this the only file that won't play in exclusive/event on your LG TV device? I have learned there are problems with this combi, but it doesn't seem to be related to the type of file played. What happens if you play a plain old mp3 in exclusive/event?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Hi @Symphy

    .mp3 file doesn't work -> Log_MP3_not working.rar
    .flac 5.1 HiRes Blu-Ray audio rip is working fine -> Log_5.1flac_BRAudio_working.rar
     

    Attached Files:

  4. Symphy
    • Team MediaPortal

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    494
    Likes Received:
    132
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +152 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Ok i think i got it. Problem is in the baswasapi.dll.
    MP comes with the beta dll 0.0.0.19. Problem does not occur when using the newer 2.4.0.2 and bass.net 2.4.10.3.
    This means we'll have to wait for a MP update that includes the most recent bass library...
     
  5. Wiedmann

    Wiedmann Portal Pro

    Joined:
    June 22, 2007
    Messages:
    107
    Likes Received:
    12
    Ratings:
    +27 / 3
    Home Country:
    Germany Germany
    Oh, it's always good to have the correct documentation... Thanks.
    (Sorry, don't use/have intellisense in my plain text editor)

    Ah, this code works sometime. It seams, Event mode is only working, if freq is set to the default mixer sampling rate:
    Code (Text):
    1.                 int wasapidevice = Bass.BASS_GetDevice() - 1;
    2.                 info = BassWasapi.BASS_WASAPI_GetDeviceInfo(wasapidevice);
    3.                 _wasapi = new BassWasapiHandler(wasapidevice, true, false, true, info.mixfreq, 2, 0f, 0f);
    4.  
    Of course, doing this isn't the reason we are using WASAPI ;-) There must be some other way.

    I know.. Just to prevent "This application stopped working" without a lot of typing for a test *g*
     
  6. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Maybe @hwahrmann can help!
     
  7. Symphy
    • Team MediaPortal

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    494
    Likes Received:
    132
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +152 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Yep that's it! Problem disappears when using the latest basswasapi.dll
     
  8. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,207
    Likes Received:
    6,173
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,156 / 9
    Home Country:
    France France
    Show System Specs
    There is a branch with latest bin : MP1-4350 maybe it will help ? :)
     
  9. Symphy
    • Team MediaPortal

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    494
    Likes Received:
    132
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +152 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Thanx for your reaction.
    Yep as soon as that ends up in a MP1 release our problem will probably be solved:)
    Maybe it's an idea to add support for exclusive/eventdriven mode in standard MP as well. Would only require small changes.
     
    • Thank You! Thank You! x 2
  10. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,207
    Likes Received:
    6,173
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,156 / 9
    Home Country:
    France France
    Show System Specs
    If you can provide a patch :)
     
    • Like Like x 1
  11. Symphy
    • Team MediaPortal

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    494
    Likes Received:
    132
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +152 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Deal! :)
     
    • Thank You! Thank You! x 2
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!