[solved] Video playback only successful after second attempt when returning from standby (1 Viewer)

AlunS

Portal Pro
October 28, 2011
93
10
Home Country
Ireland Ireland
I'm having a strange one here ... it seems to have started after getting a new Sony 4k TV, and manifests itself by refusing to start any video playback, no matter if it's live TV, recorded TV or a movie/TV show the first time I attempt it after returning from standby.

At the first attempt there's a slight pause, the screen flickers briefly, sometimes you hear a very brief bit of sound, and then it returns to whatever menu you used to start the video playback.

Then at the second attempt it works fine, and all subsequent attempts work fine also, until it gets put into standby again.

It's a Pentium G4600 based system with intel HD Graphics 630 running Windows 10, all drivers etc. up to date.

I've included debug logs which cover attempting to play a recorded TV program immediately after resume. It's from when I was running v 1.26, but have just installed 1.27 and it's the same.
 

Attachments

  • MP Logs.zip
    50.8 KB

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,901
    1,822
    Southampton
    Home Country
    United Kingdom United Kingdom
    refusing to start any video playback, no matter if it's live TV, recorded TV or a movie/TV show the first time I attempt it after returning from standby.
    I looked at your log file, but as usual the log file is unintelligible gobbledegook. :(
    I don't know what the problem is, but some suggestions:

    (1) Are you using sleep or hibernation? There is a line in the log file that specifically mentions hibernate, but that may be misleading, If you are using hibernation, it might be worth trying sleep and seeing if that makes a difference.

    (2) There are some entries in the log file that suggest that you are trying to use Teletext subtitles. I don't recollect seeing those entries in my log files, so I would suggest that you use "TV Server Config" and "MP Config" to disable all subtitles, and seeing if that makes a difference.

    (3) Are you sleeping/hibernating the system with MP still running? If you are, I would suggest that you close MP and exit to the Windows desktop before sleeping/hibernating the system. Remember that if you enable the "MPTray" utility (in "MP Config"), you can start MP from the Windows desktop by pressing the "green marble" button on your MCE RC6 remote control (you don't need to use a mouse). I always exit to the Windows desktop before hibernating my system.

    -- from CyberSimian in the UK
     

    AlunS

    Portal Pro
    October 28, 2011
    93
    10
    Home Country
    Ireland Ireland
    I'm definitely using sleep, not hibernation and I've also disabled what Windows 10 calls "hybrid sleep".

    I am putting the system into sleep with MP still running, but not actively playing anything. It's usually either in the EPG or main menu when I do it.

    If it helps, if immediately after resuming instead of trying to start watching something I stop and restart MP it works fine. Having to do that every time, or alternatively having to drop back to Windows before hibernating which would amount to the same thing would seriously reduce the WAF, which is at an all time low anyway as it is.

    I'll give the subtitles a go and report back but I'm not hopeful.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,578
    1,927
    Home Country
    Germany Germany
    Try unchecking the setting shown in the attached screenshot, if ticked. For further info see here.

    314336_config1.jpg
     

    AlunS

    Portal Pro
    October 28, 2011
    93
    10
    Home Country
    Ireland Ireland
    Wow, thanks! That worked a treat. I'd always wondered what that setting did, but as it was on by default and didn't seem to be relevant to my issue I left it alone.

    I wonder also if it has something to do with the problems I am having getting refresh rate changing to work. I get a similar phenomenon when I attempt a refresh rate change, i.e. a quick flash of a black screen and a chirp from the audio. Interesting.

    EDIT: Just tried it and refresh rate change works perfectly now too. If that setting can cause so many problems, maybe it should be set to off by default? I searched for weeks trying to find a solution to both these problems and was almost ready to give up, I owe you a virtual beer!!
     
    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,578
    1,927
    Home Country
    Germany Germany
    I have asked a couple of times to have the default for that setting to be set disabled, but clearly it is not a problem for everyone and perhaps there are negative implications though I have never experienced any. I and a couple of others had this and reported it on the upgrade to MP 1.21 and there have been a handful of incidences since. Interesting that your problem seems to have come with the change of display, maybe a clue there for the devs.
    Good to hear everything is working again.:)

    P.S. If we ever get out of lockdown I will take you up on that virtual beer.(y)
     

    fredco

    Portal Pro
    November 13, 2010
    131
    33
    Home Country
    Netherlands Netherlands
    @joecrow: Thanks a million for this! I have had this weird issue for ages and with one simple uncheck, it's gone! Never understood what the option was for, like AlunS. And I still don't...
    It's probably something else, but when starting a video the audio doesn't start IMMEDIATELY along with the video. So maybe a second or two are silent. Also quite annoying, but not as much as the video starting and stopping. I use the internal video player for playback with hardware acceleration Native in LAV-Filters.
     

    Chubler

    Portal Member
    July 14, 2009
    46
    25
    Home Country
    Australia Australia
    Thanks joecrow (+1 rep),

    Been struggling with this issue for a while now. Your suggestion has won me some points with the family as we like to be green and have the system hibernate when not in use, but the whole exiting Mediaportal and restarting on every session was more annoying than the problem. Now it is working as it should.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,901
    1,822
    Southampton
    Home Country
    United Kingdom United Kingdom
    when starting a video the audio doesn't start IMMEDIATELY along with the video.
    One possible cause is that your audio device is trying to save energy by powering-down the digital-to-analogue converters when there is no signal. This is known as the "silent stream bug". My HTPC behaves like this (HDMI audio connection), although I don't know whether it is the Nvidia audio device in the graphics card, or my Sony TV. It makes the MP sound effects unusable, as most of the sound effect is missing (I hear only the tail-end of the sound effect, so I have disabled them).

    I believe that there are several tools that keep the digital-to-analogue converters powered up by continuously sending a small signal that is too quiet to hear. Names that come to mind are:
    Note: I have no personal experience of any of these tools, so use with caution.

    -- from CyberSimian in the UK
     

    fredco

    Portal Pro
    November 13, 2010
    131
    33
    Home Country
    Netherlands Netherlands
    Thanks @CyberSimian! I delved deeper into this issue and especially the "Silent Stream Bug" you mentioned. I downloaded different pieces of software that claimed to do like you said: keeping the DA-convertors "alive" by sending a non-audible signal periodically. Turned out this was NOT the thing happening in my AV-receiver.
    While checking around the different MP-settings and the LAV Audio-settings I noticed when starting a video I heard a relay switching inside the AV-receiver. That got me thinking about some kind of processing that was initiated inside the receiver. It looked like some decoding was started when a video stream was fed to the receiver. That set me on the right track: I use bitstreaming in my LAV-filters, meaning all audioformats like DTS-HD are fed into the receiver as a series of 0's and 1's. It's then up to the receiver to decode this stream into the appropriate format and switch the receiver into that mode. That exactly causes the delay! It needs some time for that!
    Of course I immediately turned off bitstreaming and voila: immediate sound with video.
    Thanks for your insights. It eventually pointed me to the solution. Maybe this might be useful for someone with a similar setup.
     

    Users who are viewing this thread

    Top Bottom