VODServer - Watch internet streams as TV channels (1 Viewer)

Nervesagent

Portal Pro
February 26, 2014
150
19
40
Denmark Denmark
i got vodserver to work with ampersand in the url by replacing the & in the input value by %26
i still have a lot of glitches when recoding the network stream (rtsp over gb ethernet).. its probably a ffmpeg output setting. ill post the log tomorrow.
 

Nervesagent

Portal Pro
February 26, 2014
150
19
40
Denmark Denmark
So after trying everything to get my Fritz DVB-C streams to work in MP1.11 I think VODSERVER may be the solution, BUT.. like I said in my reply before FFMPEG has a problem decoding/encoding the stream..(It's choppy as hell!)
Can anybody help me by analyzing this log:

Code:
[2015-05-13-17:35:36.312][INFO ][qtp556529265-23 - /channel?id=HBO][VODServiceHa
ndler] /channel /play [SERVICE REQUEST START]
[2015-05-13-17:35:36.332][INFO ][qtp556529265-23 - /channel?id=HBO][CommandRunne
rService] /channel /play Executing command: ffmpeg -threads 4 -i "rtsp://192.168
.1.65:554/?freq=330&bw=8&msys=dvbc&mtype=256qam&sr=6900&specinv=0&pids=0,16,17,1
8,20,2900,2901,2911,3001" -vcodec mpeg2video -s 720x576 -r 25 -flags cgop+ilme -
sc_threshold 1000000000 -b:v 2M -maxrate:v 2M -bufsize:v 1.4M -acodec mp2 -ac 2
-b:a 128k -f mpegts -
ffmpeg version N-56892-ge1f8184 Copyright (c) 2000-2013 the FFmpeg developers
  built on Oct  4 2013 18:01:41 with gcc 4.8.1 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aa
cenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavp
ack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil  52. 46.100 / 52. 46.100
  libavcodec  55. 34.100 / 55. 34.100
  libavformat  55. 19.100 / 55. 19.100
  libavdevice  55.  3.100 / 55.  3.100
  libavfilter  3. 88.101 /  3. 88.101
  libswscale  2.  5.100 /  2.  5.100
  libswresample  0. 17.103 /  0. 17.103
  libpostproc  52.  3.100 / 52.  3.100
[mp1 @ 003dd840] Header missing
  Last message repeated 3 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 2 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 1 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 2 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
[mp2 @ 03cf2800] Header missing
[mp1 @ 003dd840] Header missing
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 2 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 1 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 1 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 2 times
[mpeg2video @ 03c31060] Invalid frame dimensions 0x0.
[mp1 @ 003dd840] Header missing
  Last message repeated 156 times
RTP: missed 354 packets
[mp1 @ 003dd840] Header missing
  Last message repeated 1 times
[rtsp @ 003dfac0] PES packet size mismatch
[mp1 @ 003dd840] Header missing
  Last message repeated 44 times
[rtsp @ 003dfac0] decoding for stream 0 failed
[rtsp @ 003dfac0] Could not find codec parameters for stream 0 (Audio: mp1 ([6][
0][0][0] / 0x0006), 0 channels, s16p): unspecified frame size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, rtsp, from 'rtsp://192.168.1.65:554/?freq=330&bw=8&msys=dvbc&mtype=256
qam&sr=6900&specinv=0&pids=0,16,17,18,20,2900,2901,2911,3001':
  Metadata:
  title  : SatIPServer:1 2
  Duration: N/A, start: 22267.377122, bitrate: 256 kb/s
  Program 19081
  Metadata:
  service_name  : RTL 4
  service_provider: Ziggo
  Program 19082
  Metadata:
  service_name  : RTL 5
  service_provider: Ziggo
  Program 19083
  Metadata:
  service_name  : RTL 7
  service_provider: Ziggo
  Program 19084
  Metadata:
  service_name  : MTV
  service_provider: Ziggo
  Stream #0:1: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv),
720x576 [SAR 64:45 DAR 16:9], max. 15000 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
  Stream #0:2(dut): Audio: mp2 ([4][0][0][0] / 0x0004), 48000 Hz, stereo, s16p
, 256 kb/s
  Stream #0:0(dut): Audio: mp1 ([6][0][0][0] / 0x0006), 0 channels, s16p
  Program 19085
  Metadata:
  service_name  : NPO Politiek
  service_provider: Ziggo
  Program 19086
  Metadata:
  service_name  : Shorts TV
  service_provider: Ziggo
  Program 19087
  Metadata:
  service_name  : 192TV
  service_provider: Ziggo
[mpeg2video @ 05b323a0] impossible bitrate constraints, this will fail
Output #0, mpegts, to 'pipe:':
  Metadata:
  title  : SatIPServer:1 2
  encoder  : Lavf55.19.100
  Stream #0:0: Video: mpeg2video, yuv420p, 720x576 [SAR 64:45 DAR 16:9], q=2-3
1, 2000 kb/s, 90k tbn, 25 tbc
  Stream #0:1(dut): Audio: mp2, 48000 Hz, stereo, s16, 128 kb/s
Stream mapping:
  Stream #0:1 -> #0:0 (mpeg2video -> mpeg2video)
  Stream #0:2 -> #0:1 (mp2 -> mp2)
Press [q] to stop, [?] for help
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
[2015-05-13-17:35:41.948][INFO ][qtp556529265-23 - /channel?id=HBO][CommandRunne
rService] /channel /play Opening response output stream
frame=  39 fps=0.0 q=15.5 size=  319kB time=00:00:01.48 bitrate=1765.2kbits/
frame=  64 fps= 60 q=30.8 size=  655kB time=00:00:02.48 bitrate=2165.0kbits/
frame=  80 fps= 49 q=4.7 size=  829kB time=00:00:03.12 bitrate=2175.5kbits/s
frame=  89 fps= 41 q=5.7 size=  929kB time=00:00:03.48 bitrate=2186.4kbits/s
[mpeg2video @ 03c31060] 00 motion_type at 11 25
[mpeg2video @ 03c31060] ac-tex damaged at 28 8
[mpeg2video @ 03c31060] Warning MVs not available
[mpeg2video @ 03c31060] concealing 45 DC, 45 AC, 45 MV errors in P frame
frame=  113 fps= 42 q=14.1 size=  1021kB time=00:00:04.44 bitrate=1884.1kbits/
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
frame=  118 fps= 37 q=15.8 size=  1239kB time=00:00:04.64 bitrate=2187.3kbits/
frame=  130 fps= 35 q=27.6 size=  1388kB time=00:00:05.12 bitrate=2221.0kbits/
RTP: missed 2825 packets
RTP: missed 109 packets
[mpeg2video @ 03c31060] ac-tex damaged at 1 13
[mpeg2video @ 03c31060] concealing 810 DC, 810 AC, 810 MV errors in P frame
[mpeg2video @ 03c31060] 00 motion_type at 36 1
[mpeg2video @ 03c31060] Warning MVs not available
[mpeg2video @ 03c31060] concealing 135 DC, 135 AC, 135 MV errors in B frame
frame=  233 fps= 55 q=4.8 size=  1453kB time=00:00:09.24 bitrate=1287.8kbits/s
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
RTP: missed 184 packets
[mpeg2video @ 03c31060] ac-tex damaged at 20 29
[mpeg2video @ 03c31060] invalid mb type in I Frame at 0 34
[mpeg2video @ 03c31060] ac-tex damaged at 0 35
[mpeg2video @ 03c31060] concealing 315 DC, 315 AC, 315 MV errors in I frame
[mpeg2video @ 03c31060] ac-tex damaged at 40 0
[mpeg2video @ 03c31060] Warning MVs not available
[mpeg2video @ 03c31060] concealing 90 DC, 90 AC, 90 MV errors in B frame
[rtsp @ 003dfac0] PES packet size mismatch
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
frame=  244 fps= 30 q=6.3 size=  2500kB time=00:00:09.68 bitrate=2115.5kbits/s
RTP: missed 2748 packets
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
[mpeg2video @ 03c31060] 00 motion_type at 26 34
[mpeg2video @ 03c31060] concealing 0 DC, 0 AC, 0 MV errors in B frame
[mpeg2video @ 03c31060] concealing 41 DC, 41 AC, 41 MV errors in P frame
frame=  338 fps= 39 q=3.6 size=  2624kB time=00:00:13.44 bitrate=1599.2kbits/s
RTP: missed 196 packets
RTP: missed 13 packets
RTP: missed 70 packets
[mpeg2video @ 03c31060] concealing 597 DC, 597 AC, 597 MV errors in P frame
[mpeg2video @ 03c31060] invalid mb type in B Frame at 28 1
[mpeg2video @ 03c31060] 00 motion_type at 35 16
[mpeg2video @ 03c31060] concealing 270 DC, 270 AC, 270 MV errors in B frame
RTP: missed 13 packets
[mpeg2video @ 03c31060] concealing 604 DC, 604 AC, 604 MV errors in B frame
RTP: missed 15 packets
[mpeg2video @ 03c31060] skipped MB in I frame at 19 10
[mpeg2video @ 03c31060] concealing 450 DC, 450 AC, 450 MV errors in I frame
[rtsp @ 003dfac0] PES packet size mismatch
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
frame=  356 fps= 28 q=15.1 size=  3581kB time=00:00:14.16 bitrate=2071.6kbits/
RTP: missed 2920 packets
RTP: missed 9 packets
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] 00 motion_type at 0 27
invalid mb type in B Frame at 10 2
[mpeg2video @ 03c31060] ac-tex damaged at 0 28
[mpeg2video @ 03c31060] 00 motion_type at 0 3
[mpeg2video @ 03c31060] slice mismatch
[mpeg2video @ 03c31060]  mb incr damaged
1 times  Last message message repeated repeated 1 times
  [mpeg2video @ 03c31060] L00 motion_type at 34 5
ast m[mpeg2video @ 03c31060] eslice mismatch
s  sage  repeated Last 1 message times
[mpeg2video @ 03c31060] 00 motion_type at 0 31
[mpeg2video @ 03c31060] mb incr damaged
[mpeg2video @ 03c31060] 00 motion_type at 0 32
[mpeg2video @ 03c31060] 00 motion_type at 41 9
[mpeg2video @ 03c31060] 00 motion_type at 2 33
[mpeg2video @ 03c31060] 00 motion_type at 0 10
[mpeg2video @ 03c31060] 00 motion_type at 0 34
[mpeg2video @ 03c31060] 00 motion_type at 0 11
[mpeg2video @ 03c31060] slice mismatch
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] 00 motion_type at 0 12
00 motion_type at 1 21
[mpeg2video @ 03c31060] 00 motion_type at 0 13
[mpeg2video @ 03c31060] ac-tex damaged at 1 22
[mpeg2video @ 03c31060] 00 motion_type at 0 14
[mpeg2video @ 03c31060] 00 motion_type at 9 23
[mpeg2video @ 03c31060] 00 motion_type at 0 15
[mpeg2video @ 03c31060] 00 motion_type at 11 24
[mpeg2video @ 03c31060] 00 motion_type at 0 16
[mpeg2video @ 03c31060] 00 motion_type at 23 25
[mpeg2video @ 03c31060] 00 motion_type at 0 17
[mpeg2video @ 03c31060] ac-tex damaged at 8 26
[mpeg2video @ 03c31060] 00 motion_type at 0 18
[mpeg2video @ 03c31060] 00 motion_type at 0 27
[mpeg2video @ 03c31060] 00 motion_type at 15 19
[mpeg2video @ 03c31060] 00 motion_type at 0 28
[mpeg2video @ 03c31060] 00 motion_type at 0 20
[mpeg2video @ 03c31060] 00 motion_type at 0 29
[mpeg2video @ 03c31060] 00 motion_type at 0 21
[mpeg2video @ 03c31060] 00 motion_type at 0 30
[mpeg2video @ 03c31060] 00 motion_type at 11 22
[mpeg2video @ 03c31060] 00 motion_type at 17 31
[mpeg2video @ 03c31060] 00 motion_type at 5 23
[mpeg2video @ 03c31060] 00 motion_type at 8 32
[mpeg2video @ 03c31060] 00 motion_type at 2 24
[mpeg2video @ 03c31060] 00 motion_type at 0 33
[mpeg2video @ 03c31060] invalid cbp 0 at 0 25
[mpeg2video @ 03c31060] 00 motion_type at 0 34
[mpeg2video @ 03c31060] 00 motion_type at 0 26
[mpeg2video @ 03c31060] slice mismatch
[mpeg2video @ 03c31060] concealing 1530 DC, 1530 AC, 1530 MV errors in B frame
RTP: missed 60 packets
RTP: missed 40 packets
frame=  460 fps= 34 q=2.0 size=  3633kB time=00:00:18.32 bitrate=1624.7kbits/s
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] slice mismatch
ac-tex damaged at 14 9
[mpeg2video @ 03c31060] ac-tex damaged at 23 30
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] invalid cbp -1 at 6 31
[mpeg2video @ 03c31060] skip with previntra
slice mismatch
  [mpeg2video @ 03c31060]  slice mismatch
repeated 1 times repeated Last 1 message times
  [mpeg2video @ 03c31060]  invalid cbp -1 at 0 33
Last message r[mpeg2video @ 03c31060] eslice mismatch
pea[mpeg2video @ 03c31060] tinvalid mb type in B Frame at 3 35
ed 1 times
[mpeg2video @ 03c31060] invalid cbp -1 at 2 12
[mpeg2video @ 03c31060] invalid cbp -1 at 1 13
[mpeg2video @ 03c31060] slice mismatch
[mpeg2video @ 03c31060] invalid mb type in B Frame at 21 16
[mpeg2video @ 03c31060] concealing 1305 DC, 1305 AC, 1305 MV errors in B frame
RTP: missed 244 packets
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] ac-tex damaged at 18 27
ac-tex damaged at 39 20
[mpeg2video @ 03c31060] mb incr damaged
[mpeg2video @ 03c31060] invalid mb type in B Frame at 17 10
[mpeg2video @ 03c31060] invalid mb type in B Frame at 15 29
[mpeg2video @ 03c31060] ac-tex damaged at 28 10
[mpeg2video @ 03c31060] ac-tex damaged at 18 34
[mpeg2video @ 03c31060] ac-tex damaged at 40 11
[mpeg2video @ 03c31060] invalid mb type in B Frame at 8 31
[mpeg2video @ 03c31060] ac-tex damaged at 1 12
[mpeg2video @ 03c31060] ac-tex damaged at 8 32
[mpeg2video @ 03c31060] invalid mb type in B Frame at 17 13
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] ac-tex damaged at 27 33
slice mismatch
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] ac-tex damaged at 4 34
ac-tex damaged at 18 15
[mpeg2video @ 03c31060] [mpeg2video @ 03c31060] slice mismatch
invalid cbp 0 at 34 16
[mpeg2video @ 03c31060] skip with previntra
[mpeg2video @ 03c31060] ac-tex damaged at 8 18
[mpeg2video @ 03c31060] ac-tex damaged at 31 19
[mpeg2video @ 03c31060] ac-tex damaged at 31 20
[mpeg2video @ 03c31060] invalid cbp 0 at 34 21
[mpeg2video @ 03c31060] invalid mb type in B Frame at 26 23
[mpeg2video @ 03c31060] ac-tex damaged at 30 24
[mpeg2video @ 03c31060] ac-tex damaged at 16 24
[mpeg2video @ 03c31060] ac-tex damaged at 5 25
[mpeg2video @ 03c31060] ac-tex damaged at 24 27
[mpeg2video @ 03c31060] concealing 1215 DC, 1215 AC, 1215 MV errors in B frame
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
[mp2 @ 03cf2800] Header missing
Error while decoding stream #0:2: Invalid data found when processing input
[2015-05-13-17:35:57.293][WARN ][qtp556529265-23 - /channel?id=HBO][CommandRunne
rService] /channel /play Stream copying finished due to IOException (probably du
e to closed output channel)
[2015-05-13-17:35:57.295][INFO ][qtp556529265-23 - /channel?id=HBO][VODServiceHa
ndler] /channel /play [SERVICE REQUEST END]
[2015-05-13-17:35:57.297][INFO ][qtp556529265-23 - /channel?id=HBO][VODServiceHa
ndler]  [SERVICE REQUEST END]
av_interleaved_write_frame(): Broken pipe
I've reverted back to the "standard VODSERVER" but I've already tried updating FFMPEG before and several output settings I found on the www.
I did edit the vodserver-service-play.xml since the !!OUTPUTARGUMENTS!! (or something) did not get applied from vodserver-service-common.xml.
This is what mine looks like now..
Code:
<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd">
  
   <!-- Definition for the simple service. This service can be invoked as
      http://vodserver:port/play?input=<input>
      <input> can be anything from which ffmpeg can read; a local file, a stream URL, ...
   -->
   <bean id="/play" parent="paramBuilderServiceBase" class="vodserver.service.CommandRunnerService" >
     <property name="command">
       <!-- Command used to retrieve the input and perform the transcoding.
          See the relevant definitions in vodserver-service-commons.xml
          for parameterized values. -->
       <value>ffmpeg -threads 4 -i "!!input!!" -vcodec mpeg2video -s 720x576 -r 25 -flags cgop+ilme -sc_threshold 1000000000 -b:v 2M -maxrate:v 2M -bufsize:v 1.4M -acodec mp2 -ac 2 -b:a 128k -f mpegts -</value>
     </property>
   </bean>
  
</beans>
the last "-" in the ffmpeg command line apparantly pipes to stdout equivalent of vlc, but I've tried replacing that ffmpeg commandline with vlc but I couldn't pipe it properly like ffmpeg does.. it was funny that I could start vlc just by changing to a channel and maybe worth some fiddling with by someone who does understand piping in VLC so we can use a different encoder too.. but...

WHO CAN HELP ME GET MY RTSP STREAMS WORKING?
Any other stream works nicely btw!

Other references I've tried:
https://github.com/ZoneMinder/ZoneMinder/issues/811
http://ffmpeg.gusari.org/viewtopic.php?f=11&t=853
https://ffmpeg.org/pipermail/ffmpeg-user/2013-November/018641.html
and many more...

Thank you.
 

Nervesagent

Portal Pro
February 26, 2014
150
19
40
Denmark Denmark
Still messing with the rtsp stream... I edited the play service again in an attempt to let vlc do the recoding:
<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd">

<!-- Definition for the simple service. This service can be invoked as
http://vodserver:port/play?input=<input>
<input> can be anything from which ffmpeg can read; a local file, a stream URL, ...
-->
<bean id="/play" parent="paramBuilderServiceBase" class="vodserver.service.CommandRunnerService" >
<property name="command">
<!-- Command used to retrieve the input and perform the transcoding.
See the relevant definitions in vodserver-service-commons.xml
for parameterized values. -->
<value>vlc -I dummy "!!input!!" --sout #transcode

{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=rtp,mux=ts,dst=-} vlc:quit"</value>
</property>
</bean>

</beans>
But now it says it cant open output stream... anybody knows how to pipe the output to the - (or unnamed pipe like ffmpeg does?)
Same problem when I try to use avconv.exe
I'm sure one of the MP devs that worked on timeshift must have an idea?
I can think of many applications for this, like opening an online webpage for a channel guide when tuning to a certain channel...please help.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    @Nervesagent
    I'm sure one of the MP devs that worked on timeshift must have an idea?
    Nope, sorry.
    About all I can see is that the RTSP URLs you're using look like SAT>IP (KABEL>IP) protocol. As such, I'd expect that the stream is an MPEG 2 transport stream... and therefore, it should be directly compatible with the IPTV filter, without the need for this plugin. In short: I don't understand what you're trying to do.
     

    Nervesagent

    Portal Pro
    February 26, 2014
    150
    19
    40
    Denmark Denmark
    @Nervesagent
    I'm sure one of the MP devs that worked on timeshift must have an idea?
    Nope, sorry.
    About all I can see is that the RTSP URLs you're using look like SAT>IP (KABEL>IP) protocol. As such, I'd expect that the stream is an MPEG 2 transport stream... and therefore, it should be directly compatible with the IPTV filter, without the need for this plugin. In short: I don't understand what you're trying to do.
    I tried scanning in an m3u with my streams first but it just gets no signal.. In VLC it plays fine. Is there anything I'm missing? Also manually adding the stream and then previewing it gives me error.. Any log you want me to post?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I tried scanning in an m3u with my streams first but it just gets no signal.. In VLC it plays fine. Is there anything I'm missing? Also manually adding the stream and then previewing it gives me error.. Any log you want me to post?
    Please could you start a new thread (so we don't clog up this thread with non-VODServer posts).

    Edit c:\ProgramData\Team MediaPortal\MediaPortal TV Server\MPIPTVSource.ini and set LogVerbosity to 5.
    Restart the the TV service (TV Server configuration -> manual control -> stop service... then start service).
    Try to scan.
    Cancel after the scan fails for three or four channels.
    In your thread, please attach:
    1. The m3u file you tried to use.
    2. All log files (as always!). You can use the watchdog tool with option 3 to easily get a zip file... or if MediaPortal is not installed
      1. Open TV Server config.
      2. Click open log directory in the top left corner.
      3. Zip all files in that directory.
      4. Attach the zip file.
     

    Nervesagent

    Portal Pro
    February 26, 2014
    150
    19
    40
    Denmark Denmark
    I tried scanning in an m3u with my streams first but it just gets no signal.. In VLC it plays fine. Is there anything I'm missing? Also manually adding the stream and then previewing it gives me error.. Any log you want me to post?
    Please could you start a new thread (so we don't clog up this thread with non-VODServer posts).

    Edit c:\ProgramData\Team MediaPortal\MediaPortal TV Server\MPIPTVSource.ini and set LogVerbosity to 5.
    Restart the the TV service (TV Server configuration -> manual control -> stop service... then start service).
    Try to scan.
    Cancel after the scan fails for three or four channels.
    In your thread, please attach:
    1. The m3u file you tried to use.
    2. All log files (as always!). You can use the watchdog tool with option 3 to easily get a zip file... or if MediaPortal is not installed
      1. Open TV Server config.
      2. Click open log directory in the top left corner.
      3. Zip all files in that directory.
      4. Attach the zip file.
    Cool... thanks.. here's the thread: https://forum.team-mediaportal.com/...nt-scan-fritz-dvb-c-wlan-repeater-m3u.130730/
     

    Waldschrat

    MP Donator
  • Premium Supporter
  • July 18, 2007
    2
    0
    Thanks for this, although I am still having some issues.

    I can get livestreamer to work fine and VOD Server is playing a test file fine but I can't bring them together. Can you give me an example of a stream that you can get to work? Perhaps one from film.on which is what I have been trying.
    I tried filmon as well and could not get it to work. For me it looks like the problem is the output format of the stream which cannot be trancoded by ffmpeg for VODServer. With a newer ffmpeg version I got a lot of aac errors in the VODServer window, but still no luck (so at least some real error messages, not just "Broken pipe" or "Invalid parameter"). Maybe a custom build ffmpeg with a different aac library can help, but I am not really sure.

    Example of a working stream: Any Twitch stream that is currently online (that's what I am using this for).
    So for example the stream that livestreamer also uses as an example (day9tv) can be accessed by http://localhost:9999/livestreamer?stream=twitch.tv/day9tv&quality=best
     

    Nervesagent

    Portal Pro
    February 26, 2014
    150
    19
    40
    Denmark Denmark
    I've been messing with Vodserver and because the ffmpeg had some trouble decoding my rtsp streams I modified the play service so it would first be encoded by vlc and then piped to ffmpeg and then ffmpeg makes it available for MePo through an unnamed pipe. Now I can basically use any stream that I can play in VLC in MediaPortal properly with Timeshift etc..

    The only problem with this i'm facing with this is that I can't get it to run multiple instances or streams at the same time. I think it has something to do with the way the internal services are managed in VodServer. Rewriting the VodServer concept completely from scratch seems like the best idea to me, but that is a little too time-consuming and difficult for me at the moment. Other than my hack to use VLC I wanna try to do a similar experiment using Mencoder, maybe that will solve the multi-instance issue.
    Should I post my findings / vodserver mods to a new thread or keep them in here?
     

    divxmaster

    Portal Pro
    February 15, 2009
    55
    16
    New Zealand New Zealand
    @Nervesagent, I would be interest in seeing your findings.

    - I have just setup vodserver and have noticed some interesting things. I first installed into MP 1.12. Vodserver did not work, streams kept abnormally disconnecting, and then on auto-reconnect it would replay the last 5 seconds over again. I imaged my pc back to MP 1.10, and it all works fine.
    I haven't tried upgrading back to 1.12 yet.

    - MP tv server seems to now support mp4 avc/aac streams as input. I modified vodserver ffmpeg parameter (in vodserver-services-common.xml):
    from -vcodec mpeg2video -s 720x576 -r 25 -flags cgop+ilme -sc_threshold 1000000000 -b:v 2M -maxrate:v 2M -bufsize:v 1.4M -acodec mp2 -ac 2 -b:a
    128k -f mpegts -
    to -codec copy -f mpegts -

    this worked great, with cpu usage at only .1% for vodserver.
    However for some reason the audio only works for mediaportal running on the tv server pc. MP streaming wont send the aac to another client pc.
    so I remodified the ffmpeg parameter to: -vcodec copy -acodec mp2 -ac 2 -b:a 128k -f mpegts -
    which seems to work in all instances. Your webstreams may differ.

    Cheers,
    Divxmaster
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    K 1.25.0 VOD from .m3u playlist. Is possible to watch? watch/edit Videos 7
    E retaining Watch Status when updating? Newcomers Forum 1
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    SpudR Forum Duplicate lines in 'Watched' Website/Forum/Wiki Feedback 2
    TLD Can not watch tv from remote clients Television (MyTV frontend and TV-Server) 19
    R Visual status of watched TV programs MediaPortal 1 Talk 2
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    K sudden complication watching recorded TV Newcomers Forum 6
    R [solved] Watching a record during recording stops sometimes 2.2 Archive 30
    Scheibes Automatischer Serienimport fehlerhaft (Share Watch) Allgemeines Support- und Diskussionsforum 18
    doskabouter Black screen while watching some iptv streams General Support 2
    A Flag Mover: backup and restore watched flags Plugin Development 33
    zunixnuz TV recording is watched state 1.20 2
    A Plugin to transfer watched states between two MP2 installations Archive 47
    CyberSimian MP 1.20: Watched percent sometimes incorrect MediaPortal 1 47
    M partially watched video/song/recorded tv show file text color + remember cursor in folders other features (of release or svn versions) 28
    Alberto83 [no Bug] Watched status not retained when rewatching an episode and stopping. Archive 49
    doskabouter Notification mail for new posts on watched threads Website/Forum/Wiki Feedback 5
    M Recorded TV - Watched status is not updated 1.20 Pre Release 11
    N Can't Watch DVB-T2 Channels General Support 44
    mp2-ulrich [solved] MP2 W10 watching tv not possible General 3
    P Multiple clients - share resume/watched data General 1
    SpudR Custom filter for partially watched movies Moving Pictures 5
    ajs Trakt crashed Mediaportal if no Internet in home lan Trakt 2
    Similar threads

























    Top Bottom