WASAPI not play flac 5.1 music on another HTPC selected BASS, all excellent plays, there is not.

Discussion in '1.7.x' started by ajs, June 21, 2014.

  1. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,699
    Likes Received:
    2,688
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,650 / 30
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Mediaportal 1.7.1, WASAPI, HDMI, Reciever

    WASAPI not play flac 5.1 music. On another HTPC selected BASS, all excellent plays, there is not.
    Stereo flac - work, DTS - work. MP3 - Work

    Settings:
    1.png 2.png


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Helios61
    • Premium Supporter

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Could you please test with Debug Mode, because there are a lot of errors in your log?

    Start -> Team MediaPortal -> MediaPortal -> MediaPortal Debug-Mode

    And please report, with which PC from your SysInfo this issue occures. Is the sound device able to playback 5.1 files. You can check it control panel -> sounds.

    best regards
    Helios
     
  4. HomeY
    • Team MediaPortal

    HomeY Test Group

    Joined:
    February 23, 2008
    Messages:
    6,460
    Likes Received:
    2,627
    Gender:
    Male
    Occupation:
    Network Engineer
    Location:
    ::1
    Ratings:
    +4,737 / 16
    Home Country:
    Netherlands Netherlands
    Show System Specs
    And test with the buffer set to 0.1 - 0.5, since 2.0 seems way too high for WASAPI (at least i was getting strange issues when i have my buffer above 0.5)
     
    • Thank You! Thank You! x 1
  5. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,699
    Likes Received:
    2,688
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,650 / 30
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Ok!

    DTS, Flac 2.0, MP3 - Work with 2 ctr buffer. Why flac 5.1 not?[DOUBLEPOST=1403383401][/DOUBLEPOST]
    333.png

    3
     
  6. CypherMK
    • Team MediaPortal

    CypherMK Test Group

    Joined:
    March 11, 2009
    Messages:
    1,735
    Likes Received:
    297
    Gender:
    Male
    Ratings:
    +617 / 3
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I only get flac 5.1 to work with buffer set between 0.1 and 0.46. Otherwise it won't play with me either. At the moment I have set it to 0.4 for months now, no issues.
     
    • Like Like x 1
    • Great Idea! Great Idea! x 1
  7. CypherMK
    • Team MediaPortal

    CypherMK Test Group

    Joined:
    March 11, 2009
    Messages:
    1,735
    Likes Received:
    297
    Gender:
    Male
    Ratings:
    +617 / 3
    Home Country:
    Netherlands Netherlands
    Show System Specs
    And on a side note. Why don't we remove the buffer setting?
     
  8. Helios61
    • Premium Supporter

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Code (Text):
    1. [2014-06-21 23:34:12,334] [Error  ] [MPMain   ] [ERROR] - BASS: Unable to play M:\Music\Loseless\Yello\2012 - The Best Of\03 - The Rhythm Divine.flac.  Reason: BASS_ERROR_INIT.
    2. [2014-06-21 23:34:12,337] [Log    ] [MPMain   ] [DEBUG] - BASS: Disposing Music Stream M:\Music\Loseless\Yello\2012 - The Best Of\03 - The Rhythm Divine.flac
    3. [2014-06-21 23:34:12,338] [Log    ] [MPMain   ] [INFO ] - g_Player: ended
    4. [2014-06-21 23:34:12,338] [Error  ] [MPMain   ] [ERROR] - PlaylistPlayer: *** unable to play - M:\Music\Loseless\Yello\2012 - The Best Of\03 - The Rhythm Divine.flac - skipping track!
    As HomeY and CypherMK already daid, please try a lower buffer setting. If it doesn't work, could you please provide a sample?
     
    • Like Like x 1
    • Agree Agree x 1
  9. HomeY
    • Team MediaPortal

    HomeY Test Group

    Joined:
    February 23, 2008
    Messages:
    6,460
    Likes Received:
    2,627
    Gender:
    Male
    Occupation:
    Network Engineer
    Location:
    ::1
    Ratings:
    +4,737 / 16
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Same here with 0.1 on a multi-seat setup.

    It seems that other devices or drivers sometimes need a higher buffer.

    No clue, but we know the buffer is a 'tricky' setting:
    http://wiki.team-mediaportal.com/1_MEDIAPORTAL_1/0_What's_New/1.6.x/Known_Issues/Music_BASS_errors
     
    • Thank You! Thank You! x 1
  10. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,699
    Likes Received:
    2,688
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,650 / 30
    Home Country:
    Ukraine Ukraine
    Show System Specs
    • Like Like x 1
  11. HomeY
    • Team MediaPortal

    HomeY Test Group

    Joined:
    February 23, 2008
    Messages:
    6,460
    Likes Received:
    2,627
    Gender:
    Male
    Occupation:
    Network Engineer
    Location:
    ::1
    Ratings:
    +4,737 / 16
    Home Country:
    Netherlands Netherlands
    Show System Specs
    The default buffer after install is set to 0.5 so maybe you changed it a long time ago ;)
    But good to hear it's working now! (y)
     
    • Agree Agree x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!