WebMediaPortal on Windows Server Essentials 2016 - Cannot add ASP.NET Application Pool

Discussion in 'MPExtended' started by Requiem, February 19, 2017.

  1. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +173 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Hi,

    I switched to a Windows Server 2016 Essentials Setup, works fine so far.
    I downloaded IIS edition of WMP 0.6beta, which I had running previously on WHS2011.

    Now, I cannot add the Asp.net application pool to IIS. aspnet_regiis -ir no longer works in IIS 10.x, I googled for it and only found solutions for WSE2012, which tell me to activate it by installing the feature - I have .NET 3.5 and 4.6 installed and also ASP.NET installed, but no ASP.NET Application pool is showing up and I am not offered to add it.

    Can anyone help me, please?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +173 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Did nobody set up IIS version on WSE2016 yet? Any help is appreciated.
     
  4. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +173 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Did nobody set up IIS version on WSE2016 yet? Any help is appreciated.
     
  5. Zoidberg77
    • Premium Supporter

    Zoidberg77 MP Donator

    Joined:
    July 12, 2011
    Messages:
    392
    Likes Received:
    131
    Ratings:
    +178 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Hi Requiem,

    I have IIS Express 7.5 installed and running on my Server 2016 Standard Edition. I can't remember having any trouble.
    I have .net 3.5 and 4.6 features activated, but no asp.net:
    upload_2017-2-25_11-11-33.png

    Though if you're trying to install IIS (not Express) this info may be not helpful... :unsure:
     
    • Thank You! Thank You! x 1
  6. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +173 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Thanks. I just dont want to install IIS Express alongside with IIS but rather integrate WMP into my default Website. Worked fine on WHS2011. I can install ASP.NET etc., but the application pool just won't show up in IIS Manager, no matter what I try.
     
  7. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +173 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Oookay, got it. It's very simple - and very annoying, if you come from the old variants...
    The ASP.net application pool will NOT show up in IIS 10.x, even after you installed .NET, MVC3 and ASP.Net. It is integrated into the standard app pools.
    So, all you have to do: Use the standard app pool (Net 4.0, integrated pipeline) and enable 32 bit applications. Everything works fine, then. *sigh*
    I spent hours and hours on that...
     
    • Like Like x 1
  8. Requiem
    • Premium Supporter

    Requiem MP Donator

    Joined:
    January 1, 2012
    Messages:
    585
    Likes Received:
    80
    Gender:
    Male
    Ratings:
    +173 / 2
    Home Country:
    Germany Germany
    Show System Specs
    One more thing - create a new Application pool. based on .Net4.0 with integrated pipeline.
    If you use the predefined and allow 32 bit applications, the standard WSE Website will not work anymore. If you dont allow them WebMediaPortal will not work. So just use different application pools and allow 32bti applications for WMP only.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!