WebMP 0.5 on Windows 8 (IIS 8) (1 Viewer)

mbuzina

Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Home Country
    Germany Germany
    I am trying to get WebMP working on Windows 8. Initially I had a working Version 0.43 due to my upgrade from windows 7 to 8. Now I installed Version 0.5 and it seems to fail.

    I first tried using IIS 8 Express, it did not work. Now I installed IIS in full and added the WebMP as an Application (I had some issues because I setup the root of the website to be the same as the root of WebMP, that was a mistake).

    Now I get the following error (sorry for the German)
    Code:
    Die Datei oder Assembly "MPExtended.Libraries.Client" oder eine Abhängigkeit davon wurde nicht gefunden. Es wurde versucht, eine Datei mit einem falschen Format zu laden.

    Translation:
    The File or Assembly "MPExtended.Libraries.Client" or a dependency of ti could not be found. A file with the wrong format has been tried to load.

    Any ideas?
     
    Last edited:

    mbuzina

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Home Country
    Germany Germany
    OK, so I enabled dependency tracking and now the error message in full (but German, I don't know how to change that at the moment)

    Serverfehler in der Anwendung /WebMP.

    Die Datei oder Assembly "MPExtended.Libraries.Client" oder eine Abhängigkeit davon wurde nicht gefunden. Es wurde versucht, eine Datei mit einem falschen Format zu laden.


    Beschreibung: Unbehandelte Ausnahme beim Ausführen der aktuellen Webanforderung. Überprüfen Sie die Stapelüberwachung, um weitere Informationen über diesen Fehler anzuzeigen und festzustellen, wo der Fehler im Code verursacht wurde.

    Ausnahmedetails: System.BadImageFormatException: Die Datei oder Assembly "MPExtended.Libraries.Client" oder eine Abhängigkeit davon wurde nicht gefunden. Es wurde versucht, eine Datei mit einem falschen Format zu laden.

    Quellfehler:

    Beim Ausführen der aktuellen Webanforderung wurde einen unbehandelte Ausnahme generiert. Informationen über den Ursprung und die Position der Ausnahme können mit der Ausnahmestapelüberwachung angezeigt werden.

    Überwachung beim Laden der Assembly: Mit folgenden Informationen kann bestimmt werden, warum die Assembly MPExtended.Libraries.Client nicht geladen werden konnte.

    === Zustandsinformationen vor Bindung ===
    LOG: Benutzer = IIS APPPOOL\.NET v4.5
    LOG: DisplayName = MPExtended.Libraries.Client
    (Partial)
    WRN: Für eine Assembly wurden partielle Bindungsinformationen bereitgestellt:
    WRN: Assemblyname: MPExtended.Libraries.Client | Domänen-ID: 2
    WRN: Eine partielle Bindung tritt auf, wenn nur ein Teil des Assemblyanzeigenamens bereitgestellt wird.
    WRN: Dies führt möglicherweise dazu, dass die Sammelmappe eine falsche Assembly lädt.
    WRN: Geben Sie die Textidentität der Assembly mit allen Einzelheiten an.
    WRN: Dazu gehören der einfache Name, die Version und Kultur und das öffentliche Schlüsseltoken.
    WRN: Weitere Informationen und allgemeine Lösungen für dieses Problem finden Sie im Whitepaper unter "http://go.microsoft.com/fwlink/?LinkId=109270".
    LOG: Appbase = file:///C:/Program Files (x86)/MPExtended/WebMediaPortal/www/
    LOG: Ursprünglicher PrivatePath = C:\Program Files (x86)\MPExtended\WebMediaPortal\www\bin
    Aufruf von Assembly : (Unknown).
    ===
    LOG: Diese Bindung startet im default-Load-Kontext.
    LOG: Die Anwendungskonfigurationsdatei wird verwendet: C:\Program Files (x86)\MPExtended\WebMediaPortal\www\web.config
    LOG: Die Hostkonfigurationsdatei wird verwendet: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet.config
    LOG: Die Computerkonfigurationsdatei von C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config wird verwendet.
    LOG: Die Richtlinie wird derzeit nicht auf den Verweis angewendet (private, benutzerdefinierte, teilweise oder pfadbasierte Assemblybindung)
    LOG: Download von neuem URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/webmp/d350100c/d156ab83/MPExtended.Libraries.Client.DLL.
    LOG: Download von neuem URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/webmp/d350100c/d156ab83/MPExtended.Libraries.Client/MPExtended.Libraries.Client.DLL.
    LOG: Download von neuem URL file:///C:/Program Files (x86)/MPExtended/WebMediaPortal/www/bin/MPExtended.Libraries.Client.DLL.
    ERR: Das Setup der Assembly konnte nicht abgeschlossen werden (hr = 0x8007000b). Die Suche wurde beendet.

    Stapelüberwachung:

    [BadImageFormatException: Die Datei oder Assembly "MPExtended.Libraries.Client" oder eine Abhängigkeit davon wurde nicht gefunden. Es wurde versucht, eine Datei mit einem falschen Format zu laden.]
    System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) +0
    System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks) +210
    System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection) +242
    System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +17
    System.Reflection.Assembly.Load(String assemblyString) +35
    System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +122

    [ConfigurationErrorsException: Die Datei oder Assembly "MPExtended.Libraries.Client" oder eine Abhängigkeit davon wurde nicht gefunden. Es wurde versucht, eine Datei mit einem falschen Format zu laden.]
    System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +12761078
    System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +503
    System.Web.Configuration.AssemblyInfo.get_AssemblyInternal() +142
    System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +334
    System.Web.Compilation.BuildManager.CallPreStartInitMethods(String preStartInitListPath) +203
    System.Web.Compilation.BuildManager.ExecutePreAppStart() +152
    System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException) +1151

    [HttpException (0x80004005): Die Datei oder Assembly "MPExtended.Libraries.Client" oder eine Abhängigkeit davon wurde nicht gefunden. Es wurde versucht, eine Datei mit einem falschen Format zu laden.]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +12881540
    System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +159
    System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +12722601


    Versionsinformationen: Microsoft .NET Framework-Version:4.0.30319; ASP.NET-Version:4.0.30319.18010
     

    mbuzina

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Home Country
    Germany Germany
    OK, now I solved that (set to 32 Bit applications, was a bit hard to find in IIS 8).

    Next Problem is the missing System.Web.Helpers
     

    mbuzina

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Home Country
    Germany Germany
    Found it somewhere in old installation cache. Now
    System.Web.MVC
    System.Web.WebPages
    System.Web.WebPages.Razor
    Microsoft.Web.Infrastructure

    Found all these locally and copied them to the bin folder. Now it redirects me to the URL:
    http://localhost:8080/WebMP/Account/LogOn?ReturnUrl=/WebMP

    But the page is empty. On to the next challenge.

    @Oxan: I guess you need to add the DLLs I mention in this post to your deployment package or you need to specify a download location somewhere. I was lucky I found them on my machine in a cached version of the non IIS installer.
     

    Oxan

    Retired Team Member
  • Premium Supporter
  • August 29, 2009
    1,730
    1,124
    Home Country
    Netherlands Netherlands
    You can get the DLLs by just installing ASP.NET MVC 3 (4 probably also works), as is explained in the IIS Guide.

    They're bundled with the IIS Express edition, but not with the IIS edition as people setting it up with IIS should be able to install them by themselves (it's not that hard), and I don't want to force any MVC edition on the experienced people using IIS (who might need another version for another site).

    Also, if you really need them, you can download them from our repository on GitHub.
     

    mbuzina

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Home Country
    Germany Germany
    Thx, I have read the document a few times, but I have obviously overread the section on MVC... :oops:

    Any idea about the empty Account pages? Where should the IIS Version of WebMP place its logs? The logs in the MPExtended Log Directory are not touched.
     

    Oxan

    Retired Team Member
  • Premium Supporter
  • August 29, 2009
    1,730
    1,124
    Home Country
    Netherlands Netherlands
    That might be because the IIS user doesn't have access to that log directory. Try granting full permissions on that directory to the IIS_IUSRS group.
     

    Oxan

    Retired Team Member
  • Premium Supporter
  • August 29, 2009
    1,730
    1,124
    Home Country
    Netherlands Netherlands
    Then it probably means that the error handling in MPExtended isn't even called. Maybe there is something in the Windows event log or IIS error log?
     

    mbuzina

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Home Country
    Germany Germany
    Obviously toying around with it yielded the following:

    RTFM ;-)

    1. Install MP Extended
    2. Install IIS 8
    3. Install MVS 3.0
    4. Setup a site in IIS which does NOT point to WebMP/www
    5. Setup an application that does point to WEbMP/www

    Be done with it ;-)
     

    Users who are viewing this thread

    Similar threads

    Nope that wasnt the trick. Same message, points to the "bass.net" file. Has someone the needed dll. for the bass player in an working envoiroment to share? Needed something working with
    Nope that wasnt the trick. Same message, points to the "bass.net" file. Has someone the needed dll. for the bass player in an...
    Hello, i have an issue when trying to play music in mepo (v1.21) Everything else is working. When i start a song mepo crashes...
    Replies
    2
    Views
    712
    Thank you for reporting your solution. :)
    Thank you for reporting your solution. :)
    Dear community, I used mediaportal 1.12.0 for several weeks with Windows 10 upgrade from Windows 8.1 without problems. Client and...
    Replies
    8
    Views
    3K
    ;)
    ;)
    Hi, running for more than 8 years MP1 without any big problems... When this week windows 10 upgrade came (upgraded from previous...
    Replies
    12
    Views
    3K
    • Locked
    Yes, it will (thanks to @Chris84).
    Yes, it will (thanks to @Chris84).
    Hi, Some of you have reported problems running WebMediaPortal on Windows 8. I've fixes ready for all those bugs, but I'd like to...
    Replies
    2
    Views
    2K
    Problem solved! Thank you for your ideas!
    Problem solved! Thank you for your ideas!
    Today I updated my System from 1.4 to 1.7.1 Hotfix. When I start the Music playing MediaPortal crashes. Here are a part of the...
    Replies
    4
    Views
    1K
    Top Bottom