Win 10 crash, hang and freeze with USB Tuner. (1 Viewer)

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    1,640
    1,233
    Germany Germany
    Country flag
    I use a TBS 5881 usb tuner on my desktop PC. Following the upgrade from Win 1803 to 1809 I have been experiencing various problems all of which can be resolved either by unplugging the tuners usb connection or uninstalling MP. The problems include hanging on boot (continuously rotating dots), random complete freezes, usually shortly after startup (can only be cleared with the power button) and BSODs (DPC Watchdog Violation), these all occur in normal use not with MP running. I have noticed that from say a fresh install of MP1 and TV scan everything seems OK, TV plays EPG (OTA) loads but the problems begin after a restart or logout and login into a different account. Furthermore if I unplug the tuners usb and reconnect it following a Win 10 restart or login it will work fine until the next restart.
    Interesting for other reasons I was running a trial version of JRiver with TV and OTA EPG grabbing setup and had no problems when MP1 was uninstalled. I also tried MP2.2 and suffered the same problems.
    I do have the latest Win 10 drivers for the TSB 5881 installed. Is anyone else using this USB tuner or similar, seeing problems with Win 10 1809 or can suggest how to fix it?
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    You could disabling USB power-off/suspend for the tuner stick (in Device Manager -> properties for the device - untick the 'Allow the computer to turn off...' option):

    upload_2019-3-15_11-47-2.png


    Also try disabling 'USB selective suspend' on Windows power settings:

    upload_2019-3-15_11-48-36.png
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,640
    1,233
    Germany Germany
    Country flag
    Also try disabling 'USB selective suspend' on Windows power settings:
    Many thanks for that I will give it a try but there was no "Power Management" tab for the tuner driver in the Device Manager. I have also tried the bios setting which powers the USB when the PC is shut down but I had the failure with it both enabled and disabled.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,434
    10,256
    France
    France France
    Country flag
    Maybe it's needed to do it on mass storage and/or all mass usb storage :)
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,640
    1,233
    Germany Germany
    Country flag
    Maybe it's needed to do it on mass storage and/or all mass usb storage :)
    Maybe but I do not have any usb storage permanently attached to this PC and all the HDDs have no Power Management options in Device Manager:p.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    these all occur in normal use not with MP running.
    Remember that TV Server (TVService.exe) - which manages the tuners - is always running in the background, even when MP [client/frontend] is not running.

    Have you tried delaying the TV service startup?
    (TV Server Configuration -> General section -> Application tab -> delay in seconds...)
    General Configuration

    Are you using "pause card" or "stop card" for "...when card enters idle state..."?
    TV Servers

    (Stop usually recommended.)

    As a last resort (only! - if both "pause card", "stop card" and startup delay don't help) you could try enabling the "always reset graph after stop" debug option.
    (Start TV Server Configuration with the /debugoptions command line switch; you'll find the setting in the special "Debug Options" section.)

    upload_2019-3-16_9-7-23.png


    upload_2019-3-16_9-7-7.png
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    1,640
    1,233
    Germany Germany
    Country flag
    Have you tried delaying the TV service startup?
    I have now set that for 20 sec and will see how it goes.

    Are you using "pause card" or "stop card" for "...when card enters idle state..."?
    It is set for stop, I am not actually using a card, could never get it working (C1+ here in Germany, TBS do not support it).

    As a last resort (only! - if both "pause card", "stop card" and startup delay don't help) you could try enabling the "always reset graph after stop" debug option.
    Will do if necessary but since disabling the usb selective suspend I have not had any problems yet, that is not conclusive as it can run for several days before blowing up again. I also believe the problem is not confined to Win 10 1809, on 1803 I was also having problems with this tuner, albeit not catastrophic ones, usually fixable by manually stopping and restarting the TV Servervice.

    @mm1352000 good to see you are still around :)(y)
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    but since disabling the usb selective suspend I have not had any problems yet
    I've used a variety of USB tuner sticks over the years, from big brands and no-names, and the only time I've had serious issues with one of them it was related to it not handling 'selective suspend' properly (so it sometimes wouldn't work after a wake from sleep).
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    haaitje Crashes when trying to add lyrics MPTagThat 0
    cerberus Erfahrungsbericht Upgrade Win 10.1909 MP 1.24 Installationsprobleme? 2
    rsbrux Operating System Win 10 vs. 8.1 Operating System 2
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    C DVB-C Empfänger Hauppauge Win TV dual wird in Media Portal nicht aktiviert TV / Streaming 1
    L WinTV HVR 5500 HD mit Win TV V8.5 software findet keine Kanäle 3rd Party Software 0
    joecrow [solved] (Solved) Win 10 1809 Woes General Support 4
    Patrik-See Win 10 Benutzer bei verschiedenen Clients Betriebssysteme 4
    C Ceton InfiniTV Eth first time install on Win 8 Pro Newcomers Forum 12
    S Why open source fails and Integration wins for complex programs General 15
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    T Mediaportal 1.18 on win 10 issue with Kodi as client server General Support 8
    L Service keeps crashing General 3
    U [solved] MediaPortal crashing on startup General Support 10
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    ajs Trakt error when start with MP crash Trakt 1
    R TV server crash with WintTV quadHD General 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    Similar threads

























    Top Bottom